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Fat Segmentation on Abdominal CT 
 

1. Introduction 
This Quick Start guide describes semi-automatic segmentation of abdominal fat and muscle on 

abdominal CT images [1, 2].  

The steps below use the commands under the main menu’s Workflows > CT Abdominal Fat 

Segmentation group and create segmentation masks (ROI layers) with automatically assigned names, 

including: 1) whole fat (total adipose tissue, TAT), 2) subcutaneous fat (subcutaneous adipose tissue, 

SAT), 3) visceral fat (visceral adipose tissue, VAT), 4) muscle, 5) intramuscular fat (intramuscular adipose 

tissue, MAT), as well as auxiliary ROI layers, such as Abdominal Cavity (AC).  

The initial step is the automatic total fat segmentation. The next step is the segmentation of 

subcutaneous and visceral fat (SAT and VAT, respectively), which can also be done automatically. 

Alternatively, this segmentation may be done manually, with the help of a user-defined Abdominal 

Cavity (AC) ROI. Segmentation of subcutaneous, visceral, and intramuscular fat and muscle can also be 

performed using the AC contour.  
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2. Load and display 
images  

To load CT images in the DICOM 

format, start FireVoxel and use 

the main menu to select File > 

Open DICOM Single Document. 

This opens the DICOM Tree 

dialog (Figure 1) that allows the 

user to preview and select images 

to be loaded. Select (click on 

series name) or check (check box) 

the abdominal CT series and click 

Load. This will open the dialog 

titled Load Volume value 

conversion, specifying the 

options for the conversion from 

Hounsfield units (HU) to signal intensity. Accept the default settings, Load as Unsigned Integer Volume. 

Figure 1. The DICOM Tree panel is opened when the user selects File > Open DICOM 
and navigates to a directory containing DICOM images. The list on the left contains 
available images, which are previewed in the top right corner of the panel. 
The bottom right part shows image properties from the DICOM headers.   
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With this transformation, air (-1024 HU or -1000 

HU, depending on the manufacturer) is assigned 

0 grayscale intensity and water is +1024. 

Click OK to load the images.  

Save the document by selecting on the main 

menu File > Save FireVoxel Document. The user 

may wish to save the document after each 

processing step to avoid losing results. 

Images can be displayed in Film view or Slice 

view. To toggle between the views, double-

right-click on the image. In Slice view, use Up 

and Down arrow keys on the keyboard or scroll 

the mouse wheel to scroll through slices.  

To view the layers in the document (essential in this 

procedure), double-left click on the image to open the Layer 

Control panel. After the images are loaded, only the base 

image layer is present.  

3. Segment Whole Fat Mask (current slice) 
Navigate to the slice to be segmented by scrolling the mouse 

wheel or pressing Up and Down arrow keys. The first step is 

the automatic segmentation of the total fat within the slice. 

On the main menu, select Workflows > CT Abdominal Fat 

Segmentation > Segment Whole Fat mask (current slice) 

(Figure 2). This command opens CT Fat Segmentation Dialog 

(Figure 3). Accept the defaults and click OK. This command 

creates two new ROI layers (Figure 4):  

1) auto whole fat slice #[number] – the TAT layer mask, and  

2) auto body slice #[number] – the whole 

body mask (vs background).  

4. Produce Subcutaneous and 
Visceral Fat Masks 

This step automatically separates the total fat 

mask into subcutaneous and visceral fat masks 

(SAT and VAT, respectively).  

Make sure that the base image and the auto 

whole fat slice #[number] (TAT) layer are 

Figure 2. Open Workflows > CT Abdominal Fat Segmentation > 
Segment Whole Fat mask (single slice). 

Figure 3. CT Fat Segmentation dialog with 
default parameters. 

Figure 4. The ROI layers created by Segment Whole Fat mask 
(whole fat mask (red) and body mask (blue, invisible)).   
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checked (visible). Select Workflows > CT 

Abdominal Fat Segmentation > Produce 

Subcutaneous and Visceral Fat Masks (current 

slice). This opens the CT Fat Segmentation 

Dialog. Accept defaults and click OK. During 

processing, the status bar in the lower left 

corner of the software window will show the 

current processing step. When completed, 

the command creates two new ROI layers 

(Figure 5):  

1) auto subcutaneous fat (SAT mask),   

2) auto visceral fat (VAT mask).  

 

5. Segment Abdominal fat using Abdominal Cavity ROI (current slice)  
This step describes a method to create SAT and VAT fat masks with the help of a user-defined 

Abdominal Cavity (AC) ROI layer. Here, this 

method and its results are labeled manual 

segmentation.   

5.1 Define Abdominal Cavity using 
MagTrace 

The Abdominal Cavity ROI may be created 

using the Magnetic Trace tool (MagTrace, Trace 

group). The user draws a MagTrace vector 

contour around the abdominal cavity (AC), 

including the abdominal organs and visceral fat 

inside the contour and leaving the muscle, 

bones, and subcutaneous fat   outside (Figure 

6).  

To start MagTrace, on the main menu, select 

Trace > Start MagTrace. Click along the 

boundary of AC to place about 20 anchor 

points (green circles in Figure 6). Press Esc to 

finish and exit from the MagTrace tool.  

To reposition an anchor point, click the 

contour to display the anchor points, hover 

the mouse over the point and drag it to the 

new location. To add an anchor point, hover 

the cursor over the contour and press Alt+1. 

Figure 5. The ROI layers created by Produce Subcutaneous and 
Visceral Fat Masks (subcutaneous fat (green) and visceral fat 
(yellow). 

Figure 6. MagTrace contour enclosing abdominal cavity. 

Figure 7. Abdominal Cavity ROI layer and Rasterize commands in 
the Vector group. 
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To delete an anchor point, hover the cursor over the point and press Alt+4. To activate the contour click 

on the contour; to deactivate, click anywhere outside the contour. All anchor point adjustments are 

done after exiting from the MagTrace tool.  

Now this vector contour can be used to create a raster ROI layer. Uncheck all ROI layers. With only the 

base image visible, click on the contour to activate it and select Vector > Rasterize selected Vector 

entities. This creates a new ROI layer, named New ROI 3D #[roi number], with the voxels inside the 

MagTrace contour filled with color (Figure 7). Rename this layer Abdominal Cavity (double-click the 

layer name in the Layer Control, type in a new name in the box that opens and click OK).  

Alternatively, the user can first create a new ROI layer (Layer Control > New ROI 3D), rename it 

Abdominal Cavity, make it the active ROI layer, and then use Vector > Rasterize selected Vector entities 

command to create the raster AC ROI in this layer.  

5.2 Define Abdominal Cavity ROI using Paintbrush 
The Abdominal Cavity ROI can also be created using the Paintbrush and ROI tools. Some users may 

prefer this method to using MagTrace. 

Create a new layer (Layer Control > New ROI 3D) 

and rename it Abdominal Cavity. Activate the 

Paintbrush tool by holding down Ctrl key and the 

left mouse and draw a rough contour around the 

abdominal organs. The outside boundary of this 

contour must follow the AC boundary. The shape 

of the inside boundary does not matter. Once the 

contour is completed, release the Ctrl key and 

mouse button. Make corrections using the 

Paintbrush and Eraser (Ctrl + right mouse button). 

Next, on the main menu, select ROI > Fill 2D 

Contours. This command fills the inside of the 

contour and completes the Abdominal Cavity ROI.  

To define the AC ROI for 3D segmentation, the user may use the Paintbrush to draw the perimeter of 

the ROI skipping several slices (e.g., on every 5th slice) and then use ROI > Morphology > Fill 2D 

Contours and Morph Convex to complete the AC ROI. 

5.3 Segment subcutaneous and visceral fat using AC ROI 
Check the boxes next to the base image, auto whole fat slice, and Abdominal Cavity layers.  

Select Workflows > CT Abdominal Fat Segmentation > Segment Abdominal fat using Abdominal Cavity 

ROI (current slice). This command creates two new ROI layers (Figure 8): 

1) manual subcutaneous fat slice #[number],  

2) manual visceral fat slice #[number].  

Figure 8. The ROIs created by Segment Abdominal fat using 
Abdominal Cavity ROI: subcutaneous fat (maroon) and visceral 
fat (dark green). 



FireVoxel QuickStart – Fat Segmentation on Abdominal CT 5 

firevoxel.org   

6. Measure VAT/(SAT+VAT) ratio (current slice) 
This step allows the user to measure the volumes of visceral and 

subcutaneous fat compartments (in cm3) and the visceral fat fraction 

VAT/(SAT+VAT). 

This step will return the measurements for all segmentation layers 

present in the document, both automatic and manual, visible or invisible. 

On the main menu, select Workflows > CT Abdominal Fat Segmentation 

> Measure VAT/(SAT+VAT) ratio (current slice). This opens a dialog 

displaying the results: VAT volume (cm3), SAT volume (cm3), and 

VAT/(SAT+VAT) ratio. If both automatic and manual segmentation ROIs 

are present in the document, the SAT, VAT and VAT fraction are returned for each segmentation type 

(Figure 9). In addition, the relative difference between the automatic and manual segmentation is also 

shown for the volumes and the ratio: |auto - manual|/manual. If layers from only one segmentation 

type (manual or automatic) are present, the results are shown only for that type. 

To copy these results to clipboard, click on the dialog box and press Ctrl+C, then press Ctrl+V to paste 

the results into another application.  

The volumes of each layer in voxels and cubic centimeters can also be obtained by activating the 

corresponding layer and using ROI Stats 3D command on Layer Control.  

7. Single Slice 2D: Segment SAT, VAT, MAT and Muscle using Abdominal 
Cavity contour (MagTrace) 

This step automatically segments muscle and intramuscular fat in addition to the subcutaneous and 

visceral fat using the Abdominal Cavity contour (rather than raster AC ROI layer). 

Check the boxes for base image and 

auto whole fat slice #[number]. 

Make sure that the AC vector 

contour is present. On the main 

menu, select Workflows > CT 

Abdominal Fat Segmentation > 

Single Slice 2D: Segment SAT, VAT, 

MAT and Muscle using Abdominal 

Cavity contour (MagTrace). This 

opens the CT Fat Segmentation 

Dialog (Figure 3). Click OK to accept 

the defaults.  

This commands creates four new ROI 

layers (Figure 10):  

Figure 9. Measure 
VAT/(SAT+VAT) results. 

Figure 10. The ROI layers created by Single Slice 2D: Segment SAT, VAT, MAT 
and Muscle. 
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1) manual subcutaneous fat slice #[number]  

2) manual visceral fat slice #[number]  

3) manual muscle slice #[number] 

4) manual muscle fat slice #[number].  

This command will also show a dialog with the area measurements (in cm2) 

for SAT, VAT, MAT and muscle compartments (Figure 11).  

To copy these results to clipboard, click on the dialog box and press Ctrl+C, 

then press Ctrl+V to paste the results into another application. Then click 

OK to close the results box.  

These results can also be retrieved using Measure SAT, VAT, MAT and Muscle described next. 

The volumes of each ROI can also be obtained by activating each layer, opening Layer Control and using 

ROI Stats 3D. 

8. Measure SAT, VAT, MAT and Muscle 
This steps allows the user to measure and display the areas of the ROIs segmented by the Single Slice 2D 

command (manual segmentation).  

Check the boxes for the base image, manual subcutaneous fat slice #xx, manual visceral fat slice #xx, 

manual muscle slice #xx, manual muscle fat slice #xx.  

Select Workflows > CT Abdominal Fat Segmentation > Measure {SAT, VAT, MAT and Muscle}. The 

information dialog with the area measurements (in cm2) of SAT, VAT, MAT and muscle will be displayed, 

as in the previous step (Figure 11). These results can be copied to clipboard (Ctrl+C) and pasted 

elsewhere (Ctrl+V). 

Note that this command returns the ROI areas rather than their volumes, in contrast to Measure 

VAT/(SAT+VAT command). 

 

Figure 11. Tissue area 
measurements created by 
Single Slice 2D command. 


