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Chapter 1

Introduction

1.1 About

FireVoxel is a Windows-based research software package for analyzing MRI, CT, PET, and SPECT images.
It has been developed by Artem Mikheev and Henry Rusinek at the Department of Radiology, New York
University School of Medicine. FireVoxel provides powerful image processing tools for:

� Loading and displaying images in DICOM or image formats (Analyze, MIDAS, NIfTI, etc.)

� Region-of-interest (ROI) analysis

� Image segmentation

� Motion correction and coregistration

� Modeling and parametric mapping of 4D datasets and dynamic series, including diffusion-weighted
MRI and dynamic contrast-enhanced MRI

� Many other common image analysis tasks and workflows.

1.2 Terms of Use & License

FireVoxel is provided for research purposes only. It is not intended for clinical use. The software
is available free of charge to users at not-for-profit research institutions, including academic, medical, and
independent research centers.

FireVoxel is provided solely for research purposes andmust not be used for diagnosing patients or commercial
activity.

Users who download and install FireVoxel must accept the terms of License Agreement.

1
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1.3 Links and Contacts

� https://firevoxel.org – FireVoxel website – Download the latest software version, obtain instructions for
obtaining the license key, and access software documentation and video tutorials.

� https://iacfvx.blogspot.com – Artem Mikheev’s blog on development news, features, and updates.

� Basic FireVoxel Tutorials YouTube channel – Video tutorials on FireVoxel basic functionality.

� Advanced FireVoxel Software YouTube channel – Video tutorials on advanced topics and workflows.

� For license issues, please contact Henry Rusinek at hr18@nyu.edu.

� For support, please contact artemmikheev@gmail.com.

1.3. Links and Contacts 2
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Chapter 2

Basics

2.1 System requirements to run FireVoxel

FireVoxel runs on 64-bit versions of Windows (Windows 7 and newer). Windows XP and 32-bit Windows
are no longer supported. Mac and Linux are not supported.

FireVoxel requires two Microsoft Visual C++ redistributable packages for Visual Studio. Both of
these packages are necessary.

To check whether they are already installed on your computer, go to Windows Control Panel > Programs
and Features and look for these packages on the list of currently installed programs. These packages can
be accessed via Microsoft Visual C++ support page and installed anywhere on your computer:

� Redistributable for Visual Studio 2015, 2017 and 2019 – On Microsoft Visual C++ support
page, scroll down to “Visual Studio 2015, 2017 and 2019” and download x64: vc_redist.x64.exe.

� Redistributable for Visual Studio 2013 – On Microsoft Update for Visual C++ 2013, select an
appropriate mirror site and download vcredist_x64.exe.

3
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2.2 Installation

FireVoxel is downloaded as compressed (.zip) folder labeled with the build number (e.g., FvxBuild350.zip).
The contents of the file must be extracted to a folder named FireVoxel. The software should not be installed
in the Program Files folder, because Windows protection of Program Files may prevent FireVoxel from
accessing its Temp subfolder.

2.3 Activation

A small file named FireVoxel.key must be individually obtained, as described on FireVoxel website). This
procedure helps to ensure proper use of the software and prevent its unauthorized copying and commercial-
ization. Granting the license key is solely at the discretion of the FireVoxel team.

The license key is unique for a specific computer. If a user who already has a license key installs FireVoxel
on another computer, the user must obtain a new license for this new installation.

2.2. Installation 4
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Chapter 3

Help

This section describes the commands under the main menu’s Help tab, which provides access to basic
diagnostic information about the computer and FireVoxel installation. When images are open in FireVoxel,
this tab also contains the Test operations for pre-release software testing.

3.1 About this Application

Shows dialog with build number, release date, version expiration date, copyright information, contact in-
formation for license requests and support, allocated memory and disclaimer, as well as web addresses of
FireVoxel’s main website, development blog, and LinkedIn group (Fig. 3.1).

Fig. 3.1: About FireVoxel.

5
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3.2 Display current UI configuration

Shows dialog with a snapshot of default folders and current options (Fig. 3.2).

3.3 CPU Info

Shows dialog with information about the computer CPU type and speed and other parameters (Fig. 3.3).

3.4 Test (with images only)

� LOCOI compress

� EquiNet: Denoise Volume

� Compress Volume EquiNet

� Compress Volume NLM

� Ynet Compression

� Trivial interslice compression

3.5 Memory Leak Report (without images)

3.2. Display current UI configuration 6
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Fig. 3.2: Display current UI configuration.

Fig. 3.3: Display CPU info.

3.5. Memory Leak Report (without images) 7



Chapter 4

Interface and User Actions

� Open FireVoxel

� Main window, menu, and document windows

� Close FireVoxel

� User Interface Options

� Mouse and keyboard actions

� Commands, parameter panels, and dialog

FireVoxel’s graphical user interface allows user to access commands and tools. This chapter describes the
interface elements and the main user actions. The appearance and functionality of the interface can be
adjusted using File > User Interface Options.

4.1 Open FireVoxel

To open FireVoxel, double-click FireVoxel.exe (in FireVoxel directory). Alternatively, create a desktop
shortcut and double-click it.

4.2 Main window, menu, and document windows

Launching FireVoxel opens the main software window (Fig. 4.1). It contains the main menu (in the top
left corner), status bar (bottom left, reads Ready in Fig. 4.1), main toolbar (right, inactive), and mini-
mize/maximize/close buttons (top right).

The main menu contains commands grouped by themes and tasks and has three levels: tabs, commands,
and subcommands. Commands are activated by clicking the menu tab name, scrolling down to select the

8
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Fig. 4.1: FireVoxel’s interface without images.

4.2. Main window, menu, and document windows 9
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command and clicking it. If commands have subcommands, these subcommands will be shown as a secondary
menu when the command is clicked. To use a subcommand, select it and click its name.

The main menu tabs and the commands available within these tabs are different depending on whether any
images are open in FireVoxel.

When no images are open in FireVoxel, the main menu contains five tabs: File, Applications, Dynamic
Analysis, View, and Help (Fig. 4.1). The commands available without images are used mainly for software
testing and batch processing. The main toolbar , if displayed, is grayed out and not functional. The visibility
of the toolbar is toggled using View > Show Main Toolbar .

When images are open, the main menu shows the full set of tabs: File, Volume, ROI, Vector, Transform,
Nonuniformity, Register, Segment, Trace, 4D Processing, Workflows, Measure, View, and Help
(Fig. 4.2). The document name is shown in the blue title bar. The main toolbar becomes functional. The
status bar shows the cursor coordinates and other information. In Fig. 4.2, the status bar reads ROI=OFF,
xyz=[145.491,2.418,40) (left kidney).

Fig. 4.2: FireVoxel’s interface with an image displayed in a document window.

Images are displayed in document windows. Each document window is labeled with a name in the blue title
bar and minimize/maximize/close buttons. The images are aligned left, and extra space is filled with a solid
background color, which can be customized (see Document background).

4.2. Main window, menu, and document windows 10
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Multiple document windows may be opened at once. Each window must have a unique name. An attempt
to open two document windows with the same names triggers an error message.

4.3 Close FireVoxel

To close FireVoxel, select File > Exit. If any open documents contain unsaved changes, a file-save dialog
will be shown prompting the user to save these documents, or discard changes, or cancel exiting.

The software can also be closed by clicking the cross in the upper right corner of the main software window.
Again, the user will be prompted to save or discard any new changes to the currently open documents, after
which the software will be closed.

4.4 User Interface Options

FireVoxel’s user interface can be customized using File > User Interface Options. This command opens
a dialog where the user can adjust various parameters that control the appearance and functionality of the
interface (Fig. 4.3). The changes of appearance are applied immediately. The changes of functionality are
applied after the user closes and reopens FireVoxel.

4.4.1 Temp folder

Shows the current location and size of FireVoxel’s Temp folder. The user can type in a path to a different
folder or browse to folder to select it. Clear button deletes the contents of the Temp folder. The location of
the Temp folder is also shown in Help > Display current UI configuration.

4.4.2 Interface color scheme

Offers a dropdown menu with a selection of color schemes: Basic (default), Aqua, Luna Blue, Obsidian,
Silver. The schemes alter the color of the main software window, main toolbar , and bottom information bar.
Changes are applied immediately.

4.4.3 Document background

Opens a color picker for selecting the padding color of the document windows (the color that fills parts of
the window not occupied by the image). The default color in the basic color scheme is moderate blue HEX
6060c0 (RGB [38, 38, 75], RGB decimal [96, 96, 192], CMYK [50, 50, 0, 25], Hue/Sat/Lum 160/104/136).

4.3. Close FireVoxel 11
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Fig. 4.3: User Interface Options dialog.

4.4. User Interface Options 12
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4.4.4 Main toolbar alignment

Opens a dropdown menu with a selection of positions where the main toolbar is docked: Left, Top, Right
(default), Bottom. The change of position is applied immediately. If a toolbar is undocked and then docked
again, it is docked at the position specified by this option.

4.4.5 Display

Initial layout

Opens a dropdown menu with options for the initial layout: FilmView (default), Single Slice, and Axial,
Sagittal, and Coronal projections. The option is applied upon the next loading of images into FireVoxel. The
option does not affect previously saved FireVoxel documents, which are opened in the saved view.

View Convention

Opens a dropdown menu with options for image orientation: Radiological (axial images are shown with
patient’s left side on the right side of the image); Neurological (left side on the left); or Original Data
(orientation follows the convention of the original data).

Images in NIfTI-1 format with sform and qform entries are displayed as prescribed by their header entries.
Images in NIfTI-2 format are not compatible with FireVoxel.

Use Interpolation

Checkboxes for selecting the types of layers and views shown with interpolation. Options include Volumes
(checked by default), ROIs (unchecked), Real-valued volumes (checked), and Film View (unchecked). Inter-
polation makes images appear less grainy.

Patient Orientation

Checkbox (checked by default) toggling the visibility of green letters indicating patient orientation: R (right),
L (left), A (anterior), P (posterior), H (head), F (feet).

4.4.6 Volumetric Cursor

Opens a dropdown menu with options for the cursor behavior on orthogonal projection views of the same
image (see Toolbar > Display orthogonal projections):

1. Multiprojection Synchronize on left mouse click (default): Left mouse click on any of the three
projections forces the other two views to display the current cursor position on each of these projections.
The cursor is shown as a cross indicating the intersection of the other two orthogonal planes.

2. Regular: Allows the three projections to be displayed independently, without sensitivity to the mouse
clicks or the current position of the cursor. Each orthogonal projection can be scrolled separately,
without affecting the other two views.

4.4. User Interface Options 13
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4.4.7 Automatically tile all views when a document is loaded

Checkbox (checked by default) controlling the arrangement of document windows. When checked, has the
effect of View > Tile after a new document is loaded (Fig. 9.2).

4.4.8 Specify missing modality when loading volumes

Checkbox (checked by default). ADD DETAILS

4.4.9 Load Dynamic Modelling settings from FVX file

Checkbox (checked by default) to toggle on and off the loading of dynamic modeling parameters from a
FireVoxel document (*.fvx). When the user opens a FireVoxel document that contains parametric maps
generated with Dynamic Analysis models, the free parameters in the document are compared to the
model parameters in the current configuration of FireVoxel. If these two sets of parameters do not match, a
warning is shown: Loading [ *.fvx name] (Model #): Saved number of Free Params differ from
current Model. The document is loaded after the user clicks OK on the warning dialog. The mismatch may
arise, for example, because the dynamic models in FireVoxel were updated since the maps were generated in
the user document.

4.4.10 Default volume transform interpolation

Opens a dropdown menu with a selection of interpolation methods applied to the layers and views checked
in the Use Interpolation section. The options include Nearest neighbor, Tri linear (default), Wsinc2, Wsinc3,
and Wsinc4. The interpolation method may be chosen to match the imaging modality (e.g., Tri linear for
CT or Wsinc for MRI).

4.4.11 Compression

Losslessly Compress DICOM file when saving (JpegLS)

Checkbox (unchecked by default) to toggle on and off the compression of DICOM files upon saving them in
lossless JPEG format (JPEG-LS).

The information on image compression can be found by loading the images into FireVoxel using File > Open
DICOM and examining the DICOM header entries in lower right part of the DICOM Tree dialog .

The compression data is recorded in the field (0002,0010) Transfer Syntax UID, part of the Pixel Data
module. See available options in DICOM PS3.18 2022b > 8.7.3 DICOM Media Type Sets.

After the images are loaded into FireVoxel, the Pixel Data module is removed and Transfer Syntax is no
longer displayed as part of the image information (see Layer Control > Info).

Example (Fig. 4.4): The header of a compressed image shows Transfer Syntax: JPEG Lossless, Non-
hierarchical, 1st Order Prediction.

4.4. User Interface Options 14
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Fig. 4.4: DICOM Tree header preview for a compressed image: Transfer Syntax - JPEG Lossless.

For uncompressed images, this field typically reads: Transfer Syntax: Little Endian Explicit (Fig. 4.5).

Note:
Compression may interfere with some processing operations. Compressed images are becoming more
common, especially since PACS increasingly apply compression to exported images by default. Users
are urged to consider whether analyzing compressed images may affect their processing results.

To convert compressed images into uncompressed images:

1. Load DICOM images into FireVoxel (see File > Open DICOM ).

2. Verify the compression format during loading (JPEG-LS or similar).

3. Open File > User Interface Options and make sure that the Lossless Compression option is
unchecked.

4. Save images in the active layer as DICOM (see Save Active Layer as DICOM ).

4.4. User Interface Options 15
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Fig. 4.5: DICOM Tree header preview for an uncompressed image: Transfer Syntax - Little Endian Explicit.

RAM Compress Integer volumes

Checkbox (checked by default) to toggle on and off the RAM compression for integer volumes (typically,
acquired images, such as MRI, CT, PET, etc.).

By default, images (volumes) are compressed to save RAM. Each slice of the volume is compressed separately
using three-voxel predictive coding combined with the Huffman entropy encoder. The compressed size of the
entire volume is thus the sum of the sizes of individual slices. See Volume > Window Center/Width
setting > Timepoint of Maximum Info for details of the compressed image size in relation to the image
information.

To use the uncompressed internal representation, uncheck this box. In this case, all images will contain the
same amount of information.

4.4. User Interface Options 16
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RAM Compress Real volumes

Checkbox (unchecked by default) to toggle on and off the RAM compression for real volumes (i.e., usu-
ally computed images, such as parametric maps and results of various analytical operations). To use the
uncompressed internal representation, uncheck this box.

4.5 Mouse and keyboard actions

The mouse and keyboard actions described below are employed to interact with FireVoxel’s user interface.
Note that these actions refer only to a typical two-button mouse (with an optional scroll wheel), as FireVoxel
is a Windows software.

Click – Single left mouse click, unless specified otherwise. Used to open menus and select commands or
launch commands via the main toolbar icons.

Double-click – Double-left mouse click.

Right-click and double-right click – Right mouse click, single or double.

Scroll – Turn the mouse up or down. May be used for, e.g., navigating through the slices of a 3D or 4D
image.

Click and drag – Left-click and hold down the left mouse button and move the mouse. Used, e.g., to draw
vector ROIs and move anchor points on a vector contours.

Right-click and drag – Click and hold down the right mouse button and move the mouse. Used, e.g., to
move a vector contour as a whole.
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Hover – Hold the cursor over an object.

Ctrl + left mouse button – Press and hold down the Control key while pressing the left mouse button
and moving the mouse. Used to draw raster ROIs.

Ctrl + right mouse button – Press and hold down the Control key while pressing the right mouse button
and moving the mouse. Used to edit raster ROIs.

Up and Down arrow keys – Pressing the Up and Down arrow keys on the keyboard is used to navigate
through slices of a 3D or 4D image (similar to Scroll).

Right and Left arrow keys – Pressing the Right and Left arrow keys on the keyboard is used to navigate
through the images along the dynamic dimension of a 4D (dynamic) dataset, such as the different time points
in dynamic contrast-enhanced MRI or CT, or b-values in diffusion-weighted MRI.

Esc – Esc key is used to exit various tools, such as the MagTrace tool and most of the toolbar tools.

4.6 Commands, parameter panels, and dialog

The user interacts with FireVoxel through commands, toolbar icons, as well as the mouse and keyboard
actions. FireVoxel often interacts with the user through the Image Processing Dialog .

4.6.1 Commands

Some FireVoxel commands are executed immediately after being called, for example, after the user selects
a command from the main menu. Such commands do not require additional input from the user. Other
commands launch standard browse-for-file, browse-for-folder, or file-save dialogs to select a directory and/or
file.

Still other commands open dialog panels that allow the user to configure the command by selecting its
parameters and options. The dialog panels may range from simple ones with one or few parameters (for
example, Specify Integer) to complex panels with multiple parameters and options (such as Dynamic
Analysis > Calculate Parametric Map, or Segment > EdgeWave Basic). In this case, processing usually
starts when the user clicks OK on the dialog.

Some dialog panels combine sections that display interactive information with sections that enable user
actions. An example of such command is Open DICOM , which opens the DICOM Tree dialog dialog that
contains sections that display the DICOM structure of a selected directory, DICOM header information,
image preview, and functionality enabling access to various commands.
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4.6.2 Image Processing Dialog

FireVoxel displays Image Processing Dialog to convey information in response to some user actions, to send
an error message or a warning, or to display results. Common examples of this dialog include:

� [Image of a certain type] required (Fig. 4.6). An error message to notify the user that the command
was applied to an image incompatible with this command’s requirements. For example, if Dynamic
Max is applied to a 3D image, the dialog will notify the user that 4D volume is required. The user may
need to select another layer in the document and consult this reference for the image type required by
the given command.

Fig. 4.6: Error of wrong image type.

� Ambiguous layer configuration (Fig. 4.7). This message usually appears after a command is called,
but it can be applied to two or more layers in the document. To resolve the ambiguity, the user needs to
examine the layers in the Layer Control and uncheck (make invisible) those layers that are not involved
in the current operation, or select an appropriate layer as the active layer.

Example in Fig. 4.7 shows this error when ROI Stats 3D is called. The ROI layer (brain mask) is the
active layer, but there are two other layers – the image layer (DICOM2_perfusion) and the T1-map –
to which this command may be applied. To avoid this error, the user may uncheck the visibility of all
layers except those to which ROI Stats 3D should be applied.

� Results (Fig. 4.8). Some commands return numerical results of measurements or computations in
the form of the Image Processing dialog. These results can be copied to Clipboard (Ctrl+C) and
pasted elsewhere (Ctrl+V). Example in Fig. 4.8 shows the results of measurements of subcutaneous
and visceral fat segmented on CT.

� Confirmation dialog (Fig. 4.9). Many commands underDynamic Analysis > Calculate Parametric
Map that perform voxel-by-voxel processing show a confirmation dialog after the user clicks Process
All or Process ROI only.

The confirmation dialog summarizes the operation setup (including model, outputs, processing mode,
critical options, active layer) and asks the user whether to proceed with the analysis. This step allows
the user to verify whether important and computationally “costly” processing steps are configured
correctly before launching a potentially time-consuming task.
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Fig. 4.7: Error when a command may be applied to more than one layer.
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Fig. 4.8: Dialog returning measurement results.

Fig. 4.9: Confirmation dialog before starting voxel-by-voxel analysis.
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Chapter 5

Toolbar

� Toolbar visibility and position

� Toolbar icons

� Undo / Redo

5.1 Toolbar visibility and position

The visibility of the main toolbar (Fig. 5.1) is toggled on and off using View > Show Main Toolbar .

By default, the main toolbar is docked on the right-hand side. To select a different toolbar docking placement,
use File > User Interface Options > Main Toolbar Alignment . The position of the toolbar is changed
immediately after this option is changed in the User Interface Options.

When using FireVoxel on a laptop with a small screen, it is recommended to dock the toolbar at the bottom
of the software window or leave the toolbar undocked, to have easy access to all toolbar icons.

The toolbar can be undocked by hovering the mouse over its top edge (if the toolbar is docked on the right or
left) or over its leftmost edge (if the toolbar is docked at the bottom). When the cursor becomes a 4-arrow
cross, the user may click and drag the toolbar to a new location. An undocked toolbar can be positioned
anywhere on the screen, inside or outside FireVoxel’s main software window.

To dock the toolbar, double-click its blue title bar. The toolbar will return to its docking position indicated
in the User Interface Options.

Fig. 5.1: Main toolbar.
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Each icon on the toolbar launches an individual tool. With few exceptions, most of these tools duplicate the
commands that are available via the main menu.

To exit from the tools such as Zoom or Change Width/Level, press Esc.

If the tool opens a dialog (e.g., Calculate Parametric Map or EdgeWave Segmentation), click OK on
the tool dialog to start processing or Cancel to exit from the tool.

5.2 Toolbar icons

Change Width/Level

Zoom by window selection

Zoom All and fit to View

and Zoom in and Zoom out with fixed upper corner

View Projection of Selected Entity

Play 4D Experiment

Voxel Time Activity Curve Browser

Construct Vector ROI

Insert Polyline

Insert Text - Currently inactive

Voxel Paintbrush settings

EdgeWave Basic

Calculate Parametric Map

5.2. Toolbar icons 24



FireVoxel: User Manual, Draft 2025-04-29

Display orthogonal projections

Magnetic Trace

Rasterize selected vector entities

Undo – Active for selected commands that change voxel values in the active layer.

Redo – Becomes active after Undo is used.

5.3 Undo / Redo

Undo and Redo features are available via the main toolbar icons. These features are inactive (grayed out:

/ ) for most commands.

These features become active ( / ) for some of those commands that change the voxel values in
the active layer without creating a new layer or document window.

The features do not apply to commands that create new document windows and layers, or create or edit
raster ROIs, vector ROIs, or contours.

Several such commands can be found in the Volume > Voxel value conversion > Linear conversion over
ROI OR Invert .

The Undo/Redo functionality is illustrated here using Invert as an example:

1. Original image – When the original (Dixon) image is opened in FireVoxel, the Undo/Redo features
are inactive.

2. Inverted image – Select Volume > Voxel value conversion > Invert . The image is inverted and the
histogram is flipped around the middle of the interval. Undo feature becomes active. Redo remains inactive.

2. Undo Invert – Click Undo . The kidney image is restored to its original state (before Invert
was used) and the histogram is again flipped. The Undo is now inactive, but Redo becomes active.
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Fig. 5.2: Original image and histogram. Undo/Redo inactive.

Fig. 5.3: Result of Volume > Invert. Undo active/Redo inactive.
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Fig. 5.4: Result of Undo command. Undo inactive/Redo active.

3. Redo Invert – Click Redo . The image is inverted again, as after the first Invert (Fig. 5.3).
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Chapter 6

Open

� File types

� Open FireVoxel Document

� Open FireVoxel Folder (without images)

� Open Image

� Open TAC as 4D

� Open DICOM

– DICOM Tree Dialog

– Open DICOM folder: Single Document

– Open DICOM folder: Multiple Documents

– DICOM > Open selected SERIES

– Opening CT images and value conversion

� [Recent documents]

This chapter describes commands for loading images and data into FireVoxel grouped under the main menu’s
File tab.

Commands for preliminary processing of DICOM files (such as de-identification and sorting DICOM tree by
folders) are described in De-identification and DICOM Operations.
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6.1 File types

FireVoxel operates with the following data types:

� 3D images (volumes) created by MRI, CT, PET, SPECT, and ultrasound;

� 4D datasets – Dynamic series of 3D volumes (dynamic contrast-enhanced MRI or CT, diffusion-weighted
MRI, dynamic PET, etc.);

� 3D or 4D regions of interest (ROIs) – Segmentation masks;

� Vector ROIs and vector contours (e.g., MagTrace).

The following file types can be opened in FireVoxel:

� FireVoxel documents (*.fvx);

� DICOM files and directories (*.dcm, *.ima, etc.);

� Image formats – Midas, ANALYZE, NIfTI, FreeSurfer, and RAW 4D (*.im, *.img, *.nii, *.nia, *.nii.gz,
*.mgh, *.mgz, *.time).

The following files may also be created by FireVoxel’s commands and may be opened in a text editor, such
as Notepad:

� .vroi – Vector ROI – See Save VROIs;

� .vtf – Volume Transform File – See Transform using VTF file;

� .txt files such as:

– statistics within ROI – See ROI Stats 3D ;

– time-activity curves within ROI – See ROI Stats 4D ;

– radiomics results.

6.2 Open FireVoxel Document

Open browse-for-file dialog to open a FireVoxel document (.fvx). The selected document will be opened in a
new document window.

6.3 Open FireVoxel Folder (without images)

Open automatically all FireVoxel documents in a folder. This command is available when no images are open
in FireVoxel and is used mainly for batch processing.
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6.4 Open Image

Opens browse-for-file dialog to select a file in one of the image formats including Midas (*.im), ANALYZE
(*.img), NIfTI (*.nii, *.nia, *.nii.gz), FreeSurfer (*.mgh, *.mgz), or RAW 4D (*.time). The selected image
is opened in a new document window.

6.5 Open TAC as 4D

Opens browse for file dialog to load a .txt file. After the file is selected, TAC Volume attributes dialog is
opened with the boxes for width, height, depth, and noise level (%). After the user clicks OK, the next dialog
offers a choice of modality: MR, CT, PET, or US. Next, the result is displayed in a new document window.

6.6 Open DICOM

The Open DICOM (Single Document or Multiple Documents) commands open browse-for-folder
dialog to select a directory with DICOM images. The directory may contain multiple subdirectories. Once
the user selects the directory, FireVoxel opens the DICOM Tree dialog (Fig. 6.1).

6.6.1 DICOM Tree Dialog

The DICOM Tree dialog shows images organized by PATIENT ( ), STUDY ( ), and
SERIES.

SERIES may be one of four types (each labeled with a corresponding icon):

� S (slice, ) - A series of 2D images;

� SL (slice list, ) - A dynamic series of slices;

� V (volume, ) - A 3D image;

� VL (volume list, ) - A dynamic series of volumes.

User may mark entries in the DICOM Tree by checking or selecting them. To check, check the box next
to Series or Image name to select one or several entries. To select, click the Series or Image name, and the
selected object will be highlighted with a red box, one at a time. By default, when the DICOM Tree is
opened, the entire Series is selected.

The DICOM Tree dialog contains the following parts:

� [Select images to load]:

Browse - Browse for folder to select a DICOM directory.

Refresh - Reload the directory displayed in Current Directory box.
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Fig. 6.1: DICOM Tree dialog allows the user to examine, preview and select images.

Current Directory - The contents of the directory displayed in the DICOM Tree.

Only series containing (filter) - Type keyword(s) to select only series with names containing these
keywords. To display filtered DICOM Tree results, click Refresh. Example (Fig. 6.1): Entering VIBE
will select series titled Axial T1 VIBE. . . , VIBE DIXON. . . , Perf VIBE. . . , etc. To display the
full DICOM Tree, delete the keywords and click Refresh again.

Use Series UID - Toggles on/off using series unique identifier for sorting ((0020,000E) Series Instance
UID). Series Instance UID is a non-human-readable identifier that “guarantee[s] uniqueness” of all
instances of this Series and distinguishes them from all other series, “across multiple countries, sites,
vendors and equipment.” Each UID consists of two parts an <org root> and a <suffix>: UID = <org
root>.<suffix>. The <org root> “1.2.840.10008” is reserved for DICOM defined items. See more on
UIDs at DICOM Part 5, Chapter 9: Unique Identifiers.

� Description – PATIENT/STUDY/Series title, series number, dimensions (width (W) x height (H) x
depth (D) x N (dynamic dimension)), image time (start and end), and echo time. The series number
for SL and VL shows the numbers of the first and last series of the list: [First, Last].

The width (W) and height (H) are the in-plane image dimensions in voxels. The depth (D) is the
number of slices (D=1 for S and SL). The dynamic dimension N is provided for slice lists (SL) and
volume lists (VL). For example, for dynamic contrast-enhanced MRI, N would represent the number
of time points; for diffusion-weighted MRI, N would stand for the number of b-values, etc.

� [Preview window] [top right] – Displays selected image (or the default image if Series is selected).

� [Header information] [bottom right] – Displays selected DICOM header information (by default), or
full info (if Full Info box is checked).
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– Full Info – Checkbox to toggle on/off between displaying full DICOM header information when
checked, or only selected fields when unchecked (default). The on/off selection does not affect the
information used by Compare command.

– Compare – Enables comparison of DICOM headers of two checked images (2D images, not
volumes). Opens a text file (default: Notepad) with a list of pairs of DICOM fields that differ
between the two images.

� Actions – Load / Copy / Delete / Show Compatible Volumes / Check Subtree / Check Range /
Uncheck All / Set b-value / (x, Cancel Open).

– Load – Load series and display in a new document window.

Note: Layer Control > Load DICOM enables loading DICOM images as new layers in an
existing document window. The matrix and voxel size of the loaded images must be the same as
those in the original document window.

– Copy – Open browse for folder dialog to copy marked series or images to the selected folder.

– Delete – Delete marked images from the DICOM directory. The command has a failsafe dialog
(Some images will be deleted). NOTE: When the user clicks Yes, the images are
permanently deleted from the source folder. Select No if in doubt.

– Show Compatible Volumes – Shows only volumes with the same dimensions and resolution as
the selected image. These images can be opened in the same document window.

– Check Subtree – Checks boxes next to all entries on a level below the selected/current entry
(i.e., if a PATIENT is selected, all STUDIES grouped under this PATIENT will be checked; if a
STUDY is selected, all VL (volume lists) under this study will be checked, etc.).

– Check Range – Enables checking boxes for a range of entries under the currently selected entry
(i.e., a range of STUDIES under PATIENT, or a range of SLICES under VOLUME). Opens dialog
(Specify descendant range in [range] to enter Range start and Range end indices between
which the boxes will be checked. Indices start at zero (first entry has index=0).

– Uncheck All – Uncheck all entries.

– Set b-value - Opens dialog (Specify b-value (sec/mm^2)) to enter a b-value for the marked
diffusion-weighted MR image. Populates DICOM field (0018,9087) DiffusionBValue with the user-
entered value. See Diffusion b-value Attribute: (0018,9087). This option is needed to enter the
b-values manually when they cannot be automatically read from the DICOM headers. The b-
values may also be stored in private fields, such as (0019,100C) for Siemens images. NOTE:
The b-value header field is modified once the user clicks OK on the dialog. Even if the user then
cancels loading images, their DICOM headers will retain the user-entered b-values.
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6.6.2 Open DICOM folder: Single Document

Opens browse-for-folder dialog to select a directory with DICOM images. Once the user selects the directory,
the command opens DICOM Tree dialog, showing the structure of exams in this directory. The directory
may contain multiple subdirectories, with images from different patients, exams, modalities, etc. FireVoxel
will infer the DICOM Tree structure from the DICOM headers, as long as these headers can be correctly
interpreted by the software.

The user then selects images (studies, series, or individual images) to be loaded and displayed in a single
document window. After the user clicks Load, the DICOM Tree dialog is closed, and the images are loaded
and displayed in a document window.

Only images with compatible parameters (the same width, height, and depth dimensions and
resolution) can be loaded in the same document window. If the selected images have incompatible
parameters, an error message is shown and loading images is canceled (Selected SERIES depth differ >
Loading DICOM Failed).

To select multiple image series with disparate parameters and open them in different document windows, use
the next command (Open DICOM folder: Multiple Documents).

If your images are not displayed correctly, please report this issue to the FireVoxel team.
Problems with image loading sometimes arise from the variations of the DICOM format among imaging
platforms. In many cases, these issues can be fixed promptly, especially if the user provides the developers
with sample images (preferably de-identified).

6.6.3 Open DICOM folder: Multiple Documents

This command enables opening several image series, each in its own document window, from the DICOM
Tree, without the need to use Open DICOM folder: Single Document multiple times.

Opens browse-for-folder dialog and allows the user to select a DICOM directory. Once the directory is
selected, opens the DICOM Tree dialog. The user selects images (studies, series, etc.) and clicks Load.
Selected images are displayed in a new document window (provided images have compatible dimensions).

After the images are loaded, the DICOM Tree dialog remains open. The user may select more images and
click Load again. These new images are displayed in another document window. The user may repeat
selecting images and loading them multiple times, each time creating a new document window.

See View for how to adjust the way the images are displayed and how to navigate through different slices
and dynamic frames.

6.6.4 DICOM > Open selected SERIES

Custom option for select users (mainly on GE platform).

Opens browse-for-folder dialog to select a DICOM directory. Displays simplified DICOM Tree dialog showing
sorting as PATIENT > STUDY > SERIES > IMAGE (Fig. 6.2).
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Fig. 6.2: DICOM > Open selected SERIES opens simplified DICOM Tree.

Allows the user to select specific image series and load it in a document window. Open selected SERIES
does NOT form high-level 3D and 4D entities, as is done by File > Open DICOM folder command (Fig.
6.3).

Fig. 6.3: Open DICOM folder opens full-feature DICOM Tree.
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6.6.5 Opening CT images and value conversion

CT images in DICOM format may be opened in FireVoxel as real-valued volumes with voxel values expressed
in CT numbers (Hounsfield units (HU)) or as integer grayscale volumes. When the user selects the images
in the DICOM Tree and clicks Load, FireVoxel determines the initial import settings based on the DICOM
header data. If the selected series includes CT images, the user will be prompted to choose the value
conversion option (Load Volume value conversion dialog, Fig. 6.4) between loading the images directly,
without converstion (in HU) or after conversion to grayscale intensity values.

If the user selects the option to Load as Real Valued Volume (upper radio button in the dialog in Fig.
6.4), the images are loaded as CT numbers (HU). In this case, voxel values may take both positive and
negative real values that are displayed as a color map.

Fig. 6.4: The Load Volume value conversion dialog by default offers conversion from HU to grayscale values.

The default option is set to Load as Unsigned Integer Volume (lower radio button in Fig. 6.4). In this
case, FireVoxel converts the original CT voxel data expressed in HU (Voxel_HU) into non-negative integer
intensity values (Voxel_Intensity) according to the rule:

Voxel_Intensity = Voxel_HU x multiplier + offset.

FireVoxel determines the default multiplier (Multiply by) and offset (Add) from the following DICOM
header fields:

(0028,1052) Rescale Intercept – The air value corresponding to zero intensity (typically -1000 HU
or -1024 HU, depending on the hardware manufacturer);

(0028,1053) Rescale Slope (Slope=1);
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(0028,1054) Rescale Type (HU).

For details on viewing options for CT images, see Grayscale Window and ViewFilter sections.

For converted images, FireVoxel displays both the signal intensity (SI) and the HU values at the current
cursor position in the status bar in the lower left corner of the software window (Fig. 6.5).

Fig. 6.5: Status bar shows voxel signal intensity (SI) and CT Hounsfield units (HU) in dense bone.

6.7 [Recent documents]

The lower portion of the File menu contains a list of recently saved documents and images. Selecting files
from this list allows the user to quickly reopen these files. If a file has been moved or deleted, a warning is
shown that the file cannot be found.
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Chapter 7

DICOM Operations and De-identification

� De-identification

– Customize de-identification profile

� DICOM Operations

– Show PHI profile

– De-identify DICOM folder

– De-identify document

– Split multiframe DICOM file

– DICOM folder total Pixel Element size

– Minimize DICOM headers in Current Document

– DICOM Tree to folders

– Open selected SERIES

Several DICOM operations are available under File >DICOM (command group). These commands include
tools for de-identification (anonymization) of DICOM images, as well as commands for manipulating DICOM
files and folders.

The selection of available DICOM commands depends on whether any images are open in FireVoxel. Some
commands are always accessible and other commands are available only with or without images open.

Note: DICOM > Open selected SERIES is described in the Open section.
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7.1 De-identification

Patient privacy rules and research regulations often require that research data be de-identified (anonymized).
FireVoxel offers its users broad discretion over de-identification of images. Users are able to customize the
de-identification options according to their local privacy regulations, research needs, and processing tasks,
which may dictate what information is considered sensitive and how strict the anonymization should be.

Caution!
Users of FireVoxel are responsible for complying with the local patient privacy laws when
working with images that may contain identifying information.

The DICOM header fields that contain the information identifying the subject, physician, operator, and
imaging center are usually considered Protected Health Information (PHI).

In the US, the Health Insurance Portability and Accountability Act (HIPAA), provides the standard for
de-identification of protected health information and lists 18 identifiers that must be treated with special
care.

Image processing software packages typically offer de-identification commands, but the list of sensitive DI-
COM fields (tags) removed by these commands varies by software package (for a comparison of free de-
identification tools, see Aryanto 2015 PMID: 26037716).

In FireVoxel, de-identification is performed using commands under File > DICOM:

� De-identify DICOM folder (with and without images open) and

� De-identify document (only with images open).

7.1.1 Customize de-identification profile

FireVoxel allows the user to customize de-identification through the PHI profile, a list of header fields stored
in a text file named FireVoxelPHIprofile.txt (Fig. 7.1) in the FireVoxel directory and used by the de-
identification commands.

The default FireVoxel PHI profile contains only the most important identifiers listed in order of their field
codes (i.e., 0008,0080; 0008,0081; 0008,0090;. . . ). For a complete list of DICOM fields and their descriptions,
see DICOM Standard Browser.

The user may customize this PHI profile by editing FireVoxelPHIProfile.txt, adding or removing DICOM
fields, and then saving these changes. Each field name must be placed in a separate line. The order of the
fields does not matter. The new PHI profile takes effect when FireVoxel is started next time. The user
should keep a backup copy of the custom PHI profile, because FireVoxelPHIProfile.txt will be overwritten
when FireVoxel is reinstalled or updated to a new build. To restore the default PHI profile, the user may
overwrite FireVoxelPHIProfile.txt with the list of tags shown in the sidebar.

Note: The default PHI profile contains fields (0010,1002) OtherPatientIDs and (0010,1000) RE-
TIRED_OtherPatientIDs (in this form), because these fields are often present in images commonly handled
by the FireVoxel team. Users are advised to configure the PHI profile to include these and/or other DICOM
header fields relevant to their applications and patient privacy requirements.
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7.2 DICOM Operations

7.2.1 Show PHI profile

Creates and opens a copy of FireVoxelPHIProfile.txt, named CurrPHIprofile.txt (by default located in Temp
directory).

7.2.2 De-identify DICOM folder

Deletes fields listed in FireVoxelPHIProfile.txt from all images in the user-selected selected directory.

Opens browse-for-folder dialog to select a directory containing DICOM images that need to be de-identified.

Once the user selects the directory, a failsafe dialog appears and asks the user to confirm the operation: All
DICOM files in [selected directory] will be overwritten. Proceed?

If the user clicks Yes, the files in the selected directory will be replaced with the de-identified files named
image_00, image_01, etc. with fields listed in FireVoxelPHIProfile.txt removed.

Once the operation is completed, an information dialog will report the results: [number] out of [total
number] of files were de-identified. Time elapsed = [time] sec.

Clicking No cancels the operation.

7.2.3 De-identify document

Available only when images are open in FireVoxel and displayed in a document window.

Removes DICOM fields listed in FireVoxelPHIProfile.txt from the images displayed in the active document
window. Opens a dialog showing the list of PHI fields found in the active document (Protected Health
Info is present, Fig. 7.2).

The user may choose to De-identify or Cancel. If the user selects De-identify, the PHI fields are deleted
only within the active document. The source DICOM images (outside FireVoxel) are NOT de-identified.
Select Layer Control > Info to verify that the sensitive tags are no longer present.

7.2.4 Split multiframe DICOM file

Available only when NO images or documents are open in FireVoxel.

Separates a multiframe DICOM image (3D or 4D) into individual frames and writes the resulting image series
into a user-selected target directory. The images in the target directory may then be loaded into FireVoxel
using File > Open DICOM folder: Single Document .

Opens browse-for-file dialog to select a multiframe DICOM file (.dcm). Once the user selects the file, the
command opens a browse-for-folder dialog to choose (or create) a target directory. The command then
proceeds to split the original image into individual frames, each slice as a separate DICOM file (.dcm), and
saves them in the target directory.
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Fig. 7.2: De-identify document command opens PHI is Present dialog.

A multiframe image contains a sequential set of image frames, all with the same dimensions and orientation,
with a single header. This results in a more compact representation than a regular, single-frame series, in
which every image has its own header. Multiframe images may be created, for example, by imaging systems
that produce output in the preclinical DICOM format.

Multiframe images may be identified by the following attributes in their headers: (1) Number of Frames
(0028,0008), (2) Frame Increment Pointer (0028,0009), and (3) Stereo Pairs Present (0022,0028). Such
images may not be supported by some DICOM viewers and cannot be directly opened in FireVoxel without
being first split into an image series.

7.2.5 DICOM folder total Pixel Element size

Available only when NO images or documents are open in FireVoxel.

Opens browse-for-folder dialog and returns for the images in the selected folder the sizes (in bytes): - Total
DICOM file size, - Total DICOM Pixel Element file size.

The total DICOM file size is the sum of the sizes of individual images in the series. The total DICOM pixel
element file size is the image size excluding the header. This information can be copied and pasted elsewhere
(using Ctrl+C, Ctrl+V).

Note:
Starting with build 369, the pixel element size of zero is returned for uncompressed DICOM files. A
non-zero size value is returned for images saved in JPEG Lossless or JPEG-LS formats. See also File
> User Interface Options > Compression.

The purpose of this command is to provide an estimate of the relative sizes of the header and image pixel
data.
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7.2.6 Minimize DICOM headers in Current Document

Available only when images ARE open in FireVoxel and displayed in a document window.

Display fewer DICOM tags in the active document. Removes non-essential tags that are not PHI tags.

7.2.7 DICOM Tree to folders

Copies DICOM images from a user-selected directory, sorts them according to the DICOM Tree structure
by Patient, Study, and Series, and pastes copies of these images into automatically created folders named
Patient_N, Study_X, Series_Y.

The command opens a dialog panel with boxes for entering/selecting the Source Folder and the Target Folder.

The Source Folder is the directory with the original, unsorted DICOM images. The Target Folder is the
location where the sorted images will be placed. After the user specifies the Source and Target folders, a
dialog appears: “Include Patient Name as part of the folder name?”

If the user selects Yes, the top directory within the target folder will be named PA-
TIENT_[PatientNameFirst]_[PatientNameLast]_PatientSex_PatientBirthDate.

If the user selects not to include patient’s name, this directory is named PATIENT_1. REVIEW

The next level directory (or directories) inside PATIENT_[. . . ] will be labeled
STUDY_[StudyDescription]_[StudyDate] (after DICOM fields).

Still deeper level directories are named SERIES_MN_[SeriesDescription], MN = 00, 01, 02. . .

Inside each SERIES directory, images are labeled image_00.dcm, image_01.dcm, etc.

7.2.8 Open selected SERIES

Custom image loading option, see Open > DICOM: Open selected SERIES .
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Fig. 7.1: Default FireVoxel-
PHIProfile.txt.
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Chapter 8

Save

� Save FireVoxel Document

� Save Active Layer as DICOM

� Save Active Layer as DICOM folders

� Save Active Layer as Image

This chapter describes saving images and data that are loaded, modified, or created in FireVoxel. Most of
these actions are accomplished using commands grouped under the File tab of the main menu.

8.1 Save FireVoxel Document

Opens Save As dialog to save the active document as a FireVoxel document (.fvx). The document is saved
with its full contents, including image layers, ROI layers, color maps, vector ROIs, polylines, and MagTrace
contours. The default file name is the name of the document window. If the document already exists in the
selected directory, the Save command asks the user to confirm overwriting it.

De-identification: Upon every Save, the document is checked for containing identifying information
(Protected Health Information, PHI) in the fields listed in FireVoxelPHIProfile.txt (for details, see De-
identification).

If the document does not contain PHI fields, Save FireVoxel document will open Save As dialog directly.

If the document contains PHI fields, a dialog (Protected Health Info is present) with the list of identifying
fields will be shown with options to: 1) De-identify and Save – Remove PHI fields before saving the document,
2) Save – Save while keeping these fields unchanged, or 3) Cancel – Cancel saving.

If the document is saved with PHI fields, the PHI dialog will be shown every time the user saves the document.
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8.2 Save Active Layer as DICOM

Opens file save dialog to export the current layer as DICOM files (.dcm – DICOM multiple files by default, or
.dci, single file). The files are saved in the user-selected directory with names formed from the user-specified
name with added suffixes _tXXXX_nXXXXXN (t for dynamic index and n for slice). Before files are saved,
a dialog is shown prompting user to confirm generating new UIDs (Yes by default).

The same functionality can also be accessed via the Layer Control panel, using Save DICOM.

8.3 Save Active Layer as DICOM folders

Opens browse-for-folder dialog to select the target directory. Once the user selects the directory, this Save
command creates a series of nested folders according to the Dicom Tree structure of the image in the active
layer (PATIENT, STUDY, SERIES). The user will be prompted to confirm or decline including the patient’s
name in the name of PATIENT directory.

If the patient confirms using the patient’s name, the PATIENT directory is labeled with patient’s information:
PATIENT_LastName_FirstName_gender_DOB. The STUDY directory is labeled with the study descrip-
tion (DICOM field 0008,1030) and study date: STUDY_StudyDescription_mm_dd_yy. The SERIES is
labeled with the series description (0008,103E) and series number: SERIES_[NN]_SeriesDescription. Each
image is named image_00.dcm, image_01.dcm, etc.

If the patient declines using the patient’s name, the PATIENT directory is labeled PATIENT_1. ISSUE -
no PATIENT_2. The STUDY, SERIES and images are labeled as described above.

8.4 Save Active Layer as Image

Opens file-save dialog to save the active layer in NIfTI format (*.nii). Saving images in MIDAS (*.im)
and ANALYZE (*.img) is also available for backward compatibility. However, these older formats are less
preferable, in particular, due to their inability to unambiguously store the image orientation, and the user is
advised to use NIfTI whenever possible. Saving the active layer as image is also available via Layer Control
> Save Image.
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Chapter 9

View

� Slice View and Film View

� Navigating through slices and dynamic frames

� Interface configuration (View)

� Orthogonal Projections

� Zoom

� Display graphics (View)

� Dynamic experiment (Toolbar)

This section describes commands and options that control how the images are displayed in FireVoxel. These
commands include navigation through slices and dynamic frames. These tools do not modify the image data,
but only change how the images are displayed. Customized views can be saved as FireVoxel documents.

Many of these commands are available under the View tab on the main menu. Selected commands are also
accessible through the Toolbar .

Additional tools for adjusting the appearance of layers (such as the layer order, visibility, ROI color, and
color map options) are available through Layer Control .

9.1 Slice View and Film View

Images loaded in FireVoxel can be displayed in Slice View, when only one slice is shown in the document
window, or Film View, when all slices are shown as tiles in the same document window (Fig. 9.1).

If the document is dynamic, Film View displays all slices at the same value of dynamic variable (such as
time, b-value, echo time, etc.).

To switch back and forth between the Slice and Film views, double-right-click anywhere on the image.
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Fig. 9.1: The same volume in Slice View and Film View.

To select the default initial view used when images are first loaded into FireVoxel, use File >User Interface
Options > Initial layout .

9.2 Navigating through slices and dynamic frames

The user may navigate through the slices of a 3D volume by using the up and down arrow keys on the
keyboard or scrolling up or down the mouse wheel. If the image is 4D, these actions enable viewing slices of
a 3D volume at a single dynamic frame.

To navigate through dynamic frames (such as time points or b-values), the user can press the right and left
arrow keys. In Slice View, the same slice will be displayed at consecutive values of dynamic variables. In
Film View, all slices will also be displayed at each value of dynamic variable.

9.3 Interface configuration (View)

9.3.1 New view

Creates a copy of the active document window in a new window. The original window is renamed [name]:1 and
the new window is named [name]:2, etc. Each view can be manipulated independently and saved separately.
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9.3.2 Cascade

Arranges all document windows as a stack (cascade), with the active window in front.

9.3.3 Tile

Arranges all document windows as tiles (Fig. 9.2). Minimized windows are not tiled and remain minimized.

9.3.4 Show Main Toolbar

Toggles on/off the visibility of the toolbar. Checked by default (toolbar visible).

9.3.5 Select All

Selects all vector entities (vector ROIs, polylines, and spline contours) in the active document. With all
vector entities selected, clicking anywhere outside the vectors deselects all of them. Clicking any vector
entity selects that entity and deselects the others.

9.3.6 Close

Close Document

CAUTION: No file save dialogue. Any unsaved changes may be lost. Closes the active document.

To avoid losing unsaved work, close each document by clicking the cross in the upper right corner. Alterna-
tively, close FireVoxel, in which case the file-save dialog will be shown for each document one by one.

Close All Documents

CAUTION: No file save dialogue. Closes all documents.

Close All Documents but this

CAUTION: No file save dialogue. Closes all documents except the active one.
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Fig. 9.2: Tiled document windows.
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Close All Views but this

Closes all views of the images displayed in the active window (usually orthogonal projections) except the
active window.

9.4 Orthogonal Projections

9.4.1 Set projection for this view (View & Toolbar)

Opens a dialog panel (Specify Volume Projection, Fig. 9.3) to configure orthogonal projection for the current

document window. Clicking View Projection icon opens the same panel.

Fig. 9.3: Specify Volume Projection panel.

The top part (Rotation) contains boxes to enter angles (in degrees) of rotation about X, Y, and Z axes.
Orthogonal rotations can be applied by clicking buttons +/-90 (degrees) (Fig. 9.4, Fig. 9.5, Fig. 9.6).

Clicking Original restores the original orientation. The Type dropdown menu offers the choice of several
types of views: Normal (regular rotation, default), Max Intensity (maximum intensity projection), Max
Intensity with Zero block, Min Intensity (minimum intensity projection), Slab Average (each voxel contains
average signal at that location over the entire slab). ADD DETAILS
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Fig. 9.4: Projection at 90 deg about Z axis.

Fig. 9.5: Projection at 90 deg about X axis.

Fig. 9.6: Projection at angles about X, Y, Z axes.
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9.4.2 Reset projection for this view (View)

Restore the original view for the current document window.

9.4.3 Max intensity projection snapshot (View)

Opens a new document window (named snapshot) with the maximum intensity projection (Fig. 9.7).

The snapshot has the same in-plane dimensions as the original image, but contains only a single slice.

The snapshot cannot be converted back into the original image. In contrast, maximum intensity image
obtained using Set projection with Type >Max intensity can be reset to the original image by selecting
Type > Normal.

Fig. 9.7: MR angiography axial and coronal views (left and center, respectively) and coronal maximum
intensity projection snapshot (right).

9.4.4 Display orthogonal projections (Toolbar)

Clicking Display orthogonal projections toolbar icon opens document windows with orthogonal
projections complementary to the active document window. For example, if the active document window
displays an axial view, the command opens two new document windows showing coronal and sagittal views.
By default, the new windows are tiled .

The new views are opened according to the setting in File > User Interface Options > Display > View
Convention.

If the View Convention is Radiological (left side on the right), Display orthogonal projections opens
two additional windows (for a total of three windows, including the original).

If the View Convention is Neurological (right side on the right), Display orthogonal projections
opens three additional windows: the orthogonal projections plus the original projection in left-side-on-the-
left orientation (for a total of four windows, including the original).
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If the user clicks Display orthogonal projections icon two or more times (with the same or different
windows activated), no new windows are opened besides the original set, although document windows may
be re-tiled after each icon click.

9.5 Zoom

9.5.1 Zoom by window (View & Toolbar)

Zoom in on a rectangular selection with a mouse. To launch the tool, select View > Zoom by window or

click icon (cursor becomes a magnifying glass). To use, click the image, drag the mouse to expand a
white dashed rectangle and release the mouse button. Tool quits upon mouse release. To undo and return
to the original view, use View > Zoom All.

9.5.2 Zoom in/out with fixed upper left corner (View & Toolbar)

Zoom whole image relative to the upper left corner. To apply, select View > Zoom in or Zoom out or

click icons or . Repeat until a desired zoom level is reached.

9.5.3 Zoom All and fit to View (View & Toolbar)

Restore original view (undo zoom in or out). To apply, select View > Zoom All or clicking Zoom All

toolbar icon .

9.5.4 Zoom 1x1 (View)

Display each image voxel as one pixel on screen. Use Zoom All to return to the original view.

9.6 Display graphics (View)

9.6.1 Display\Hide vector

Toggles on/off (checked/unchecked) visibility of vector ROIs and polylines in the active document window
(or current view if several orthogonal projections are open).
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9.6.2 Display\Hide raster

Toggles on/off visibility of image layers and raster ROI layers in the active document window (or current
view if several orthogonal projections are open).

9.6.3 Display\Hide grid

Toggles on/off visibility of a rectangular grid. Opens dialog (Specify Grid Step) with a box for entering
the Grid Step in millimeters. Displays a square grid of green lines spaced by grid step in row and column
dimensions. The grid is shown for all slices, but only for the current view (if orthogonal projections are
displayed). To change the grid step, use this command twice and enter a new grid step.

Fig. 9.8: Display curve length.

9.6.4 Display\Hide Curve Length

For a vector (a two-point polyline), toggles on/off the visibility of the length of the segment between two
points. The length (in millimeters) is displayed next to the polyline as a red number (Fig. 9.8).

For a sector (a three-point polyline), toggles on/off the angle measure, displayed as a green number.

9.6.5 Enumerate polylines

Toggles on/off the visibility of the numbers labeling control points in polylines and MagTrace splines (Fig.
9.9).

The numbers are shown as red numbers next to each control point. The numbers remain visible for both
active and inactive polylines.
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Fig. 9.9: Enumerate polylines option ON.

9.6.6 Contour and Fill Properties

Opens a panel (Polyline and Spline properties) for adjusting parameters of vector polylines and splines.
This panel can also be open by double-clicking a polyline or spline. This panel is described in detail in Trace
section on Magnetic Trace tool.

9.7 Dynamic experiment (Toolbar)

9.7.1 Play 4D experiment (Toolbar)

Clicking Play 4D experiment icon to display the dynamic frames of the current slice consecutively
for a user-specified time interval. Opens dialog (Specify Interframe time delay (.001 sec precision)) with
a box for entering the time during which each frame is shown. Clicking OK starts the sequence of views.
The cursor turns into a blue wheel.

9.7.2 Display voxel TAC (Toolbar)

Clicking Display voxel TAC icon opens a panel to view the time-activity curve (TAC) at the current
voxel (Dynamic Activity Curve: Signal values, Fig. 9.10).

The panel shows the TAC plot, with the origin and maximum values of the horizontal and vertical axes.

Options:

Attributes – Opens dialog to enter T1 value for conversion to concentration.
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Fig. 9.10: Display voxel TAC panel.

Concentration – Opens panel (Concentration Conversion) for converting MRI signal intensity to gadolinium
concentration.

Radius (voxels) – Up and down arrow buttons for adjusting the size of the sampled area. Default size, 0 (1
voxel).

2D (checkbox) – Checked by default, toggles between 2D and 3D sampling mode.

Save – Opens browse for file dialog for saving the current TAC as a text file with two columns: dynamic
dimension and signal.
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Chapter 10

Grayscale Window

� Grayscale Window Width and Level

� Adjusting Window Width/Level in FireVoxel

� Change Width/Level (Toolbar)

� Tissue-Specific Windows

10.1 Grayscale Window Width and Level

Windowing controls how image voxel values are mapped onto grayscale levels when a digital image is dis-
played. Windowing allows the viewer to adjust image brightness and contrast and may help to emphasize
specific image structures.

Windowing is critical for CT images, where the grayscale values reflect a range of CT numbers expressed
in Hounsfield units (HU). The Hounsfield scale (Fig. 10.1) is obtained using a linear transformation of the
X-ray attenuation coefficients for each voxel (𝜇𝑣𝑜𝑥𝑒𝑙) into units where the radiodensity of water (at standard
temperature and pressure) is zero and the radiodensity of air is equal to –1000 HU:

𝐻𝑈 = 𝐾 × (𝜇𝑣𝑜𝑥𝑒𝑙 − 𝜇𝑤𝑎𝑡𝑒𝑟)

(𝜇𝑤𝑎𝑡𝑒𝑟 − 𝜇𝑎𝑖𝑟)
(10.1)

Here K is an integer coefficient equal to 1000 (or 1024 in some CT systems), and 𝜇𝑤𝑎𝑡𝑒𝑟 and 𝜇𝑎𝑖𝑟 are the
attenuation coefficients of water and air.

The CT numbers in medical images typically range between –1000 HU for air to over +1000 HU for dense
bone. Computer displays are usually capable of showing 256 grayscale values, and human eye can distinguish
even fewer levels. The full range of 2000 HU distributed over 200 gray levels would lead to each level repre-
senting 10 HU. The differences between important image structures can be emphasized through windowing,
or selecting the range of values (window width, W) and the center value (window level, L) to be mapped
onto grayscale.
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Fig. 10.1: Typical CT numbers (Hounsfield units) for various tissues.

For example, abdominal organs are often viewed in a narrow window centered at a low, positive value in
order to highlight the differences between tissues with closely spaced CT numbers (Fig. 10.2).

Fig. 10.2: A narrow window (L: 50; W: 200) for abdominal organs, with typical ranges of CT numbers shown
by red bars.

The window width, or the range of CT numbers in the image, changes the image contrast. Increasing the
width decreases contrast, and narrowing the window increases contrast. The window level, or the CT number
at the center of the window, changes the image brightness. Increasing the window level decreases brightness.

For a given window level and width, the window limits, the upper limit (UL) corresponding to white and the
lower limit (LL) corresponding to black grayscale value, are determined as follows: UL = L + W/2; LL = L
– W/2.
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10.2 Adjusting Window Width/Level in FireVoxel

In FireVoxel, windowing can be quickly and interactively adjusted using the Change Width/Level tool, best
suited for adjusting the grayscale window of CT images.

Alternatively, ViewFilter option on the Layer Control panel enables precise control of window level and
width for all images, including real-valued images displayed as color maps.

Both these methods can be used for windowing CT images loaded as real-valued volumes (in HU, without
conversion) or converted to unsigned integer intensity values (see Load > CT data conversion).

For converted images, the window level (L) and width (W) in ViewFilter are shown as converted values.
For example, if the conversion from voxel Hounsfield units (voxel_HU) to voxel intensity (voxel_intensity)
is given by voxel_intensity = voxel_HU + 1024, then the window level of the intensity image is L(intensity)
= L(HU) + 1024, and W(intensity)=W(HU).

Another method for selecting the window level and width is via the main menu command Volume > Window
Level setting > Optimal for All (or Optimal for current timepoint). This method helps the user to quickly
adjust the grayscale window to view a given dataset. Note that these commands select the window center
and width automatically and do not target a specific tissue.

10.3 Change Width/Level (Toolbar)

FireVoxel’s Change Width/Level toolbar tool is intended primarily for adjusting the grayscale window
for integer images in the active layer. However, the tool will also act on real-valued images displayed as color
maps, but may not be optimal for this purpose. For adjusting width/center of colormaps see Layer Control
Panel > ViewFilter.

To launch the tool, click the toolbar icon (cursor becomes black/white circle). To exit, press Esc.

To use, click and drag the mouse across the image, horizontally or vertically.

To increase the window width, drag the mouse horizontally to the right. To decrease the window width,
drag the mouse to the left.

To increase the window center, drag the mouse vertically up. To decrease the window, drag the mouse
down.

10.4 Tissue-Specific Windows

Windowing helps to highlight specific organs or tissues in a medical image. Wide window (400-2000 HU) is
suitable for displaying images with widely varying attenuation values, such as the lungs or bones adjacent
to air and blood vessels. Narrow window (50-350 HU) is more suitable for displaying soft tissues. Typical
tissue-specific windows (width/level combinations, HU) set using ViewFilter for CT images converted to
unsigned integer volumes, may be as follows:

Lung window: L: –600 HU W:1600 HU (Fig. 10.3)
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Bone window: L:500 HU W:2000 HU (Fig. 10.4)

Soft tissue window: L:50 HU W:400 HU (Fig. 10.5)

Fig. 10.3: CT image converted to intensity and displayed in lung window set in ViewFilter.
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Fig. 10.4: CT image converted to intensity and displayed in bone window set in ViewFilter.
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Fig. 10.5: CT image converted to intensity and displayed in soft tissue window set in ViewFilter.
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Chapter 11

Layers

� Layer types

� Layer Control dialog

� Layer Control commands

� Layer operations

� Copy layers using Layer Control

FireVoxel document windows may contain multiple image layers, similarly to PhotoShop and similar image
processing software. Layers are images of the same matrix dimensions and resolution (voxel size) overlaid on
top of each other. Layers may be created by the user or by FireVoxel commands. Layers can be manipulated
and transformed using various commands, moved between compatible documents (of the same resolution and
matrix size), and exported to external files.

A document may contain different types of layers in various combinations. There is no (practical) limit on the
number of layers, although with many high-resolution layers in the same document, processing may become
slow.

11.1 Layer types

11.1.1 Image layers

Image layers contain 3D or 4D images created by medical imaging acquisitions. These images typically
consist of voxels stored as 16-bit integers displayed as grayscale levels.
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11.1.2 ROI layers

ROI layers (segmentation masks) are 3D or 4D images with binary values: filled within selected areas and
empty elsewhere. The empty voxels are always transparent. The filled voxels have a uniform color and their
opacity is set by the alpha value.

Note:
In FireVoxel status bar in the lower left corner, for ROI layers, the current voxel value is shown as either
ON or OFF. When the cursor is positioned over a filled ROI voxel, the status bar reads ROI=ON.
When the cursor points to an empty ROI voxel, the status bar reads ROI=OFF (see an example in
Fig. 4.2 showing ROI=OFF at the current cursor position over the ROI layer named left_kidney).

11.1.3 Real-valued layers

Results of arithmetic operations on images and parametric maps reside in real-valued data layers that are
displayed in pseudocolor (color map). Their opacity is set by the alpha value.

11.2 Layer Control dialog

11.2.1 General description

The Layer Control dialog displays the layers in the document and their properties and allows the user to
manipulate them with an array of command (Fig. 11.1).

To open Layer Control, double-click anywhere on the document window. Layer Control is accessible only
when there are images open in FireVoxel. The dialog can be positioned anywhere on the screen, over the
FireVoxel main window or outside. If several document windows are open, the Layer Control shows the layers
in the active window; clicking on another window makes the Layer Control display the layers in that window.
The Layer Control dialog can remain open while the user is working with several documents and switching
from one document to another.

The title bar of the Layer Control panel displays the name of the active document window and the name and
matrix dimensions of the active layer, as well as the total number of visible layers (in Fig. 11.1, the active
layer matrix is 320 x 260 x 80 x 1 and the document contains 3 layers).

Layer Control displays the layers as a table, in which each row contains a layer and columns contain layer
properties.
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Fig. 11.1: Layer Control dialog.
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11.2.2 Layer name and renaming layers

Each layer is identified by its name. By default, image layers are named after the source images. ROI layers
are named depending on the command that was used to create them (e.g., New ROI 3D creates layers
named New ROI 3D #n, n=0, 1, 2. . . ). To rename the layer, double-click its name, enter a new name in
the text box that opens, and click OK.

11.2.3 Layer order and reordering layers

Layer Control displays the list of layers ordered from the deepest (base layer) at the top to the shallowest
(closest to the viewer) at the bottom of the list. New layers are appended at the bottom of the list (that
is, overlaid on top of the already existing layers). To reorder layers, click the layer name and drag it up or
down on the list.

11.2.4 Active layer

The active layer highlighted in the Layer Control by a red border. The active layer can be manipulated and
will be the one manipulated by default (e.g., ROI drawing will be done on the active layer). Many FireVoxel
commands by default act on the active layer. To activate a layer, click on its name. If an action creates a
new layer in a document, this new layer becomes active by default.

11.2.5 Layer visibility and Display Unmarked Layers

A check box in front of the layer name toggles the visibility of this layer. Unchecked layers become invisible.
However, they can be made visible by checking Display Unmarked Layers box.

11.2.6 Mark\Unmark All

Marks on and off all layers. If some layers are unmarked, acts as Mark All. If all are marked, acts as
Unmark All.

11.2.7 Color map and ROI layer color

A small square swatch next to the layer name shows the color map or ROI color. Color map are selected
for acquired images or parametric maps. The ROI layer color is assigned by default when the ROI layer is
created. The color map and the ROI color can be adjusted using ViewFilter option on the right hand side
of the panel.
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11.2.8 Transparency and Alpha slider

The first column after the layer name, labeled %, shows the layer’s opacity, expressed in percent, from fully
transparent (0%) to fully opaque (100%). The Alpha slider under the layer list in the Layer Control allows
the user to change the opacity of the active layer.

Note that although alpha expresses opacity, it is commonly used interchangeably with the layer transparency,
which is (100% - Alpha).

By default, image layers are shown as 100% opaque and ROI layers as 20% opaque (note these values for the
base layer and two ROI layers shown in Fig. 11.1).

To change the layer transparency, make the layer active by clicking its name in the Layer Control, then
click and drag the alpha slider to the left (towards 0%) to make the layer more transparent or to the right
(towards 100%) to make the layer less transparent. Click on the slide to the left or right of the slider to
chang the opacity in 20% increments in either side.

Note:
Transparency (or Alpha) is an attribute of the entire volume layer, with a single value for the entire
layer. Transparency affects only how the image is displayed and does not affect any image processing
operations.

VOID (value) is an attribute of an individual voxel, which enters into image processing operations. All
VOID voxels are always displayed as fully transparent, regardless of the layer’s transparency setting.

11.2.9 Dynamic frames (#times)

The column labeled#times contains the number of dynamic frames in the layer. For 3D volumes, #times=1.
For 4D images and ROIs, #times=number of frames.

11.2.10 Data type

The column labeled type shows the data type in the layer. Images are usually integer, parametric maps and
other calculated layers are often real, ROI layers are labeled roi (binary images with voxels filled with 1s
and 0s, with 0s fully transparent and 1s opacity given by the alpha value).

11.3 Layer Control commands

11.3.1 New ROI 3D

Create a new 3D ROI layer, which is appended at the bottom of the list of layers. The new ROI layer is
named New ROI 3D #n, n=0, 1, 2. . . The color is assigned automatically from a sequence (red, blue, green,
yellow, cyan, brown, etc.)
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11.3.2 New ROI 4D

Create a new 4D ROI layer, appended at the bottom of the list and labeled New ROI 4D #n, n=0, 1, 2. . .
The ROI size in the 4th (dynamic) dimension will be the same as the size of the base image.

11.3.3 Load DICOM

Opens browse for folder dialog to select a directory with DICOM documents. Once the folder is selected, the
DICOM Tree panel is opened, as in File > Open DICOM command. Only DICOM documents with the
same matrix size and resolution can be opened as a new layer. If the dimensions are incompatible, after the
user clicks Load, a warning is displayed (Equal dimensions are expected) and loading files is canceled
(Failed to add a new layer). If the images are compatible, Load adds them as a new layer and makes
this layer active. The name of this layer will be the same as the name of the loaded DICOM images.

11.3.4 Load Image

Opens browse for file dialog allowing the user to select an image file in one of the compatible formats. The
image is added as a new layer, named as the loaded file, which is made the active layer.

11.3.5 Duplicate

Duplicate the active layer. The new layer is added at the bottom of the list and named as the active layer
with added _copy suffix. Both image layers and ROI layers can be duplicated.

11.3.6 Save DICOM

Save the active layer as DICOM. Opens browse for folder dialog to save the active layer as DICOM document.

11.3.7 Save Image and Save All

Save Image saves the active layer as NIfTI image (.nii). Saving in older MIDAS (.im) or ANALYZE (.img)
formats is also possible, but less preferred because of these formats’ limited ability to store image orientation
unambiguously. Save All saves each visible layer in the document as a separate image. The command opens
a file-save dialog with -.nii appearing by default in the File name box. When the user clicks Save, each of
the layers is saved as an image of the same name.

11.3. Layer Control commands 67



FireVoxel: User Manual, Draft 2025-04-29

11.3.8 Remove

Removes unmarked (unchecked) layers after asking the user to confirm this action (Remove all unmarked
layers?). If all layers are checked, removes the active layer, also after user’s confirmation (Remove Active
Layer?).

11.3.9 ViewFilter

Opens display options depending on the layer type:

� For image layers (integer or real valued): grayscale or color map selection panel;

� For ROI layers: color picker panel.

For image layers, Color Mapping radio buttons can be used to select gray scale (Color Mapping: None) or
one of eight available color maps (Fig. 11.2).

The corresponding color bar is shown on the left, with numbers indicating upper and lower limits, center,
as well as the first and third quartiles. Checking Invert Scale check box reverses the order of the colors
between the upper and lower limits.

The Level-Width text boxes show values of the window level (color scale center) and width (the range
between the lower and upper limits). The window level and width values can be changed by entering new
numbers into the respective boxes or by using the up and down arrows next to the text boxes, with the
changes taking effect instantly. Clicking Default restores the default values of level and width.

11.3.10 Info

Opens Full DICOM Info panel with header information for the selected layer (Fig. 11.3).

The panel consists of 3 parts: Data Header, Element Value, and selected tags. Data Header part shows a
list of header tags. Clicking each tag shows its value in the Element Value window. The selected tags part
shows image properties: Name, modality, rows, columns, etc. Clicking Copy Info to Clipboard copies the
information from the selected tags panel that can be then pasted into a text file and saved.

11.3.11 ROI Stats 3D

Opens ROI Stats 3D dialog with the image statistics (Fig. 11.4).

If the active layer contains an image (integer- or real-valued), the statistics are displayed for the voxel values
in this layer. If the document also contains a single visible ROI, the statistics are shown for the part of the
image within this ROI. If the document contains no visible ROI or multiple ROIs, statistics are shown for
the entire image.

If the active layer is an ROI, the statistics are displayed for the only visible image layer. If multiple image
layers are present, an error message is shown (Ambiguous Layer Configuration). If only ROI layers are visible,
the statistics will show a constant voxel value of 1.
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Fig. 11.2: View Filter panel.
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Fig. 11.3: Layer Info Panel.
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Fig. 11.4: ROI Stats 3D Panel.
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The ROI Stats 3D dialog includes the following features:

Histogram – A bar plot of the distribution of voxel values in the active layer (and within the ROI, if appli-
cable) and histogram controls. Controls include checkboxes and buttons that open subdialogs for entering
values.

Histogram Controls – Bin Width, Number of Bins (N_Bins), Range ([Min, Max]).

Bin Width = (Max – Min)/N_ Bins

By default, the Range is set to the full range of voxel values between the minimum and maximum
values. The default number of bins is 100. The default Bin Width = Range/100.

For a fixed Range, the Bin Width and Number of Bins are automatically adjusted when either
of these values is changed. That is, if the Number of Bins is changed, the Bin Width is adjusted
accordingly. If the Bin Width is changed, the Number of Bins is adjusted.

When the Range is changed, the Bin Width remains fixed, but the Number of Bins is auto-
matically adjusted.

Full – Sets the Range to the to full interval between the minimum and maximum voxel values
(while the Bin Width remains fixed and the Number of Bins is adjusted).

Clip – (Checked by default) If checked, only the values inside the Range are used to display the
histogram and calculate statistical parameters, and the edge bins at Min and Max ends of the
Range are excluded. The number of voxels included is shown in Geometrical features > Voxel
count. Toggling Clip on and off changes the Voxel count (unless Range is set to Full - then Clip
has no effect).

If Clip is unchecked, the edge bins are included, and all voxel values are displayed in the histogram
and used for the statistics calculations. The Voxel count reflects the total number of voxels in
the ROI (or image).

The user is advised to pay close attention to the Clip setting because it may affect
the output of the statistical analysis.

Percent (%) – Sets the Range by specifying the range between the Low and High voxel per-
centiles in the image (see First order features). By default, Percent is set to the full range from
Low=0% to High=100%. When Percent is set to any other values, the Range is recalculated, the
Bin Width remains fixed, and the the Number of Bins is adjusted. When Percent is clicked again,
the default Low and High percentiles are set to 0% and 100%, respectively (i.e., the previous
settings are not retained).

First order features – Range and first-order moments of voxel value distribution:

[Min, Max] – Minimum and maximum voxel signal values Mean – Mean signal over all voxels
(within image or ROI) StDev – Standard deviation over all voxels (within image or ROI) Vari-
ance – Expected value of squared deviation from the mean Inhomogeneity = StDev/Mean –
Coefficient of variation Skewness – Measure of asymmetry about the mean Kurtosis – Measure
of “tailedness” of the distribution in relation to a normal distribution. Distribution with high
kurtosis have heavy tails. Distributions with low kurtosis have light tails. Entropy – Measure of
uncertainty in the variable’s outcomes. Percentiles (1, 5, 10, 25, 50, 75, 90, 95, 99%) – Values of
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the displayed variable, at or below which a given percentage of voxels falls. Example (Fig. 11.4):
If 75% percentile is 192, 75% of voxels have signal less than or equal to 192.

Geometrical features – Size and other geometrical characteristics of the image or ROI: Voxel count – The
number of voxels within an image or ROI Volume – Volume of image or ROI (in cm3) Void voxel count –
Number of VOID voxels Num blobs - Number of unconnected subregions Blob mean – Mean over unconnected
subregions (equal to the mean value in First order features if the image or ROI contains a single region) Blob
stdev – StDev over subregions Nonuniformity – Measure of variation across subregions.

Segmentation\Modeling – Options to identify segments within the distribution. Used for segmentation
of ROIs into subregions. ADD DETAILS

� Method – Dropdown menu with a choice of methods (Default: Otsu, Zigalga, Bimodal Gauss with
Ratio, Bimodal Laplace with Ratio, Bimodal Gauss PVV, Bimodal Laplace PVV, Air Threshold)

� Number of segments

� Show model – None, All Curves, Cumulative

� Thresholds

� Update – Recalculate and display results

Save Stats – Create RoiStats3D.txt file with summary statistics with the current settings. By default, when
this file is created, it is saved in FireVoxel’s Temp folder. If the user changes the histogram settings and clicks
Save Stats again, another RoiStats3D.txt file will be created and opened. The previously created file will be
overwritten without a warning. The user is advised to save the statistical results in a different directory and
label these files systematically for future reference.

ROI stats include: Volume (in voxels and cm3), Signal Min, Max, Mean, Median, Stdev, Inhomogeneity
(stdev/mean). Also included are Histogram stats and histogram values (Bin/Signal/Count) and parameters
(skewness, kurtosis, entropy).

11.3.12 ROI Stats 4D

Opens ROI Stats 4D panel for a dynamic experiment (Fig. 11.5). The left side of the panel displays the plot
of the average values within the ROI versus the dynamic dimension (time, b-value, echo time, etc.). The
axes show the name of the variable plotted and the minimum and maximum values.

Fig. 11.5: ROI Stats 4D Panel.
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The right side of the panel shows display options and commands:

� Display:

– All layers – Check box allowing to plot values within all visible ROI layers. Each ROI’s data will
be shown in the color of the ROI layer.

– Median-onAverage-off – Displays the median value instead of the average?

– Label – Name of the ROI with the ROI volume in mm3 (e.g., ROI1_1000mm3)

– Skip Start Timepoints and Skip End Timepoints – Text boxes allowing entering the number of
points to be hidden in the beginning and end of the dynamic series.

� Commands:

– Go to Peak – TBA

– Go to Bolus Arrival – TBA

– Background – Color selector allowing to change the plot background

– Gamma-variate fit – Opens Parametric Map calculation for fitting the curve with a gamma-variate
fit (for input functions)

– Save – Open file save dialog for saving the plotted curve (time activity curve) as a text file. The file
contains: curve label (from above), and tab-delimited columns (with column headers) – dynamic
coordinate (e.g., time (sec)), avgVal – average signal value in the ROI, and vol_cm3.

– Copy to clipboard – Copies the same information to clipboard for pasting into a spreadsheet or
another document.

11.3.13 Attributes

Opens a small dialog for entering tissue T1-value (in seconds) (Fig. 11.6).

11.4 Layer operations

The button labeled Operation opens Layer Operations dialog for pairwise operations on layers (Fig. 11.7):

The following operations act on the active layer (layer A) or on two visible layers, layer A (base layer, furthest
from the viewer) and layer B (top layer, closest to the viewer). To swap operands, reorder layers in the Layer
Control layer list (Layer order and reordering layers).

To use Layer Operations, mark two layers and unmark all other layers, click Operation and then select the
appropriate operation. A new layer will be created with the result of the operation, labeled [operation]
result (e.g., union result).
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Fig. 11.6: Attributes dialog to enter T10 for an ROI layer.

11.4. Layer operations 75



FireVoxel: User Manual, Draft 2025-04-29

If the user selects an operation that does not match the type of selected layers, an error message will be shown
(ROI is required in this operation for binary operations or ROI is not allowed in this operation
for arithmetic operations). If more than two layers are selected, an error message will be shown (Invalid
number of operands for this operation). In these cases, the operation will not be performed and no
new layers will be created.

The layer operations are split in two groups, Binary and Arithmetic operations:

Binary Operations Operate on one or two ROI layer(s) and return an ROI layer (Fig. 11.8).

Intersect – A ^ B – A AND B – Returns a layer with voxel values of 1 where voxels in both
layers A and B have the value of 1 and zero otherwise. The output layer is named intersect
result.

Union – A v B – A OR B – Returns a layer with voxel values of 1 where voxels in either or both
layers A or B have the value of 1 and zero otherwise (where both A and B have zero values). The
output layer is named union result.

NOT – NOT(A) – Logical complement. Returns a layer with voxel values of 1 where layer A
have zero values and zero elsewhere. The output layer is named not result.

A AND (NOT B) – Returns a layer with voxel values of 1 where A has the value of 1 and B
is zero and zero otherwise. The output layer is named a_and_not_b result.

XOR – A XOR B – Exclusive OR – Returns an ROI layer with voxel values of 1 where layers A
and B have different values and zero where A and B have the same values. The output layer is
named xor result.

Fig. 11.8: Binary layer operations truth table.

Arithmetic Operations Require two integer- or real-valued image layers and return a single image layer
of the same type as the operands.

Abs(Diff) – |A – B| – Absolute difference – Returns a real-valued color map layer where each
voxel contains the absolute value of difference between layers A and B. The output layer is named
absolute difference result.

Max(0,Diff) – Diff=A–B if A>B and zero otherwise – Zero-truncated difference – Returns a
real-valued color map layer where each voxel is equal to the difference between layers A and B if
this difference is positive (A>B) and zero otherwise. The output layer is named zero truncate
absolute difference result. To obtain Diff=B–A, swap layers A and B in Layer Control by
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dragging and dropping the layer names into appropriate positions so that layer B is located higher
on the layer list than layer A.

11.5 Copy layers using Layer Control

The Layer Control dialog can be used to copy layers between compatible documents, i.e., document windows
that display images with the same matrix dimensions and voxel size. To copy a layer from Document 1 to
Document 2, open both documents in FireVoxel in two different document windows, open Layer Control,
and click anywhere on Document 1 to activate it. Next, in the Layer Control dialog, click the layer that
needs to be copied, drag it anywhere over Document 2 and drop it. To verify that the layer has been copied,
click on the Document 2 window and inspect the list of layers in the Layer Control. The copied layer should
be added at the bottom of the list. All types of layers can be copied using this method, but only between
compatible documents.

As an alternative to this method, layers can be copied by saving them as images and loading them into the
target document. To use this method, click Document 1, activate the layer to be copied in Layer Control and
save it using Save Image, for example, in NIfTI format (.nii). Next, click Document 2, and use Load Image
in Layer Control to select the just saved image. The loaded image will be added to the bottom of the list of
layers. The name of this new layer will be identical to the name of the file, including the .nii extension.

Fig. 11.7: Layer Operations Dialog.
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Chapter 12

Draw Raster ROIs

� Drawing and editing ROIs with paintbrush tool

� Raster paintbrush properties

Region of interest (ROI) is a binary layer, or mask, in which each voxel takes values 1 or 0. ROI voxels that
have the value of 1 have attributes of foreground color and transparency (alpha value). Voxels that have the
value of 0 are always completely transparent, regardless of the transparency value of the entire ROI layer.
In FireVoxel, ROI layers are treated as 3D or 4D raster images.

Raster ROIs may be created manually or as a result of various commands.

12.1 Drawing and editing ROIs with paintbrush tool

Raster ROIs can be drawn manually using the paintbrush tool. Drawing is done on the active ROI layer. If
there are no visible ROI layers (i.e., the document has ROI layers, but they are unmarked), a new ROI layer
is created by default and the ROI is drawn on that layer. The ROI layer has the same matrix dimensions
and voxel size as the underlying base image.

To draw an ROI, press and hold down Ctrl key and click and hold down the left mouse button. The cursor
turns into the paintbrush, shown as a green ring filled with the ROI color at 20% transparency. Move the
mouse to paint voxels that need to be included in the ROI. Any voxels touched by the paintbrush (the green
circle) will be painted the ROI color (i.e., assigned the values of 1). To finish drawing, release the mouse
button and Ctrl key (Fig. 12.1).

To erase voxels from an ROI, hold down Ctrl key and click and hold down the right mouse button. The cursor
turns into a red ring (without color inside), the eraser brush. Move the cursor to erase voxels. Any voxels
touched by the eraser will be returned to zero state and become transparent. Release the mouse button (and
Ctrl key) to finish.

Manually drawn ROIs do not need to be contiguous and may contain areas drawn on several different slices.

78



FireVoxel: User Manual, Draft 2025-04-29

Fig. 12.1: Paintbrush tool for drawing and editing raster ROIs.

12.1.1 Adjust paintbrush size

While holding down Ctrl key, scroll the mouse wheel forward and backward to increase or decrease the
diameter of the paintbrush/eraser.

12.2 Raster paintbrush properties

The paintbrush properties dialog (Fig. 12.2) can be accessed by clicking icon on the main toolbar.
The panel must be closed before the paintbrush can be used. The paintbrush settings are retained for one
session. Closing and reopening FireVoxel restores the default settings.

Paintbrush allowed on ROIs/Integer volumes/Real volumes – The three checkboxes at the top of
the dialog control the types of layers the paintbrush is allowed to change. By default, the paintbrush is
allowed to draw only on ROI layers. If the Integer volumes box is checked, the paintbrush can draw on
image layers. Similarly, if the Real volumes box is checked, the paintbrush is able to draw on real-valued
layers, such as parametric maps. NOTE: Selecting Integer volumes and/or Real volumes allows the
paintbrush to alter the base images, which is often undesirable. Therefore, users should exercise caution
when using these options.

12.2. Raster paintbrush properties 79



FireVoxel: User Manual, Draft 2025-04-29

Fig. 12.2: Paintbrush properties panel (build 465).

Paint Signal/Erase Signal – These text boxes control the grayscale value of the paintbrush/eraser, respec-
tively. This option can be used for drawing on integer or real layers. It does not affect the paintbrush on ROI
layers. By default, the paintbrush grayscale value is set to white (Paint Signal = 255) and the eraser value
to black (Erase Signal = 0). Changing the Paint Signal/Erase Signal settings by entering new values into
the corresponding text boxes allows painting and erasing voxels with other grayscale values.

Radius (vox) – This text box sets the radius of the paintbrush to a specified value (default, 2 voxels). This
allows the user to control the paintbrush/eraser size more precisely than when adjusting it by scrolling the
mouse wheel. Entering the radius of 0 sets the paintbrush size equal to 1 voxel. If the paintbrush radius is
set to 1 voxel (in Circle mode, see below), the paintbrush has the shape of a 5-voxel cross (as on the Swiss
flag).

Circle/Sphere/Cylinder – The dropdown menu allows the user to select among the three different paint-
brush types. By default, the paintbrush is set to Circle, and in this regime it paints all voxels within a given
radius from the brush center on a single plane (2D). The Sphere option enables drawing an ROI on several
slices (3D) at once: this paintbrush paints all voxels within the selected radius from the paintbrush center
in three orthogonal directions. The Cylinder option replicates an ROI drawn in one plane throughout all
voxels in the direction orthogonal to the plane of the original ROI.

Modify all timepoints – This checkbox, if checked, extends the ROI to all frames in a dynamic (4D)
experiment. This results in a 4D ROI. The box is unchecked by default.

Center Zoom on Mouse – This box is unchecked by default. This option has effect only when an image
is viewed using Zoom by Window . When enabled, this feature automatically shifts the view within the
document window to center on the current cursor position. This allows the user to control the ROI drawing
with the paintbrush more precisely. To use this option, first select View > Zoom by Window from the

main menu, or click the icon on the toolbar (the cursor will become a magnifying glass) and select
the zoom-in area. Next, start painting with the paintbrush by holding down the left mouse button. As the
mouse moves, the document window view will shift as well, so that the cursor remains in the center of the
window.
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Chapter 13

ROI

� Morphology (group)

� Remove “Salt and Pepper” artefacts

� Union Cylinder from 2D Contours

� Band of Average Signal

� Intersect Cylinder from 2D Contours

� Fill 2D Contours

� Extract Atlas ROIs

� Threshold to ROI by Signal interval

� Threshold to ROI by Signal-to-Gradient ratio

� Local Otsu Threshold to ROI

� Split ROI with Threshold (group)

� Normalize by ROI

� Make Convex 2D

� Clip Volume by ROI

� Crop Volume by ROI

� Clear ROI slices (group)

� Average ROI layers

� Convert 3D to 4D

� Max Connected Component 3D

� Max Connected Component 2D

� Connected Component by Seed
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� Inside Surface Wave distance (in 0.01 mm)

� Outside Surface Wave distance (in 0.01 mm)

� Layer Peel

� Smooth Shape

� Volumetric profile curve

� Concentric layers first order statistics

� Zoom whole extent

This section describes the commands under the main menu’s ROI tab, which act on ROI layers or create
ROI layers as results.

13.1 Morphology (group)

13.1.1 Peel (all timepoints)

Requires a 3D or 4D ROI. Opens dialog (Peel ROI, Fig. 13.1). Removes a shell ofspecified width (Radius,
by default in voxels, or in millimeters, byuser choice) from the outer boundary of the active ROI. Checking
All Layers box removes this shell from all ROI layers, visible and invisible (unchecked by default). Checking
3D Mode results in voxels removed across slices. This operation writes results to the original layers and
does not create new layers. To retain the original ROI layers, use Duplicate to create a copy and apply the
Peel command to the copy instead. If the ROI is 4D, the Peel operation is applied to all dynamic frames.

Fig. 13.1: Peel ROI panel.
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13.1.2 Grow (all timepoints)

Requires a 3D or 4D ROI. Opens dialog (Grow ROI). Inverse operation to Peel operation. Adds a shell of
specified width (Radius, by default in voxels, or in millimeters, by user choice) from the outer boundary of
the active ROI. Options are the same as for Peel.

13.1.3 Skeleton (current timepoint)

Requires a 3D or 4D ROI. No parameters. Creates a new layer. ADD DETAILS.

13.1.4 Medial Axis Transform

ADD DETAILS.

13.1.5 Average Depth (internal thickness)

Requires a 3D ROI. No parameters. Returns the average depth of the ROI in millimeters.

13.1.6 Unclump perceived Connected Components to Layers

Requires a 3D ROI. Opens dialog (Specify Peel (mm)). Removes the original layer and creates one or more
ROI layers instead, obtained by peeling a user-specified width from the ROI boundary.

13.1.7 Unclump perceived Connected Components to Atlas

Requires a 3D ROI. Opens dialog (Specify Peel (mm)). Creates a new, integer layer, labeled base, with
voxel values of 1 inside the ROI and 0 values outside. The original ROI layer is retained.

13.1.8 Peel\Grow External Surface only

Requires a 3D ROI. Opens dialog (Specify PeelGrow). Removes or adds a shell of user-specified thickness
(in millimeters) from the outside surface of the ROI. Returns the result to the original layer.

13.1.9 Current Slice Structure Graph

Requires a 3D ROI. Opens dialog (Specify Triangle size threshold). Creates a graph (vector object, made
of 3 vertices and connecting vectors), on the current slice. Triangles of size above user-specified threshold
are marked.
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13.1.10 Close broken contours and fill 2D

Requires a 3D ROI. Opens dialog with options to specify maximum distance between ROI edges to be closed
and the number of steps. Adds voxels to ROI edges in a user-specified number and up to maximum distance.

13.1.11 Extract Connected Components

Requires a 3D ROI. No parameters. Removes the original ROI and creates a new ROI layer with connected
components.

13.1.12 Fill 2D Contours and Morph Convex

Requires a 3D ROI. Acts on current layer and returns results to the same layer. Fills 2D contours and
extends convex areas across slices. Can be used to speed up segmentation: contours can be drawn selected
slices (e.g., on every 5th slice) and Fill and Morph command will fill the contours and extend the ROI to
every slice.

13.1.13 Morph Convex

Requires a 3D ROI. Acts on current layer and returns results to the same layer. Extends filled areas across
slices. Does not fill contours.

13.1.14 Fill 2D Contours and Morph Arc

Requires a 3D ROI. Acts on current layer and returns results to the same layer. Fills 2D contours and extends
filled areas across slices.

13.2 Remove “Salt and Pepper” artefacts

ADD DETAILS.

13.3 Union Cylinder from 2D Contours

ADD DETAILS.
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13.4 Band of Average Signal

ADD DETAILS.

13.5 Intersect Cylinder from 2D Contours

ADD DETAILS.

13.6 Fill 2D Contours

Requires an ROI layer. Fills voxels within ROI contours with ROI color. Contours are filled separately on
each slice, but not across slices (unlike in Morph command).

13.7 Extract Atlas ROIs

Extracts ROIs with user-selected indices from an atlas segmentation map and places each ROI in a new,
automatically created layer. Opens dialog to enter a comma-separated list of ROI indices. Returns ROI
layer(s), one per atlas region, each named atlas region [number].

Example: Input data and dialog (Fig. 13.2) and output (Fig. 13.3) of Extract Atlas ROIs applied to
FreeSurfer atlas segmentation of T1-weighted MPRAGE image of the brain.

Fig. 13.2: Extract Atlas ROI input data (FreeSurfer segmentation of MPRAGE, T1.mgz (in atlas space),
with atlas labels map aseg.mgz) and ROI selection dialog to select right cerebral white matter (41) and right
cerebellar white matter (46) regions. Atlas segmentation aseg is shown in rainbow colormap with [window
center, width]=[23.5,47].
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Fig. 13.3: Extract Atlas ROI output ROI layers for right cerebral (region 41) and right cerebellar white
matter (region 46).

13.8 Threshold to ROI by Signal interval

Requires an image layer. Creates a new ROI layer with values of 1 where image voxels have signal inside
the range between the low and high threshold, which the user can enter in a dialog panel (Specify signal
range, Fig. 13.4). Voxels outside the range are transparent (VOID). The threshold values are entered as
numerical values into the panel, so the user needs to determine them beforehand.

Fig. 13.4: Specify signal range.

13.9 Threshold to ROI by Signal-to-Gradient ratio

Requires an image layer. Creates a new ROI layer with filled voxels where signal-to-gradient (ratio) exceeds
a user-specified threshold value.
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13.10 Local Otsu Threshold to ROI

Note: This option has been moved here from Volume > Adaptive Threshold and fully revised.

The function works for integer and real volumes. Creates a new ROI layer with a binary mask generated
by signal thresholding.

For every voxel (x,y,z), the command performs Otsu thresholding within the vicinity of a user-specified radius
R (in voxels). The operation creates a mask (ROI) layer and sets the value of the mask at voxel (x,y,z) to 1
if the signal at this voxel exceeds the threshold and 0 otherwise.

Note: March 2022 - Currently only a 2D version is available (i.e., only 2D vicinity is analyzed). The 3D
code is working but computationally expensive.

13.11 Split ROI with Threshold (group)

Requires an image layer. Creates two new ROI layers with values based on the image intensity threshold:
ROI A (low portion) with filled voxels where image intensity is below the threshold value and ROI B (high
portion) with filled voxels where image intensities are above the threshold value. Opens a dialog panel that
allows the user to adjust the threshold manually based on visual inspection of the ROIs (Fig. 13.5). Press
Cancel or close the panel to cancel and remove the newly created ROI layers.

Fig. 13.5: Split ROI with Threshold dialog with the minimum (0.0) and maximum (229.0) signal values,
and a manually selected threshold (97.55) splitting the image into ROIs A (low portion, 96%) and B (high
portion, 4%).

Dialog Elements:

[Title bar] B=. . . , A=. . . – Volumes of ROI A and B (in cm3 and as percent total ROI volume) and the
ratio of B/A.
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Slider – The horizontal slider can be clicked and dragged right or left with the mouse to adjust the threshold
intensity. Moving the slider to the left lowers the threshold, decreases ROI A (low portion) and increases
ROI B (high portion). Moving the slider to the right raises the threshold, increases ROI A and decreases
ROI B. The minimum, threshold, and maximum values are shown below the slider. The resulting ROIs A
and B are updated in real time. The transparency of the ROI layers can be adjusted with the vertical slider
on the right hand side (up – more transparent, down – less transparent).

Specify – Enter a threshold value. The slider is placed at this value.

The command options offer a choice of how the default threshold is determined:

using initial Threshold – The default threshold is the minimum intensity.

using Low Portion – The default threshold is the midpoint of the intensity range.

using Histogram Split – The default threshold is determined from signal histogram. Opens ROI Stats
3D dialog. The user must use SegmentationModeling module of this dialog to select the histogram split
options (Method and Number of segments) and click Update. The threshold intensity will be shown in the
Thresholds window and used to split the ROI. Next, two new ROI layers will be created and the Split ROI
with Threshold dialog will be displayed for further adjustments.

13.12 Normalize by ROI

Requires an image and a single visible 3D ROI. Creates a new real-valued layer. Opens Volume Normalization
panel to select the options: 1) Division by Coefficient – New voxel values are equal to the original intensities
divided by the average value within the ROI, 2) Z-score – (SI-avgROI)/stdevROI – New voxel values are
original intensities shifted by the average ROI values and normalized by the standard deviation of the ROI.

13.13 Make Convex 2D

Requires an image layer and a 3D ROI. Fills voxels within a 2D convex shape that can be drawn around
existing ROI areas (e.g., if three points are drawn on the ROI layer, the command fills a triangle created by
them).

13.14 Clip Volume by ROI

Requires an image layer and a visible 3D ROI. Removes image voxels outside the visible ROI (not just active)
and replaces them with user-selected values. The user is prompted to enter a clip value (replacement): -1 (or
any negative value) for transparent voxels (signal value VOID), or 0 (or any non-negative value) for black
voxels (signal value 10). The image values within the ROI are retained. The image dimensions are preserved.
No new layers or document windows are created, the result is written to the same image layer. Therefore
if users want to retain the original image, they should duplicate this image layer of it and apply the Clip
command to the copy.

Other ROIs are unaffected. More than one ROI layer may be present. If there are two or more visible ROIs
and one of them is active, the active ROI will be used. If there are two or more visible ROIs, but none of
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them is active, FireVoxel will show a warning about an ambiguous layer configuration and the command will
not be executed.

13.15 Crop Volume by ROI

Requires an image layer and a visible 3D ROI. Crops a 3D image around the ROI in the active layer. A single
visible ROI layer is required; if there are two or more ROIs, FireVoxel shows a warning about ambiguous layer
configuration, and the command is not executed. The cropped image is placed into a new document window
named the same as the original window with _cropped suffix. The cropped region is sized to accommodate
the maximum dimensions of the ROI in all dimensions. If there are other ROI layers in the original document,
they are retained in the cropped document.

13.16 Clear ROI slices (group)

Requires a 3D ROI. Erases the ROI voxels in user-selected slices. Opens parameter panel to enter slice
numbers defining the interval [Z0, Z1] where the ROI will be erased (inside or outside this interval). The
remaining ROI slices are unchanged.

13.16.1 Clear ROI slices outside [Z0, Z1]

Erases voxels in the active, visible ROI layer from slices between the first slice to slice number Z0-1 and from
slice Z1+1 to the last slice. Edge slices Z0 and Z1 are not cleared. If the active ROI layer is invisible, the
command is not executed.

13.16.2 Clear ROI slices inside [Z0, Z1]

Erases voxels in the active, visible ROI layer from slices starting with Z0 and ending with Z1. Edge slices Z0
and Z1 are cleared. If the active ROI layer is invisible, the command is not executed.

13.17 Average ROI layers

Create a new real-valued layer from visible ROI layers. Opens parameter panel. The user can select the
values of background voxels (outside the ROIs): 0 for black (default) or -1 for transparent (VOID). The user
can also select a normalization value by which the value inside the ROIs will be multiplied (e.g., 10 x avg
value = 10).
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13.18 Convert 3D to 4D

Requires a 4D image (dynamic series) and a 3D ROI. No parameters. Extends a 3D ROI to every frame of
the 4D image.

13.19 Max Connected Component 3D

Requires a 3D ROI. Creates a new ROI layer. Finds and writes to the new layer an area of the maximum
connected components in 3D.

13.20 Max Connected Component 2D

Requires a 3D ROI. Creates a new ROI layer. Finds and writes to the new layer an area of the maximum
connected components in individual slices (2D).

13.21 Connected Component by Seed

Requires a 3D ROI and a VROI seed. Creates a new ROI layer. Finds connected component by seed growing
based on the VROI seed and writes this area into the new layer.

13.22 Inside Surface Wave distance (in 0.01 mm)

Requires a 3D ROI. No parameters. Creates a new integer (grayscale) layer with the region inside ROI filled
with values determined from ADD DETAILS.

13.23 Outside Surface Wave distance (in 0.01 mm)

Requires a 3D ROI. No parameters. Creates a new integer (grayscale) layer with the region outside ROI
filled with values determined. . . .

13.24 Layer Peel

Requires a 3D ROI. Opens parameter panel. The user specifies the number of layers to be created. Splits
the original ROI into a specified number of layers by removing from the boundary of the original ROI a shell
with the user-specified thickness (layer width). The innermost layer contains voxels that remain after peeling
of the outer layers. The action is performed on all ROI layers (3D).
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13.25 Smooth Shape

Requires a 3D ROI. Opens a parameter panel. Creates a new ROI layer. The new ROI is obtained from the
original ROI by smoothing the ROI boundary with the specified radius.

13.26 Volumetric profile curve

Requires a 4D ROI. Displays info panel (4D ROI volume time profile, Fig. 13.6). Shows ROI volume
on the vertical axis versus dynamic dimension on the horizontal axis. Can display multiple curves on the
same plot. When the cursor is placed over a curve, displays ROI parameters: volume, MaxVol (cm3), FEV1
(cm3), FVC (cm3), FEV1/FVC. Copy Measures copies these values to clipboard. Copy Curves copies
to clipboard ROI volumes as columns labeled by ROI name (only volumes are included, not the dynamic
dimension). ADD DETAILS.

Fig. 13.6: Volumetric profile panel.

13.27 Concentric layers first order statistics

Requires a 3D ROI. Opens dialog panel (Specify Integer). Returns info panel (ROI concentric ring
profiles, Fig. 13.7). Ring profiles shows plots of signal values versus the ring number from the outermost to
the innermost. ADD DETAILS.
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Fig. 13.7: ROI concentric ring profiles panel.

13.28 Zoom whole extent

Requires a 3D ROI (visible). Finds the slice with the largest ROI area and displays it at the maximum zoom
that fits into the document window at its current size. If the active ROI is invisible, shows the visible ROI.
If the active layer is invisible, but there are several visible ROIs, shows a warning about ambiguous layer
configuration.
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Chapter 14

Vector

� Display VROIs

� Construct VROI

� Matching VROI coordinates to voxel indices

� Activate, resize and move a VROI

� Vector ROI properties

� List all VROIs

� Save VROIs

� Load VROIs

� Next VROI (F11)

� Enclose connected components by a Vector ROI

� Vector ROI 2D > 3D

� Rasterize

� Insert polyline

� Delete

Vector regions of interest (VROIs) are rectangular regions in 2D, 3D, or 4D.

VROIs are defined by the coordinates of their corners in contrast to raster ROIs, which are defined as arrays
of pixel values.

VROIs are used for annotating subsets of the document, cropping images, measuring distances, placing
anatomical landmarks, and as seeds required by several commands (Connected Component by Seed, Edge-
Wave segmentation, Image-Derived Input Function).

VROIs can be created and manipulated using the commands under the main menu’s Vector tab (Fig. 14.1),
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which becomes available when images are loaded into FireVoxel. VROIs can also be drawn and rasterized
with the help of the Toolbar tools.

14.1 Display VROIs

VROIs are shown as semi-transparent rectangles, with sides parallel to the (X,Y,Z) axes of the document
(Fig. 14.2). The two intersecting diagonals indicate the VROI center. The size of a VROI may be smaller
than a single voxel. As a result, a VROI may be nearly invisible.

The visibility of all vector entities (VROIs, polylines, and contours) in a document can be toggled on and off
using View > Display/Hide Vector .

14.2 Construct VROI

To create a VROI:

Fig. 14.1: Vector menu tab.

� Load an image in FireVoxel. See Open for details.

� Navigate to the slice, or view (if multiple orthogonal projections are open), or a frame in a 4D (dynamic)
document on which VROI will be drawn. VROIs can be drawn in either the Slice or the Film view.
However, a VROI is initially defined only on a single slice (2D) and only on the current dynamic frame
in a 4D dataset.

� Select Vector > Construct Vector ROI (or click Construct vector ROI toolbar icon ).
The cursor will become a cross.
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� Move the cursor to the location where the lower left corner of the VROI should be and left-click (the
mouse button does not need to be held down after the click). A pair of small green circles (handles)
will appear at the location of the mouse click. Move the cursor towards the upper right corner of the
VROI. The VROI will be shown as a semi-transparent green rectangle with the corners at the initial
mouse click and the current cursor position. Click again to complete the VROI. The cursor will revert
to the standard white arrow.

� To exit from the VROI tool without drawing a VROI, press Esc.

� The dimensions and position of the VROI can be easily adjusted, therefore it is not critical to draw
VROIs precisely on the first attempt.

14.3 Matching VROI coordinates to voxel indices

Fig. 14.2: VROI enclos-
ing the left kidney on
DCE MRI.

A VROI is defined by the coordinates of its handles: the lower left corner (X0, Y0, Z0) and the upper right
corner (X1, Y1, Z1).

The VROI coordinates and dimensions are specified as real (decimal) numbers. This leads to the need to
map the real-valued VROI coordinates to integer voxel indices, which take integer values (0, 1, 2,. . . ). In
FireVoxel, voxel i contains points whose coordinates lie in a semi-open interval [i, i +1) (closed on the left,
open on the right). Therefore, voxel 0 extends over the coordinates [0.0, 1.0): coordinate 0.0 is part of the
first voxel, whereas the point with coordinate 1.0 is part of the second voxel (Fig. 14.3). This convention
holds for each of the {X,Y,Z} axes.

A VROI also has a dynamic index (4th dimension coordinate). Dynamic index takes integer values in the
interval [t0, t1], where t0 and t1 are the first and last indices of the dynamic frames on which the VROI is
defined.
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14.4 Activate, resize and move a VROI

A VROI has two states, active and inactive. An active VROI can be manipulated (moved, resized, rasterized,
etc.). An active VROI shows handles small circles in the lower left and upper right corners. Inactive VROIs
do not have these handles. Only one VROI in the document can be active at a time.

To activate a VROI, click anywhere inside this VROI. To inactivate a VROI, click anywhere outside the
active VROI. To resize a VROI, activate it, left-click one of its handles (the cursor will become a cross), then
hold and drag it to increase or decrease the size of the VROI.

To move a VROI without changing its dimensions, right-click an active VROI (the cursor will change to four
white arrows), then hold and drag it to a new location; release the right mouse button to finish.

A 2D VROI can be manually converted into a 3D VROI by displaying the image in orthogonal projections

(clickDisplay Orthogonal Projections toolbar icon ) and resizing the VROI to extend across several
slices. Alternatively, this can be done using Vector > Vector ROI 2D -> 3D.

The dimensions, position, and other features of VROIs may also be configured using the Vector ROI Prop-
erties panel.

14.5 Vector ROI properties

VROIs can be adjusted and manipulated via the Vector ROI Properties panel (Fig. 14.4). To open it, double
left-click on the VROI. A common mistake is to double right-click, which switches the document from the
Slice view to the Film view. To recover from this mistake, navigate to the VROI and double right-click again
to switch back to the Slice view.

Fig. 14.4: VROI properties panel.

The properties panel can remain open while the user activates different VROIs, uses Vector > Next Vector
ROI (F11) function, or even deletes all VROIs. The Vector ROI Properties panel has the following fields.
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Name - Text box containing VROI name. By default, VROIs are named vroi_N (N=0, 1, 2,. . . ) and
numbered in the order in which they are created in the document. Custom VROI names may be entered into
the name box. Renaming will not affect their original order, which is used, e.g., by Vector > Next VROI
(F11) command.

Color - The color swatch showing the current color (green by default). Double-click to open the standard
Windows color picker and select custom color. The color may be changed only for already existing VROIs.

Coordinates - The real-valued coordinates of the lower left and upper right corners, (X0, Y0, Z0) and (X1,
Y1, Z1), respectively. By default, the units are voxels, but may be switched to millimeters by using the
dropdown menu labeled units (in the lower right corner) and selecting mm instead. The coordinates are
recomputed when VROI is moved or resized manually.

Typing over the current values will change the position and dimensions of the VROI. After typing a number
in a text box, click on another text box or press Tab for the change to take effect. Pressing Enter would
close the properties panel.

Units - Drop-down menu to select the units of Coordinates, Dimensions, and Center (voxels (default) or
millimeters).

Dimensions and Center - Dimensions (DX, DY, DZ) are labeled width, height, and depth, respectively.
Center specifies the (CX, CY, CZ) coordinates of the VROI center (indicated by intersecting diagonals).
These values are recomputed dynamically when VROI coordinates are changed:

DX = X1 – X0, CX = (X0 + X1)/2

DY = Y1 – Y0, CY = (Y0 + Y1)/2

DZ = Z1 – Z0, CZ = (Z0 + Z1)/2

Typing new values into these boxes will change the size of the VROI. The coordinates will be recomputed
accordingly. To extend a VROI over several slices, enter a number greater than 1 into the Depth box.

When D or C values are modified, the corresponding minimum and maximum values are recomputed:

X0 = CX – DX/2, X1 = CX + DX/2

Y0 = CY – DY/2, Y1 = CY + DY/2

Z0 = CZ – DZ/2, Z1 = CZ + DZ/2

Dynamic index interval - The first and last dynamic frames [t0, t1] between which VROI is extended.
By default, in a 4D dataset, VROI is defined only on the current dynamic frame. Type new values into the
boxes to define a custom interval. Scroll through dynamic variable (using right and left arrow keyboard keys)
to ensure that the VROI has been extended correctly.

All Timepoints – Clicking this button extends the VROI to all dynamic frames in a 4D dataset (for any
dynamic variable, including time, b-value, flip angle, inversion time, etc.). It is equivalent to setting dynamic
index interval to t0=1 and t1=N, where N is the total number of frames in the dataset.

Center, Full Volume, Scale Dimensions - Functions for quick positioning or scaling.

Center moves the VROI so that its center coincides with the center of the image.
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Full Volume extends the VROI to the entire image volume on all slices of the current dynamic frame (use
Dynamic index interval settings to extend to other frames).

Scale Dimensions opens a dialog to enter a scaling factor by which all three VROI dimensions will be
multiplied after the user clicks OK (default, 1, no scaling): DX’ = DX * scale, DY’ = DY * scale, DZ’ = DZ
* scale. Scaling resizes the VROI, but does not change the in-plane coordinates of its center.

14.6 List all VROIs

the total number of VROIs followed by a list of VROI names and the intervals of dynamic indices on which
each VROI is defined.

Opens dialog with the total number of VROIs in the document and a list of VROIs. For each VROI, the
dialog shows the VROI’s name and [t0, t1] - the interval of dynamic indices for which the VROI is defined.
The VROIs are listed in the order of their creation in the document (the same order is followed by Next
VROI (F11)).

The command lists the VROIs regardless of the visibility option set by View > Display/Hide VROI.

14.7 Save VROIs

Saves all vector ROIs in a file with .vroi extension. Opens a file-save dialog to select the directory and
name of the target file, which is given a .vroi extension. This file can be opened using a text editor, such as
Notepad. The .vroi file contains the total number of ROIs followed by each VROI’s defining properties (ROI
label, Windows color code, t0 and t1 dynamic indices, X0, X1, Y0, Y1, Z0, Z1 coordinates).

Note that saving the entire document in the FireVoxel .fvx format also retains all VROIs.

14.8 Load VROIs

Loads VROIs from a previously saved .vroi file.

Opens a browse-for-file dialog to select a .vroi file. Once the user selects this file, the VROIs are recreated in
the document and displayed. If these imported VROis are then modified (resized, repositioned, etc.), they
need to be saved again, either with the document or as a .vroi file.

Note that the command does not check whether the loaded VROIs match the current document, or if they
are already present in the document. If these VROIs are already present in the document, the newly loaded
VROIs will be displayed on top of the existing ones. Duplicate VROIs can be visually identified by their
higher opacity and also by using List all VROIs.
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14.9 Next VROI (F11)

Activates the next VROI (in the order they were created) and display the slice containing its center (note
that voxel coordinates, including slice numbers, start from zero). If the document is in the Film view, the
command switches it to the Slice view. If the active VROI is the last one in the document, the command
circles back to the first VROI. This command is convenient when multiple, overlapping VROIs are present
in the document.

14.10 Enclose connected components by a Vector ROI

Creates a new VROI around each connected component in the active ROI layer. A message shows the number
of VROIs created. If the command is repeated (without any changes made to the raster ROIs or VROIs),
no new VROIs are created. If either the VROI or the raster layer have been modified, the command creates
a new VROI.

14.11 Vector ROI 2D > 3D

Converts a 2D VROI (with Depth < 1 - less than one slice) into a 3D VROI. This function is useful to
improve the visibility of a VROI.

14.12 Rasterize

A VROI can be rasterized, or used to create a raster ROI covering the area enclosed by the VROI.

Rasterize selected Vector entities rasterizes the active VROI, polyline, or spline (contour). The same

operation can be performed by clicking toolbar icon.

Rasterize All Splines rasterizes all splines (contours) with three or more points. The contours may be
created by Magnetic Trace or Insert polyline commands.

Rasterize All Polylines rasterizes all polylines with three or more points (two or more lines).

Rasterize All VROIs rasterizes all VROIs in the document.

The results of the Rasterize commands are added to the active ROI layer. Open the Layer Control panel (by
double left-clicking on the image) to view the document layers. If the active layer is not an ROI layer, a new
ROI layer is created automatically, and rasterized areas are added to this new layer. To add the rasterized
area to a specific ROI layer, activate this layer first by clicking on its name in the Layer Control, and then
apply the Rasterize command.
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14.13 Insert polyline

Launches the polyline drawing tool. Clicking toolbar icon launches the same tool. Click the image to
place control points connected by straight lines. Press Esc to exit the tool.

Active polylines show green control points, like other vector entities. Click the polyline to activate it. Click
away from the polyline to de-activate.

Active polylines can be manipulated. Click and drag individual control points to move and reshape the
polyline. Right-click and drag any location on the polyline to move the entire polyline to a new location.

Active polyline can be deleted by pressing Delete.

Visibility of the polylines is toggled by View > Display\Hide Vector .

For a two-point vector, the direction is indicated by an arrow at the end of the vector. The length (in
millimeters) is also shown in red next to the vector before the second point is placed. To display the length
at all times, use View > Display\Hide Curve Length.

For a three-point sector, the direction is indicated as a green arc with an arrow (from the first segment
towards the second segment). The angle measure (in degrees) is shown in green next to the apex of the
angle. To display the angle at all times, use View > Display\Hide Curve Length.

The properties of the active polyline can be adjusted by double-clicking the polyline or selecting View >
Contour and Fill Properties to open Polyline and Spline properties. The panel allows the user to control the
fill, line, and transparency properties, and also convert the polyline into a spline.

14.14 Delete

Delete All VROIs - Deletes all VROIs in the active document. Polylines and splines are unaffected. The
active VROI can be deleted by pressing Delete. The active VROI will be deleted even if it is not visible.

Delete All Splines - Deletes all splines (contours). VROIs or polylines are unaffected.

Fig. 14.3: VROI (green) co-
ordinates and voxel indices.
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Volume

� Window Center/Width setting

� Advance to (timepoint)

� Crop

� Pad

� Noise

� Smooth over (optional) ROI

� Smooth across Dynamic dimension

� Volume Edge-constrained Smooth

� Inter-Volume Edge-Constrained Smooth

� Non-local Means Denoising

� Texture Edge Detector with optional Constraint ROI

� 3D Edge Detector

� Single Scale Texture Gradient

� Multiscale Texture Gradient

� Multiscale Texture Gradient with 4D Aggregate

� Depth to Time

� Time to Depth

� Copy voxels from current timepoint to target timepoint

� Adaptive Threshold

� Convert 2D Mosaic to Volume

� Volume type conversion
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� Voxel Value Conversion

� Insert Uniform Layer

� Set DICOM tags

� Set Volume Orientation

� Change Patient Position and Orientation

The Volume tab contains commands for manipulating 3D and 4D datasets. This includes cropping, signal
scaling, smoothing, application of edge-enhancing filters and so on. Also included in this tab are tools for
conversion of numeric data type between integer and real and changing data dimensions.

15.1 Window Center/Width setting

These commands automatically adjust the grayscale window center and width to the optimal settings for
selected conditions. See also View > Grayscale Window for details of grayscale window center and width
settings.

This operation is defined for integer and real volumes only. The optimal window center/width setting is
defined as follows. First, all non-void (non-transparent) voxels are sorted into a list by their signal intensity
values. Next, a fixed percentage of all voxels (0.5%) is removed from the top and the bottom of the list.
For the remaining voxels, the range between the lowest and highest signal values is taken to be the optimal
window width and the midpoint of this range as the optimal window center.

15.1.1 Optimal for all slices and timepoints

Automatically adjusts grayscale window center and width to the values optimal for viewing of all slices and
timepoints for a dynamic dataset.

15.1.2 Optimal for current timepoint

Automatically adjusts window center and width to the values optimal for viewing of the current timepoint
(time frame). May be convenient for viewing dynamic series in which image intensity varies in a wide range,
such as dynamic contrast-enhanced MRI or CT images showing high signal enhancement in blood vessels
during the passage of the contrast bolus with.
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15.1.3 Optimal for current ROI

Automatically adjusts window center and width to the values optimal for viewing of the active, visible ROI
layer. If the document contains two or more ROI layers, but the active layer is not an ROI, shows an error
message (Ambiguous Layer Configuration).

15.2 Advance to (timepoint)

Commands in this group help to quickly navigate to an automatically selected frame of a dynamic dataset.

15.2.1 Timepoint of Maximum Info over ROI

Selects and displays the dynamic frame with the maximum information within a raster ROI. Requires a
4D (dynamic) dataset and a single raster ROI. If the document contains two or more ROI layers, shows an
error message (Ambiguous layer configuration). If the document contains no visible ROI, displays the
dynamic frame with the maximum information for the entire image.

In FireVoxel, by default, images (volumes) are compressed to save RAM. Each slice of the volume is com-
pressed separately using three-voxel predictive coding combined with the Huffman entropy encoder. The
compressed size of the entire volume is thus the sum of the sizes of individual slices.

The size of the compressed volume is an indicator of how much information is contained in the volume.
The less uniform the signal within the volume, the more information it contains and the larger the volume’s
compressed size. A uniform volume (a volume containing the same signal values throughout) has nearly zero
compressed size.

This command advances to the timepoint where a 3D volume has the largest compressed size. In dynamic
contrast-enhanced studies, which consist of a series of 3D volumes, the maximum information usually corre-
sponds to the timepoint of the maximum contrast enhancement.

Users may select non-compressed internal representation of the volumes via File >User Interface Options
> RAM Compress Integer volumes (uncheck). Without compression, all slices and timepoints have the
same amount of information, and operations based on maximum information are not meaningful.

15.2.2 Timepoint of Vector ROI peak

Selects and displays the time frame showing maximum image intensity within the active vector ROI (VROI).
If the VROI is not present, or multiple VROIs are present, but none is selected, FireVoxel will show a
corresponding error message (if no VROIs: At least one seed is expected; if multiple VROIs, none selected:
With several seeds present, a single one should be selected). The seed VROI may be 2D, 3D, or 4D.
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15.3 Crop

Selects a user-specified subset of the original dataset. Creates a new document window (named [origi-
nal]_cropped) displaying the selected subset.

15.3.1 Crop with 4D Vector ROI – Active Layer only

Requires a document with an active layer and an active vector ROI (VROI).

Selects a part of the active layer enclosed by the VROI. Creates a new document window (named
[original]_cropped) displaying the selected subset of the active layer. The VROI is not copied to the cropped
document.

The active layer may contain an image (3D or 4D), raster ROI (3D or 4D), or a color map. Even if the active
layer is invisible, it will be cropped and displayed as visible in the new (cropped) document window.

The VROI may be 2D, 3D, or 4D. A 2D or 3D VROI will crop a single slice, volume, or dynamic frame on
which it is defined. Similarly, a 4D VROI will crop only those dynamic frames on which it is defined.

To adjust the dynamic frames, double left-click the VROI to open VROI Properties panel and enter the
dynamic index interval. See Vector for details.

If multiple VROIs are present in the document, but none is selected, the command shows an error message
(More than one Vector ROI is present and none selected).

If the document contains multiple layers, they are not included into the cropped document. To crop multiple
layers, use Crop with 4D Vector ROI — All Layers.

15.3.2 Crop with 4D Vector ROI – All Layers

Requires a document with one or more layers and an active vector ROI (VROI).

Selects a part of all layers in the document enclosed by the VROI. Creates a new document window
(named [original]_cropped) displaying the selected subset of the original document. The VROI is not copied
to the cropped document.

The original document may contain images (3D or 4D), raster ROIs (3D or 4D), or color maps. Both visible
and invisible layers will be cropped, but invisible layers will remain invisible in the new (cropped) document
window.

The VROI may be 2D, 3D, or 4D. A 2D or 3D VROI will crop a single slice, volume, or dynamic frame on
which it is defined. Similarly, a 4D VROI will crop only those dynamic frames on which it is defined.

To adjust the dynamic frames, double left-click the VROI to open VROI Properties panel and enter the
dynamic index interval. See Vector for details.

If multiple VROIs are present in the document, but none is selected, the command shows an error message
(More than one Vector ROI is present and none selected).
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15.3.3 Crop current timepoint

Requires a dynamic (4D) image. Selects a single frame (3D volume) at the current value of dynamic variable
(such as time, b-value, flip angle, inversion time, Dixon contrast, etc.) Creates a new document window
(named [original_image]_cropped) showing the selected (cropped) volume.

The dynamic variable and dynamic index are shown in the status bar at the bottom left corner of the software
window (Fig. 30.2).

If the original document contains other visible layers (including ROI layers), they are copied into the cropped
document. The layers that are invisible in the original document are not included into the cropped document.
Vector ROIs are not retained.

The original document remains unchanged.

15.3.4 Crop current slice

Requires a 3D or 4D image in the active document window. Selects the current slice (e.g., slice number
P) from the original document. Creates a new document window (labeled [original]_slP) showing the
selected slice.

If the original document contains a 3D image, the cropped image is a 2D slice. If the original document
contains a 4D image, the cropped image is a 2D slice at all dynamic points of the original document. All
raster ROI layers (both visible and invisible) and vector ROIs are replicated in the cropped document.

15.3.5 Extract specified dynamic points

Requires a 4D image. Opens a dialog prompting the user to enter the indices of the dynamic variable to be
selected. These indices may be separated by commas (e.g., 1, 3, 9) to select individual dynamic frames, or
by dashes (e.g., 1-10) to select a range of indices.

Creates a new document window (labeled [original]_cropped) with a 4D image that includes the 3D
volumes with the specified dynamic variable indices.

For example, the user selects time points 1, 3, 9 from a time series, the cropped image will contain volumes
at time points number 1, 3, and 9. If the user selects dynamic points 1-10, the cropped image will contain
the first ten images of the dynamic series.

15.3.6 Remove specified dynamic points

Requires a 4D image. Opens dialog prompting the user to enter an index (or indices) of the dynamic variable
of the 3D volumes that will be removed from the original 4D image.

Creates a new document window (labeled [original]_cropped) with a 4D image in which the specified
dynamic frames are absent.

If the dynamic variable is time (with the time points from t1=0 s to tN), and the first K points are removed
[t1, tK], the time points of the remaining images [tK+1, tN] are adjusted by subtracting tK+1 so that the time
points of the cropped image are in the interval of [0 s, tN — tK+1].
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If the original document contains invisible layers, they are not replicated in the cropped document. However,
visible layers (images, ROIs, maps) are retained.

15.4 Pad

Requires a document with an active layer (visible or invisible). Opens dialog (Specify Pad size (mm)) to
enter padding size in millimeters.

Creates a new document window (named [active_window]_pad) with padded image, in which zero
intensity voxels added to each dimension of the original volume.

The dimensions of the padded image are (w+p, h+p, d+p), where w, h, and d are the width, height and
depth of the original image (in mm), and p is the pad size. If the image is 4D, each frame of the original
dynamic series is padded. The voxel size of the padded image is the same as the original voxel size. The
matrix of the padded image is increased by the number of added padding voxels.

15.5 Noise

Returns the noise values estimated using different methods for the image in the active layer. Displays
the results in FireVoxel image processing dialog. Use Ctrl+C, Ctrl+V to copy and paste these results
elsewhere.

15.5.1 Effective Noise

Requires an integer image. Returns the value of effective noise.

This is effectively a 2D algorithm. The algorithm scans all slices within the volume and for each slice measures
the average signal within a 2D window (10 mm x 10 mm). The window with the lowest average signal and
assumed to contain air. The effective noise is then computed from the Rayleigh distribution: Mean_Signal
= Noise ×

√︀
𝜋/2.

15.5.2 Background Noise

Requires an integer image or a real image without VOID voxels. Returns the value of background noise.

The original volume is first converted to Isotropic Edge Voxels. Next, the 3D edges in the volume are detected
using proprietary Texture Edge Detector algorithm. All voxels whose six-voxel neighborhood (in 3D) does
NOT contain edge voxels are considered to be central voxels. For such central voxels, the algorithm computes
the difference:

D = |Signal(Center) – AverageOfSixNeighbors(Center)|.

This difference is accumulated and its average value is calculated for the entire volume. The resulting average
value is background noise.
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15.5.3 Median Noise

Requires an integer or real image. Returns the value of median noise.

The volume is first smoothed with the 3D median filter with radius R = 1. The purpose of median smoothing
is to remove the noise without disturbing the volume edges. The difference between the original and smoothed
voxels is then computed over the entire volume. This difference is averaged over all voxels and is returned
as median noise.

15.5.4 Local 2D Difference Noise

Requires an integer or real image. Returns the value of local difference noise.

Calculates the average differences between each voxel and four of its nearest horizontal and vertical neighbors
(in 2D). Computes this difference for all voxels. Sorts differences by value, then takes the lower half of this
sorted array (to presumably exclude edges) and calculates the average noise (local difference noise).

15.6 Smooth over (optional) ROI

Computes a smoothed image by convolving the original image with a normalized 3D spherical (if 3D smooth-
ing is selected) or circular (if 2D is selected) kernel, or filter, with user-selected radius.

Creates a new layer with smoothed image.

Requires a 3D or 4D image, integer or real, in the active layer. For a 4D (dynamic) dataset, each dynamic
frame is smoothed independently. May use an optional ROI to perform smoothing only within this ROI.

Once called, the command opens dialog to adjust the smoothing parameters (Volume Smooth parameters,
Fig. 15.1).

Fig. 15.1: Volume Smooth parameter dialog.

Parameters:
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� Process 3D (checkbox) – Selects spherical (3D, if checked) or circular (2D, if unchecked) smoothing.

� Kernel Type – Smoothing kernel options include: Uniform (default), Gaussian, Radial, Raleigh,
Median, Minimal SI, and Maximal SI.

� Radius (vox) – Filter radius (in voxels).

� Constrain by Mask (checkbox) – If checked, the visible ROI is used to perform smoothing only
within this ROI. If the document contains two or more visible ROIs, this option is unavailable. To use
it, uncheck visibility of all ROIs except one.

Example:

Consider a 2D uniform (kernel type: Uniform) smoothing using a filter with the radius of 2 voxels. FireVoxel
convention is to define a single voxel as having the radius equal to 0. This means that the diameter of the
circle of radius 2 voxels is 5 voxels (diameter = 2 x radius + 1). The “circular” and symmetric kernel with
weights 𝑘𝑖, 𝑖 = 1 : 4, is shown below:

𝑀 =

⎡⎢⎢⎢⎢⎣
0 0 𝑘4 0 0
0 𝑘3 𝑘2 𝑘3 0
𝑘4 𝑘2 𝑘1 𝑘2 𝑘4
0 𝑘3 𝑘2 𝑘3 0
0 0 𝑘4 0 0

⎤⎥⎥⎥⎥⎦ (15.1)

In this example, the kernel has 13 non-zero weights. Since the kernel is uniform, 𝑘1 = 𝑘2 = 𝑘3 = 𝑘4. All
smoothing kernels are normalized, meaning that the sum of 13 weights is 1.0. So in this example all 𝑘𝑖
weights are equal to 1/13 ≈ 0.076923.

The smoothing operation works as follows. The kernel is positioned so that the central element 𝑘1 is above
a target voxel. The values of 25 image voxels located under this kernel are multiplied by the corresponding
weights 𝑘𝑖 and all products are summed. The resulting sum is the voxel value of the target voxel in the
smoothed image. The kernel is then moved to the next voxel and the process is repeated until the entire
smoothed image is computed.

For the uniform kernel, the weights 𝑘𝑖 are all equal, and as a result, the smoothed voxel is the average of its
13 neighboring voxels. For the Gaussian kernel, the weights 𝑘𝑖 are given by the values of a Gaussian function.

15.7 Smooth across Dynamic dimension

Computes a smoothed dynamic image. Requires a 4D image – integer, real, or 4D raster ROI.

Creates a new layer with the smoothed image.

Once called, the command opens dialog (Specify integer) to select Dynamic Smooth Radius, or the number
of dynamic frames over which the intensity will be smoothed.

Smoothing is performed for each 3D coordinate (x,y,z) independently. For the dynamic coordinate value N
and user-selected dynamic smooth radius Rad, the signal intensity values are averaged for all voxels within
the dynamic coordinate interval [N-Rad, N+Rad]. Void voxels are excluded from averaging. If a voxel (x,y,z)
at dynamic variable N is VOID, it remains VOID in the smoothed image.
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15.8 Volume Edge-constrained Smooth

Computes a smoothed image within areas constrained by automatically determined edges.

Requires a 3D or 4D image, integer or real, in the active layer. For a 4D (dynamic) image, each dynamic
frame is smoothed independently. Creates a new, integer layer with the smoothed image.

Once called, the command opens dialog to adjust the smoothing parameters (Edge-Constrained Smooth, Fig.
15.2):

Fig. 15.2: Volume Edge-Constrained Smooth dialog.

Parameters:

� Edge volume – Folder location of the edge volume.

� Smoothed volume – Folder location of the smoothed volume.

� Edge noise level [value] – Noise level measured. . .

� Edge Settings – Access to a secondary dialog for adjusting the Edge Settings (3D Edge Detector).
Default – button resets Edge Settings to defaults.

� Regional smooth filter – Kernel type of the regional filter. Options include: Average (default),
Median, Gaussian.

� Regional smooth radius (vox) – Radius of the smoothing aperture (in voxels).

� Final smooth radius (vox) – Radius (in voxels). . .
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15.9 Inter-Volume Edge-Constrained Smooth

Requires a 4D (dynamic) image (?).

If the image in the active layer is incompatible, shows an error message (No suitable imag`present or
enabled). Creates a new layer with the smoothed image (real-valued, grayscale).

Once called, the command opens dialog (Edge-Constrained Smooth, same as Fig. 15.2) to adjust the
operation parameters.

15.10 Non-local Means Denoising

Computes a denoised image using a non-local means (NLM) filter. Requires a 3D or 4D image, integer or real,
in the active layer. If the image is 4D (dynamic), applies denoising to each dynamic frame independently.

Creates a new layer with denoised image.

Once called, the command opens dialog (Non-local Means Denoising, Fig. 15.3) to enter the parameters
of the NLM filter.

Fig. 15.3: Non-local Means Denoising Dialog.

This procedure is based on the most popular non-local means (NLM) denoising algorithm [Buades2005]. The
non-local means filter takes the mean of all voxels in the image weighted by the similarity of these voxels’
neighborhood to the neighborhood of the target voxel. FireVoxel extends the original 2D algorithm to 3D
and makes it fully parallel to gain speed.

Parameters:

� Use 3D – If checked, applies the 3D patch and searches over the entire volume.

� Patch radius (vox) – The size (in voxels) of the spherical patch contained within the specified (real)
radius. Typically, the radius is in the [1,5] interval. Note: Processing time grows roughly as radius^3
(radius cubed), and higher radius values must be done judiciously.
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� Search radius (vox) – The size of the rectangular area where search and accumulation of the similarity
score is performed. Theoretically, this size should be equal to the entire volume. However, since the
execution time grows roughly as the radius^3 (radius cubed), typically search radius=10 is used. Higher
or lower values may be used depending on the user’s hardware.

� Noise sigma – A measure of the noise level. Controlled by the user to achieve how strong denoising
is.

� Get Noise (button) – Calculates the Local Difference noise to give the user an anchor value for
operation.

� Noise coefficient – Enables the choice between the two similar formulas in the NLM implementation
paper. Note: Build 373 – This parameter is currently not used, but will be implemented in the future
versions to allow access to the second formula.

15.11 Texture Edge Detector with optional Constraint ROI

Requires a 3D or 4D image, integer or real. May also use an optional constraint ROI. Creates a new layer
with the edge map (real-valued, rainbow colormap by default).

When the command is selected:

� If the document contains a visible ROI layer, a dialog pops up:

� If Yes is selected, then processing will be done only within this ROI. If No is selected, then the entire
image will be processed. If the document contains two or more ROI layers, an error message is shown
(Ambiguous layer configuration).

� If the image is 4D, a dialog appears (Process all timepoints?):

� If Yes is selected, each dynamic frame will be processed independently and the result will also be a 4D
image. If No is selected, only the current frame will be processed, and the result is 3D.
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� Next, the main dialog appears (3D Edge Detector, Fig. 15.4) to adjust the parameters of edge
detector. Processing starts once the user clicks OK.

15.12 3D Edge Detector

The 3D Edge Detector dialog (Fig. 15.4) is used by several commands, including Volume > Volume
Edge-constrained smooth and Inter-Volume Edge-constrained smooth, among others.

Fig. 15.4: 3D Edge Detector Dialog.

Parameters:

� Low radius\High radius [1-20] (vox) – Lowest and highest size of features calculated (in voxels).
Default: 2.960 voxels.

� Distance Metric – Calculation type for histogram comparison. The options include Signal Difference
or Histogram EMD (Earth Mover Distance).

� Voxel Weights – Choice of voxel weights to account for the voxel distance to the aperture center.
The options include Constant, Gaussian, Radial, and Rayleigh.

� Edge signal threshold – Signal intensity threshold.

15.13 Single Scale Texture Gradient

Calculates texture gradient for the user-selected single level of features (characteristic size). This function
uses an optional ROI (in which case the analysis is performed only within this ROI) and also optionally
processes all timepoints in a 4D image. When the command is selected:
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� If a visible ROI is present, a question pops up:

� If Yes is selected, the gradient map is calculated only within the selected ROI. If No is selected, the
gradient map is computed for the entire image.

� Next, if the original image is a 4D image, a dialog box pops up:

� If Yes is selected, the operation is applied to all timepoints (each dynamic frame is analyzed indepen-
dently) and the resulting gradient map is also 4D. If No is selected, the operation is applied only to
the current timepoint and the resulting gradient map is 3D.

� Next, the main dialog appears (Single Scale Texture Gradient, Fig. 15.5) and processing starts
once the user clicks OK.

Fig. 15.5: Single Scale Texture Gradient dialog.

Parameters:
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� Radius (mm) – Level (characteristic size, in millimeters) of the image features calculated.

� Distance Metric – Calculation type for histogram comparison. The options include Signal Difference
or Histogram EMD (Earth Mover Distance).

� Voxel Weights – Choice of voxel weights to account for the voxel distance to the aperture center.
The options include Constant, Gaussian, Radial, and Rayleigh.

� Magnitude measure – Filter response value is converted to the output value based on 3 different
schemes: Linear, Logarithm, Normalized.

� Normalization Coefficient – Coefficient used in Magnitude Measure=Normalize.

15.14 Multiscale Texture Gradient

Calculates texture gradient for the range of feature levels and for each voxel selects the maximum magnitude
of the gradient. During segmentation, different regions may be better separated at different feature levels,
and therefore an operation probing a range of feature levels may be able to separate these regions. This
function can also use an optional ROI and optionally process all timepoints. When the command is selected:

� If a visible ROI is present, a question pops up:

� If Yes is selected, the resulting gradient map will be calculated only within the selected ROI. If No is
selected, the gradient is calculated over the entire image.

� Next, if the original image is a 4D image, a dialog box pops up:

� If Yes is selected, the operation is applied to all timepoints (each dynamic frame is analyzed indepen-
dently) and the resulting gradient map is also 4D. If No is selected, then the operation is applied only
to the current timepoint (or dynamic frame) and the resulting gradient map is 3D.

� Next, the main dialog box appears (Multiscale Texture Gradient, Fig. 15.6) and processing starts
once the user clicks OK.
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Fig. 15.6: Multiscale Texture Gradient dialog.

Parameters:

� Low radius\High radius (vox) – Specifies the range of features calculated (in voxels). Note the
difference from the Single Scale Gradient radius, which is in mm. Default: 2.6 voxels.

� Distance Metric – Calculation type is Signal Difference or Histogram EMD (Earth Mover Distance).

� Voxel Weights – Choice of voxels weights to account for voxel distance to the aperture center.

� Magnitude Measure – Filter response value is converted to the output value based on 3 different
schemes: Linear, Logarithm, Normalized.

15.15 Multiscale Texture Gradient with 4D Aggregate

This function is similar to the regular multiscale texture gradient, but works only for 4D Volumes. During a
dynamic exam, the best separation between various pairs of regions may be achieved at different timepoints.
To take advantage of these optimal separations, the function calculates the Multiscale Texture Gradient for
each timepoint separately. Then 4D Aggregate operation is performed, when for each voxel the maximum
gradient magnitude is selected across all timepoints and assigned to the resulting map. Note that the result
of this operation is always a 3D gradient map. When the command is selected:

� If a visible ROI is present, a question pops up:

� If Yes is selected, the gradient map is calculated only within the ROI.

� Next, the main dialog box appears (the same interface as for Multiscale Texture Gradient, Fig.
15.6) and processing starts once the user clicks OK.

Parameters:
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� Low radius\High radius (vox) – Specify the lowest and highest size of features calculated (in voxels).
Note the difference to the Single Scale Gradient radius, which is in mm. Default: 2.6 voxels.

� Distance Metric – Calculation type includes Signal Difference or Histogram EMD (Earth Mover
Distance).

� Voxel Weights – Choice of voxels weights to account for voxel distance to the aperture center. The
options include Constant, Gaussian, Radial, and Rayleigh.

� Magnitude Measure – Filter response value is converted to the output value based on 3 different
schemes: Linear, Logarithm, Normalized.

15.16 Depth to Time

Requires a 4D image with dimensions W x H x D x N, where W, H, and D are width, height and depth,
respectively, and N is the number of dynamic frames. Creates a new document window named [ac-
tive_window]_DtoT displaying the current dynamic frame as W x H x 1 x D image. To scroll through slices,
the user may use Right and Left arrow keys on the keyboard.

If applied again to the W x H x 1 x D image, creates a new document window displaying only the
current slice (W x H x 1 x 1).

15.17 Time to Depth

Requires a single slice across multiple dynamic points, W x H x 1 x N (for other dimensions, shows an
error message: Volume should contain a single z-slice.) Creates a new document window named
[active_window]_TtoD with reformatted image with dimensions W x H x N x 1. If used again on this new
image, shows an error message: 4D volume required.

15.18 Copy voxels from current timepoint to target timepoint

Opens dialog (Specify Integer) to enter the target dynamic point index where the current dynamic frame
will be copied. Copies, voxel-by-voxel, the current 3D dynamic frame onto the specified dynamic frame.

15.19 Adaptive Threshold

Build 373+: See ROI > Local Otsu Threshold to ROI .
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15.20 Convert 2D Mosaic to Volume

Requires a mosaic image (2D). Mosaic is a Siemens format for storing and displaying a 3D image as a 2D,
square array of slices shown as tiles from top left, row by row, to bottom right.

If the original 3D image has voxel dimensions of W x H x D (in the column, row, and slice directions,
respectively), the dimensions of the mosaic image are (p x W) x (p x H), where p is an integer (

√
D rounded

up to the next integer). Thus, the mosaic is the smallest square array that accommodates all slices of the
original image.

Opens dialog (Specify Integer) to enter the number of images in the mosaic. The default number of images
is obtained from the private DICOM tag 0019,100A (Number of images in mosaic).

Transforms the mosaic into a regular 3D image with W x H x D dimensions. Creates a new document
window displaying the transformed image.

Other relevant tags are: Acquisition Matrix (0018,1310) (frequency rows\frequency columns\phase
rows\phase columns), Rows (0028,0010), Columns (0028,0011).

In a regular 3D image, the Columns tag is usually equal to the frequency columns value in the Acquisition
Matrix. For example, for a 3D image, the image dimensions tags may be as follows: 0018,0093 Percent
sampling 80 0018,1310 Acquisition Matrix 0\320\256\0 0028,0010 Rows 320 0028,0011 Columns 320

In a mosaic, the Acquisition Matrix tags indicate the dimensions of the individual images, whereas the
Rows and Columns tags contain the dimensions of the larger mosaic image, equal to the multiples (p) of
the dimensions of the individual images. For example, for a 5 x 5 mosaic: 0018,1310 Acquisition Matrix
0\80\62\0 0028,0010 Rows 400 0028,0011 Samping 310

Note that these tags indicate the dimensions of the individual images and the minimum dimensions of the
square table required to accommodate this 3D image, but not the total number of images.

15.21 Volume type conversion

These commands convert images into different data types. Converted images are placed in new, automatically
created layers.

15.21.1 Real to integer

Requires a visible real-valued image (in the active layer or another layer). Opens dialog (Specify Integer)
to enter the number of Resulting Bits for integer-valued image (15 by default). Creates a new layer in the
active document window (named [original_layer]_integer) with the original layer converted to integer-valued
image. The new layer is displayed with the same grayscale window width and level as the original layer.

If the active layer is not a real-valued image and there are no other visible real-valued layers, an error message
is shown (Real valued volume is required). If the active layer is not a real-valued image, but there are
two or more visible real-valued layers, the first visible layer (as listed in the Layer Control) is converted.
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15.21.2 Integer to real

Requires integer-valued image in the active layer. Creates a new layer (named [original_layer]_real)
containing the original layer converted to a real-valued image.

If the active layer is not an integer-valued image, an error message is shown (Signal intensity volume is
required).

15.21.3 ROI to integer

Requires a visible ROI layer. Creates a new layer (named [original]_integer) with voxel values obtained
from the voxel values of the original layer converted to integer signal intensity. The new layer is displayed as
a rainbow colormap with the window width/level of 1/0.5 and opacity of 100%.

If the active layer is not an ROI layer, and there is no visible ROI layer in the document, the command shows
an error message (Signal intensity volume is required).

15.22 Voxel Value Conversion

15.22.1 Equalize Histogram

Formerly Volume > Voxel Value Conversion > Flatten Histogram.

The algorithm has been revised to match the classic description of the Histogram Equalization algorithm.

Requires a 3D integer image in the active layer. Does not work for any other images. There are no parameters
for this operation.

Creates a new layer in the same document window (named after as the original layer). The distribution
of intensities of the resulting image may be examined using Layer Control > ROI Stats 3D .

15.22.2 Linear conversion over ROI

Attention: Linear conversion modifies voxel values of the original image. Use Undo/Redo toolbar
features if dissatisfied with results.

Keywords: scale, rescale, multiply, divide, normalize, ratio

Applies linear transformation to the image intensity values. Requires an active image layer. May also be
used with a visible raster ROI layer. If the document has a visible ROI, the transformation is applied only
within this ROI. If a visible ROI is not present, or if there are two or more visible ROIs in the document,
the conversion is applied to the entire image.

Opens dialog (Linear Conversion, Fig. 15.7) to specify the parameters of linear conversion:

S1 = C x S0 + B,
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where C is the coefficient, B is the bias, and converted S1 is truncated within the user-specified signal interval
[Low Limit, High Limit].

The operation replaces voxel intensities of the original image (S0) with the transformed values (S1) within
the ROI (if a visible ROI is present) or within the entire image (if an ROI is not present). The S1 values
that fall below the Low Limit or above the High Limit are replaced with the corresponding limit values.

Fig. 15.7: Voxel value linear conversion over ROI.

Example: Scale the image signal intensity within a selected area down by a factor of 7.

1. Open Layer Control .

2. Draw an ROI manually over the selected area or use segmentation tools such as EdgeWave Segmenta-
tion. If the area contains only a few voxels, use Paintbrush and enter Radius of 0 voxels in Paintbrush
Properties to select individual voxels one by one. Make sure that the ROI layer is visible.

3. Activate the image layer in Layer Control by clicking on its name.

4. Select Volume > Voxel value conversion > Linear conversion over ROI. Enter Coefficient =
0.143 (= 1/7), Bias = 0, and appropriate Low and High Limit values (Fig. 15.7). Click OK.

5. The intensity values within the ROI will be replaced with the scaled values. If necessary, use Window
and Level tool to adjust the grayscale window for optimal viewing of the transformed values.

6. If dissatisfied with the result, use Undo function to revert to the original state. Adjust the transforma-
tion parameters and repeat the operation with these new parameters.
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15.22.3 Invert

Requires an image in the active document.

Attention: Invert modifies voxel values of the original image. Use Undo/Redo toolbar features if
dissatisfied with results.

For real and integer volumes: Replaces the original voxel intensities S0 with symmetrical intensities about
the middle of the interval [S0min, S0max]. The distributions of the original and inverted signal intensities can
be examined using the histogram using Layer Control > ROI Stats 3D .

For ROI layers: Changes the value of each voxel to the inverted value (0<—>1): vnew = 1—v, where v
and vnew are the old and the new (inverted) voxel values, respectively.

Note: If you wish to modify only the appearance of the image (rather than the image intensity values),
use Layer Control > View Filter and check Invert Scale checkbox. This option inverts the display of
grayscale (the order of gray values) without changing the voxel values in the volume.

15.22.4 Logarithm Conversion

Requires an image in the active layer.

Creates a new, real-valued layer in which voxel intensities S1 are a log function of the original intensities
S0: S1= log(S0). By default, the new layer is displayed as a rainbow color map.

15.22.5 Scale to Interval

Requires an image (integer or real) in the active layer.

Modifies voxel values of the original image. The original voxel signal intensities S0 are replaced with
transformed intensities S1. Opens dialog (Specify Signal Range) to enter [S1min, S1max], the minimum and
maximum values of the transformed intensity.

The original voxel intensities in the active layer, S0, are replaced with transformed intensities S1(x,y,z) =
S1min + (S0(x,y,z) – S0min) x (S1max – S1min)/(S0max – S0min).

15.22.6 Change Specified Signal to Transparent

Requires an image in the active layer.

Modifies voxel intensities of the original image. Opens dialog (Specify Make Specified Signal
Transparent) to enter signal intensity value to be replaced with a transparent voxel. Replaces voxels with
user-specified intensities with transparent voxels.
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15.22.7 Change Transparent to Specified Signal

Requires an image in the active layer, presumably containing transparent voxels. Modifies voxel intensities
of the original image.

Opens dialog (Specify New value for transparent signal) to enter the signal intensity value to be assigned
to transparent voxels. Replaces transparent voxels with opaque voxels with this user-specified intensity value.

15.23 Insert Uniform Layer

Opens dialog (Specify Uniform signal value) to specify the signal intensity value.

Creates a new, real-valued layer with all voxels having this user-specified intensity. The new layer is
shown as a colormap and is placed on top of all existing layers in the document.

15.24 Set DICOM tags

Opens dialog (Specify string) to enter MRI sequence parameters. Modality is not checked. The new values
overwrite the original value of the corresponding DICOM field.

15.24.1 Set TR (Repetition time)

Enter TR in ms. The new value is written into DICOM field RepetitionTime (18,0080).

15.24.2 Set TE (Echo time)

Enter TE in ms. The new value is written into DICOM field EchoTime (18,0081).

15.24.3 Set FA (Flip angle)

Enter Flip Angle in degrees. The new value is written into DICOM field FlipAngle (18,1314).

15.25 Set Volume Orientation

Opens dialog (Specify string) to enter a sequence of four letters, specifying the orientation of the volume
with respect to the screen directions, [Top, Bottom, Left, Right]. The letters should always form a 4-
letter combination without spaces or punctuation marks: SIRL, APLR, etc. If the user enters implausible
orientation, a warning will be displayed.

The allowed direction labels are: L — left, R — right, A — anterior, P — posterior, S — superior, I —
inferior.

Example: If the volume orientation is set to LRAP
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� top of the screen becomes L,

� bottom — R,

� left — A,

� right — P.

15.26 Change Patient Position and Orientation

Opens dialog (Specify Image Position/Orientation Patient, Fig. 15.8) to change the position and
orientation of the patient.

Fig. 15.8: Specify Image PositionOrientation Patient panel.

The Position and Orientation coordinates are read from DICOM header fields ImagePositionPatient
(20,0032) for starting slice and ImageOrientationPatient (20,0037).

Clicking Align with scanner changes the orientation so that for each slice the orientation axis is aligned
with one of the scanner axes (1,0,0), (0,1,0), or (0,0,1).
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Chapter 16

Texture Edge Detection

� About edge detection

� FireVoxel commands with texture edge detection

� FireVoxel’s edge detection algorithm

� Distance metrics: Signal difference and Earth Mover Distance

16.1 About edge detection

Edges in a 2D digital image are lines (or surfaces in 3D) where image intensity changes abruptly (discontin-
uously). Edge detection is a fundamental step in 2D image processing, image analysis, pattern recognition,
and computer vision. The purpose of 2D edge detection is to create an edge map that may be used to
separate (segment) the image into subsets that belong to different meaningful components.

The currently available edge detection methods can be roughly divided into two groups: search-based and
zero-crossing based. The search-based methods detect edges by estimating the edge strength as a first-order
derivative (gradient magnitude and direction) and finding a directional maximum. The zero-crossing based
methods search for zeros in a second-order derivative.

For digital images, gradients (partial derivatives) can be estimated as images of differences between the
intensities of adjacent pixels in a given direction. Thus, the x-direction gradient can be estimated from pixel
intensities S as S(i+1,j,k)–S(i,j,k). However, this approach is not robust to image noise, because noise is
magnified when differences between pixels are computed. FireVoxel uses a different approach to defining the
gradient, better suited to medical images.
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16.2 FireVoxel commands with texture edge detection

In FireVoxel, several commands and operations perform edge detection or include it as a component of their
algorithms, mainly to perform segmentation and delineate image structures:

� Volume >

– Volume Edge-constrained smooth > Edge Settings > 3D Edge Detector

– Inter-Volume edge-constrained smooth

– Texture Edge Detector with optional Constraint ROI

– Single Scale Texture Gradient

– Multiscale Texture Gradient

� Segment > EdgeWave > 3D Edge Detector

� Trace >

– MagTrace settings > Edge Parameters > Multiscale Texture Gradient

– Application-specific settings

16.3 FireVoxel’s edge detection algorithm

FireVoxel’s unique edge detection algorithm is based on the continuous half-sphere design. Consider a disk
of radius r centered on a given pixel in 2D, or a sphere around a voxel in 3D (Fig. 16.1). Note that the center
of the disk or sphere is positioned at the vertex of the voxel rather than voxel center. The diameter splits
this disk into two halves A and B (or a plane splits the sphere in 3D into two hemispheres).

Fig. 16.1: Disk divided by “compass needle” into two halves, A and B.

The direction and magnitude of the gradient may be determined by finding the (A, B) split with the greatest
difference between the halves. This is achieved by “spinning the compass needle” and considering all (infinite)
possible orientations of the (A,B) split. For an image made of discrete voxels, there is a limited number of
unique ways the voxels inside the disk/sphere can be divided between the two halves. Each such split
produces a unique gradient orientation, along the vector from the center of the sphere to the center of mass
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of all voxels in one hemisphere. The gradient magnitude is the edge strength, defined (in the simplest case)
as the difference between the average signal in the two halves:

E = avg(A)–avg(B).

Note that this definition is more robust than digital x-directional gradient.

The radius of the disk/sphere determines the characteristic size (level) of the image features probed by the
edge detector. However, the number of the unique (A, B) splits grows steeply with the radius. For example,
for a sphere with r=3 voxels (as in Figure 1), there are 1053 possible splits. For a sphere with r=4, the
number of splits is already X. Thus, selecting a larger radius may significantly increase the computation
time.

Fig. 16.2: Compass operator of Ruzon and Tomasi dividing the disk into wedges.

The compass operator with the “spinning needle” was first introduced by Ruzon and Tomasi (Ruzon 1999)
to detect step edges by splitting the circle into a finite number of wedges (Fig. 16.2). FireVoxel’s algorithm
incorporates two significant innovations over the original compass operator: a) generalization to 3D, and b)
fully continuous implementation of the spinning plane.

16.4 Distance metrics: Signal difference and Earth Mover Distance

The signal distributions in the two hemispheres are compared using the distance metrics. FireVoxel offers
two distance metrics: signal difference and Earth Mover Distance (EMD) (Rubner 2000). The EMD was
an innovative feature of the compass operator edge detector, and FireVoxel retains this feature. The EMD
method is sensitive to image texture, which describes the spatial variation of the image intensity and color.
EMD is thus well-suited for medical images, which are typically rich in subtle detail.
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EMD yields at each voxel a texture-sensitive gradient with the magnitude equal to the largest EMD be-
tween the histograms. FireVoxel considers voxels with only one signal component (signal intensity), which
substantially simplifies the definition of the EMD for radiological images. In this case, EMD measures the
distance between two histograms, in which each bin corresponds to a single unit of the signal intensity for
integer-valued voxels. Real-valued volumes are first discretized to 16-bit integer volumes, which can then use
the same EMD definition.

The signal difference method accounts only for the difference between intensity and is not sensitive to texture.
However, it is substantially faster than EMD and may therefore be preferable in some cases.

For both metrics, the direction of the vector normal to the splitting plane is also available and can be used
to generate vector gradient fields. The direction of the gradient is used for 3D non-maxima suppression, an
essential part of any edge detector similar to 2D non-maxima suppression in Canny edge detector. For the
EMD metric, the calculated distance is a scalar, and while the 3D axis of the gradient is known, it does not
have a direction. For EMD, the gradient direction is determined as for the signal difference, but the gradient
magnitude is equal to the EMD.

Note that FireVoxel’s edge detector is superior to the Canny edge detector even in the signal-difference
mode. In the Canny edge detector, Gaussian smoothing is first applied to the image before gradients are
determined and edges are tracked. This Gaussian smoothing blurs the subtle boundaries often found in
medical images (e.g., between adjacent organs) and the exact position of the edge becomes imprecise. In
contrast, in FireVoxel the edge detector does not contain the smoothing step, and the edges can accurately
follow even subtle boundaries.
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Chapter 17

Texture Analysis

� Texture analysis in FireVoxel

� Texture algorithm

� Texture batch tool

Quantitative imaging biomarkers are increasingly used in cancer imaging to identify tumor stage and ag-
gressiveness. One of the most promising biomarkers is image texture – a quantitative measure of spatially
organized, quasi-periodic patterns, or granulations, with a specific brightness and smoothness. The texture
feature vector derived from the signal within the tumor in combination with clinical and genetic information
may be useful in predicting disease aggressiveness and outcome.

This team at NYU Radiology has established a strong association between texture measured using MRI,
PET, and CT images and histological characteristics of the kidney, prostate, and breast tumors [1-11]. These
and other studies provide increasing evidence that image texture reflects the underlying properties of cancer
that may be used to support clinical decisions and improve patient care. FireVoxel contains analytical tools
for computing texture feature vector for individual images and batch processing.

17.1 Texture analysis in FireVoxel

FireVoxel’s texture analysis algorithm mimics the biological patterns of cancer growth by separating the tumor
and the surrounding region into concentric 3D shells (Fig. 17.1). This approach enables capturing the spatial
variation of texture features that cannot be obtained by conventional methods. The software combines texture
from all available images, such as images acquired by multiple modalities as well as computed parametric
maps.
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17.2 Texture algorithm

To generate the texture feature vector, FireVoxel’s algorithm executes nested loops L1-L4:

L1: for each imaging modality

L2: for each region of interest (ROI)

L3: for each spatial scale (filtering size)

L4: for each concentric inner & outer ring

compute signal characteristics & append to feature vector

Here promising modalities may include CT and MRI, as well as MRI-derived maps of the apparent diffusion
coefficient (ADC) and volume transfer constant Ktrans. The L4 loop may include the surrounding rings, the
inner ring, and the remaining core (Fig. 17.2). The L3 loop includes the original image and various filtered
versions at a given feature size (Fig. 17.3). The computed signal characteristics include the mean, standard
deviation, skewness, kurtosis, and entropy.

Fig. 17.2: Tumor segmented into concentric rings.

FireVoxel’s texture analysis tool introduces optional 3D image filters that modify the original image. The
dual goal of filtering is to (a) extract features of given granularity size (Fig. 17.3); and (b) suppress image
artifacts. The current texture-sensitive filtering is based on the analysis of a spherical vicinity S of each
voxel. FireVoxel’s algorithm considers all possible splits of S into two hemispheres {S+, S-} and identifies
one in which these hemispheres have the most distinct histograms. Histograms are compared using either a
simple bin-by-bin difference or a sophisticated Earth Mover Distance method [12]. This yields at each voxel
the texture gradient with the magnitude equal to the largest difference between histograms.
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Fig. 17.3: Feature identification on MRI image by 3D filtering. A: original image; B: the same image filtered
by texture gradient sensitized to 1-mm features; C: image filtered and sensitized to 3-mm features..

17.3 Texture batch tool

Fig. 17.1: Schematic
of Tumor Growth: a)
early stage tumor, b)
advanced tumor with
a proliferating outer
layer, quiescent inner
layer and necrotic core.

FireVoxel’s batch tool enables performing texture analysis on a collection of cases in one source folder. All
study cases must be saved as FireVoxel documents (*.fvx), which allows saving multiple coregistered images
and ROI masks in a single file. It is important to name imaging modalities and ROIs consistently across the
study for easier identification of the results.

With no images loaded, select Applications > Region Heterogeneity Analysis Batch process (Fig.
17.4). This opens the dialog to configure the analysis (Fig. 17.5). The settings in this dialog are described
below.

17.3. Texture batch tool 129



FireVoxel: User Manual, Draft 2025-04-29

Source Folder – To specify the source directory, click Browse to open browse-for-folder dialog and select the
directory of the study cases. The source directory must contain all study cases saved as FireVoxel documents
(.fvx).

Output log – To specify the output file, click Browse to open save-as dialog, navigate to the target location
and enter a file name (*.txt). The output file will show the path to the source directory and the processing
settings from this dialog. The results are presented as a tab-delimited table, with each layer from each case
in a separate row and the following columns: case ID, modality, ROI (shell), texture radius, ROI volume,
and ROI parameters (mean, standard deviation, skewness, kurtosis, and entropy).

Fig. 17.5: Texture analysis dialog.

Texture levels (mm) – Parameters describing automatically created texture filters that will be applied to
all image layers. For example, if interested in analyzing 1) the original image and 2) a 3-mm filtered image
that enhances 3-mm-size features, enter 0,3 in this box. Note that filtering can be time-consuming, so for
the initial testing, skip filtering and enter 0.

Voxel Weights (drop-down menu), Texture Sensitive Gradient (EMD) (checkbox), 2D (checkbox)
– Filter parameters. The options for Voxel Weights include Constant (default), Gaussian, Radial, and
Rayleigh. Texture Sensitive Gradient (EMD), if checked, selects the Earth Mover Distance method.
Users may wish to start with the default settings (Constant, No, No).

Outer layer width (mm) – If not zero, the program will automatically create a 3D region of the specified
thickness. This ROI is located just outside the lesion. The histogram features for this region will be labeled:
lesion_or, where lesion is the name of the main (whole-lesion) ROI.

Number of inner layers – If not zero, the program will automatically create the specified number of inner
layers, or rings. These concentric rings are all located inside the lesion. The histogram features for the first
ring will be labeled lesion_ir1; for the second ring, lesion_ir2, etc. The algorithm will also segment the inner
core – the area remaining after all of rings are subtracted from the whole-lesion ROI. The histogram features
for the core are labeled lesion_co.

Inner layer width (mm) – The thickness (in mm) of each ring. When selecting the ring thickness and the
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number of rings, consider the smallest lesion size in the study. Some rings may end up being empty if the
layer thickness is too large.

Fig. 17.6: ROI Stats 3D dialog.

Histogram – Histogram parameters for the analysis. Note that these settings will impact the computed
results. Prior to the analysis, these parameters may need to be tested and selected interactively in Layer
Control > ROI Stats 3D (Fig. 17.6).

� Number of Bins – The number of bins in histogram (default, 100, as in ROI Stats 3D).

� Value range (min and max values) – The minimum and maximum values of the range of the histogram.
The default is [0, 100000]. In ROI Stats 3D dialog, the default range is set to the full range of data
within the ROI, between the lowest and the highest values.

� Use full range (checkbox) – Has the same effect as the Full button in ROI Stats 3D. Expands the
range to include the full range of data between the lowest and highest data values.

� Exclude outside (checkbox) – Has the same effect as Clip checkbox in ROI Stats 3D. If checked, the
data outside the value range are excluded.
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Fig. 17.4: Texture analysis batch tool.
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Chapter 18

Trace

� Magnetic Trace tool

� MagTrace settings

� Application-Specific Settings

� Start MagTrace

� Draw a MagTrace Contour

� Manipulate control points

� Spline properties

� Copy and snap commands

� Rasterize MagTrace contours

� MapFit

The Trace tab offers commands for accessing the Magnetic Trace (MagTrace) tool for defining vector
contours that snap to edges of objects in the image. This tool can be used to speed up manual segmentation
of organs and tissues.

18.1 Magnetic Trace tool

When using the Magnetic Tool, the user places clicks the mouse along the edge of the organ to be segmented
to place control points connected by a spline curve (Fig. 18.1).

The “magnetic” property allows placing the control points in the vicinity of the edge, but not exactly on
it, and the Magnetic Trace tool automatically moves them closer to the edge. The user can configure the
MagTrace properties and control the precision of snapping.
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Fig. 18.1: MagTrace in action.

18.2 MagTrace settings

The MagTrace tool can be configured before use by selecting Trace >MagTrace settings. This command
opens a panel with the tool parameters (MagTrace Parameters, Fig. 18.2).

Connect End to Start – Creates a closed contour. Checked by default.

Centered Auto Zoom – Unchecked by default. ADD DETAILS.

Snap-to-Edge radius (vox) – The radius of the MagTrace tool aperture (in voxels) within which the tool
detects edges and snaps to them. The larger the aperture, the faster the contour can be drawn, but also the
more likely the tool is to snap to irrelevant edges. The smaller the aperture, the slower and the more precise
is the drawing.

Spline tension [0, 1] – A coefficient that controls the curvature of the spline connecting the control points.
The lower the tension, the straighter the line. A straight line has the spline tension of zero. The tension can
also be adjusted after the contour is drawn through the contour properties panel.

Edge Parameters – Opens a secondary dialog (Multiscale Texture Gradient, Fig. 18.3) to adjust
the parameters of edge detector algorithm. These parameters may be adjusted for specific tasks and image
types. Optimal presets configured for commonly used applications are available through Trace > Application
Specific Settings. See Volume > Multiscale Texture Gradient for details of this dialog and Texture Edge
Detection.
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Fig. 18.2: MagTrace Parameters.

Fig. 18.3: MagTrace Edge Parameters.
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18.3 Application-Specific Settings

Offers presets configured for segmentation of specific organs.

18.3.1 Femur MR (0.24 mm x 0.24 mm)

Fig. 18.4: MagTrace settings for femur.

MagTrace parameters and Edge Parameters (Multiscale Texture Gradient) for segmenting femoral head (Fig.
18.4).

Snap-to-Edge radius (vox): 10. Spline tension: 0.5.
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Edge Parameters: Low & radius (vox): 6.070. Distance Metric: Earth Mover Distance. Voxel Weights:
Constants. Magnitude measure: Normalized. Normalization Coefficient: 1.

18.3.2 Hippocampus (1 mm x 1 mm)

MagTrace parameters and Edge Parameters (Multiscale Texture Gradient) for segmenting hippocampal re-
gion of the brain (Fig. 18.5).

Snap-to-Edge radius (vox): 8. Spline tension: 0.5.

Edge Parameters: Low & radius (vox): 2.180. Distance Metric: Earth Mover Distance. Voxel Weights:
Radial. Magnitude measure: Normalized. Normalization Coefficient: 1.

Fig. 18.5: MagTrace settings for hippocampus.
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18.4 Start MagTrace

Starts the MagTrace tool. MagTrace can also launched using the main toolbar icon . Once MagTrace
is launched, the cursor becomes a green circle. The size of this circle is set by Snap-to-Edge radius.

18.5 Draw a MagTrace Contour

To draw a contour, click the image to place the control points. The points will be shown as green circles
connected to the previous point with a red line (spline).

The contours are defined only on the current slice. To replicate the contours (to the current slice or other
slices), use Copy commands.

The radius of the snapping region can also be controlled by scrolling the mouse wheel up and down.

If there is an active contour in the document, starting MagTrace will continue drawing this contour. To
start drawing a new contour, press Esc to exit MagTrace, click anywhere on the image to deactivate the first
contour, then start the MagTrace tool again and draw the second contour.

To exit from the MagTrace tool, press Esc.

To delete a contour, click on it to activate (green control points appear) and then press Delete.

18.6 Manipulate control points

To manipulate the individual commands, press Esc exit the MagTrace tool. Click the contour to activate it.
An active contour shows the control points as green circles(Fig. 18.6).

To move a control point, hover the cursor over it (the cursor becomes a cross), click and drag it to a new
location and then release the mouse.

To add a control point, hover the cursor over the spline contour (the cursor becomes a cross), and press
Alt+1.

To delete a control point, hover the cursor over the point to be deleted and press Alt+4.

18.7 Spline properties

The properties of an existing spline can be configured when the MagTrace tool is off. Double-click the contour
to open Polyline and Spline properties (Fig. 18.7). Alternatively, select View > Contour and Fill
Properties to open this panel.

The options include:
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Fig. 18.6: Active MagTrace contour shows control points.

Area –- Click the Fill box to fill the area within the contour. Press the Color button to open the color
selector to customize the color.

Contour –- Check the Draw box to show the outline of the contour. Click the Color button to open a
color picker and select the line color. To control the line width, enter a number (in points) in Width box.
Check the Close box to connect the first and last points in the contour.

Spline –- Check the Spline box to convert the contour into a spline. Uncheck for straight line. If Spline is
checked, enter the spline tension into the Tension box.

Slice index –- Displays the slice number (first slice has the index of 0) on which the contour is defined.
Enter another number in the Slice index box to move the contour to that slice.

Alpha [0, 100] –- Value of the alpha channel, in percent, controlling transparency of the contour. Trans-
parency of both the line and the fill area (if selected) transparency is set simultaneously. Alpha equal to zero
results in a fully transparent contour, alpha of 100% results in a fully opaque contour.
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Fig. 18.7: MagTrace Spline and Polyline properties.

18.8 Copy and snap commands

Copy selected spline (Alt+5) – Copies and pastes the active contour onto the current slice. If the current
slice is the slice containing the selected contour, the contour is duplicated in place. The pasted contour is
pasted with the default parameters (color, fill, close, alpha).

Snap selected spline to image (Any direction: Alt+2) – Snaps the selected spline to the edges of the
image (in plane and across slices). ADD DETAILS

Snap selected spline to image (Normal: Alt+3) – Snaps the selected spline to the edges of the image
(across slices). ADD DETAILS

Copy from adjacent slice and snap – Combines copy and snap commands. Copies and pastes the selected
slice to the current slice and snaps the contour to images. May be useful when replicating an outline of an
organ through slices.

18.9 Rasterize MagTrace contours

Use Vector > Rasterize selected vector entities or Rasterize All Splines to rasterize the active spline
or all spline contours in the document. The raster ROIs are placed either into the current ROI layer or a
new ROI layer, if the current layer is not an ROI layer. See Vector chapter for details.
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18.10 MapFit

Opens a MapFit (Multi-Agent) panel (Fig. 18.8).

Fig. 18.8: MapFit panel.
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Chapter 19

Transform

� Rotate and Create new volume (changes voxel size)

� Rotate Orthogonal and Create new volume (preserves voxel size)

� Load landmark file

� Landmark alignment to a single Z-slice

� Transform using VTF file

� Save Alignment (*.vtf)

� Make isotropic

� Mirror voxels along axis (X, Y, Z)

� Translate Active layer using vector

� Rotate Active layer using sector

� Discard Alignment

� Active layer: Project to single slice volume

The Transform tab contains commands that allow users to manipulate the orientation, position and resolution
of the images. The Transform commands alter the image data and allows the user to save the transformed
images (unlike the View commands that only alter the way the images are displayed).
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19.1 Rotate and Create new volume (changes voxel size)

Acts on all layers (image and ROI, visible and invisible). Opens a dialog (Rotate Volume, Fig. 19.1).
Creates a new document labeled as the original with _rotated_n suffix (n – integer). Transforms the source
image by applying rotation, scaling, and interpolation.

Fig. 19.1: Rotate Volume Panel.

Rotations are specified by entering angles of rotation, in degrees, about X, Y, and Z axes into the boxes
labeled X-angle (deg), Y-angle (deg), Z-angle (deg).

Resampling is specified by Scale, a numerical coefficient between 0.01 and 100. The transformed image is
resampled to isotropic resolution so that Scale = Smallest dimension of original voxel

Isotropic dimension of transformed voxel .

Therefore, Scale>1 indicates upsampling (increasing resolution) and Scale<1 indicates downsampling (de-
creasing resolution).

The Interpolation dropdown menu allows the user to select an interpolation method. Options include:
Nearest neighbor, Tri-linear (default), Wsinc2, Wsinc 3, and Wsinc 4. The Tri-linear method is preferable
for CT and Wsinc methods are more appropriate for MRI.

If Scale<1 (the image is downscaled), the user may select the downscale method. Gaussian downscale
checkbox selects downsampling by Gaussian filter (blur) followed by thresholding, with user-specified Binary
Threshold specified in percent (50% by default). As a result, Gaussian downscale may be able to preserve
the image details that would be lost with regular downscale.

If theGaussian downscale box is unchecked, regular downsampling is used, and the new voxel values are
determined based on a simple average of the original voxel intensities with filtering at a fixed 50% threshold.
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Checking the box Preserve original FOV and resolution suppresses resampling and retains only rotation.
The transformed image will have the same field of view (FOV) and voxel size as the original, regardless of
Scale.

19.2 Rotate Orthogonal and Create new volume (preserves voxel size)

Acts on all layers. Creates a new document labeled as the original document with a suffix _RotOrtho_n
(n-integer). Opens a dialog panel (Rotate Volume Orthogonally around Volume Center, Fig. 19.2).
Performs orthogonal rotations around 1st, 2nd, and 3rd rotation axes.

Fig. 19.2: Rotate Volume Orthogonally around Volume Center Panel.

The drop-down menus labeled 1st, 2nd and 3rd Rotation Axis are used to select X, Y, Z, None axes of
rotation. The buttons labeled -90< deg and >90 deg are used to rotate the volume in 90-degree increments
in counterclockwise or clockwise directions about a selected axis.

The bottom part of the panel displays the rotation matrix M in one of the two configurations: 1)
Source=M*Target or 2) Target=M*Source.

Reset button clears all entries. Matrix to Clipboard copies the transformation matrix to clipboard and
allows it to be pasted into a text editor or spreadsheet. Save creates a VTF file (by default in FireVoxel
Temp directory) with information about this transformation.
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19.3 Load landmark file

Opens browse for file dialog to load a landmark file. ADD DETAILS See Coregister with Landmarks

19.4 Landmark alignment to a single Z-slice

Requires an image and a set of at least three landmarks (see Coregister with Landmarks). If no landmarks
are present, shows an error message (At least 3 points are required in this operation).

If the landmarks are present, shows image processing dialog with the measurement of the Plane fitting
error (mm). Once the user clicks OK, opens Rotate Volume dialog (Fig. 19.1) with pre-filled values of
rotations about X, Y, and Z axes. After the user clicks OK, the command creates a new document window
and displays in it the transformed image. The document is named [original]_Z_[n], where n is the number
of landmarks.

The landmarks are transferred into new document under the same names, but transformed according to the
same rule as the image.

19.5 Transform using VTF file

Acts on the active layer and all visible layers. Requires a previously saved .VTF file (see Volume Transform
File). Opens a dialog panel (Fig. 19.3).

Fig. 19.3: Transform Using VTF.

The user can select the Interpolation method (Nearest neighbor, Tri-linear, Wsinc2, Wsinc 3, Wsinc 4). If the
image is downsampled (target resolution is lower than the original resolution), the user may select Gaussian
downscale and the threshold value (50% by default). The user must also enter into the Transformation File
text box the name of the previously created .VTF file (or click Browse to open a browse for file). Pressing
OK applies the affine transformation described by the .VTF file to all visible layers. If the .VTF file does
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not match the dimensions of the active layer, FireVoxel shows an error message and the command is not
performed.

19.6 Save Alignment (*.vtf)

Open file save dialog to save the Volume Transform File (with .vtf extension) with the information about
the image transformations. The file retains the information about a sequence of transformations since the
last document save.

19.6.1 Volume Transform File (.vtf)

Fig. 19.4: Volume Transform File.

The Volume Transform File (*.vtf) can be opened with a text editor (Fig. 19.4).

The file contains the transform type (affine), the matrix size and resolution (voxel size in mm) in X, Y,
and Z direction of the source and target images, and the Transform Data (12 matrix elements of affine
transformation matrix).

The affine transformations include scaling, rotations, shear, and translations and can be expressed in matrix
form: x’ = A x + t, where x is the source, x’ is the target, A is the affine transformation matrix and t is the
translation vector. This expression can be rewritten in terms of matrix elements (Fig. 19.5):
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In VTF, the Transform Data are the twelve elements of the affine matrix (marked with the red box) listed
row by row (a11, a12, a13, tx, a21,. . . ,tz).

Fig. 19.5: Affine Transformation in matrix form.

19.7 Make isotropic

Acts on all layers in a document. Opens dialog (Specify Resolution (mm)), to enter the voxel dimension of
the transformed image. Creates a new document window named after the original window with an added
iso_[number] suffix. The image and the ROI layers, both visible and invisible, are transformed together
and retained in the transformed image. By default, the resolution is set to the smallest dimension of the
original voxel. The transformed image has isotropic resolution (cubic voxels). If the target voxel is larger
than the original (i.e., target resolution is lower than the original), regular downsampling method is used.
To perform Gaussian downsampling (more favorable to small details) use Rotate and Create new volume.

19.8 Mirror voxels along axis (X, Y, Z)

Acts on all active layers. Does not create a new document. Reflects all visible layers with respect to the
selected axis.

19.9 Translate Active layer using vector

Acts on the active layer and all visible layers. Requires a vector object (vector – a two-point polyline) (Fig.
19.6). Shifts (translates) layer(s) by the distance and in the direction specified by a vector object. Does not
create a new document.

Steps:

1. Draw a vector (a two-point vector object) using Insert polyline connecting the origin and destination
of translation. Use View > Display\Hide curve length to display the length of the vector, if needed.

2. Select Vector > Translate using vector command. The active layer, along with all other visible
layers, is shifted as defined by the vector.

3. To save the transformation as .VTF file, see Save Alignment .
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Fig. 19.6: Translate using vector.

4. To undo, use Discard Alignment .

19.10 Rotate Active layer using sector

Acts on the active layer and all visible layers. Requires a vector object, a segment – a 3-point polyline (Fig.
19.7). Rotates layer(s) by the angle specified by the sector.

Fig. 19.7: Rotate using sector.

Steps:
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1. Draw a sector – a vector object made of three ordered points (or two straight segments), using Insert
polyline.

The first segment (from the first to the second point) should be aligned with the original
alignment.

The second segment (from the second to third points) should be aligned with the target
direction. The second point is the center of rotation. Use View > Display\Hide curve
length to display the angle measure of the sector, if needed. The direction of rotation is
indicated by an arrow inside the sector. Adjust the sector by moving the anchor points after
placing them.

2. Use Vector > Rotate using sector. The layer(s) are rotated about the center of rotation by the
angle indicated by the sector in the direction from the first segment towards the second segment.

3. To save the transformation as .VTF file, see Save Alignment .

4. To undo, use Discard Alignment .

19.11 Discard Alignment

Reverses all transformations performed since the last saving of the document. If several transformations were
performed sequentially, all of them will be undone. The saved .VTF files from these transformations are not
affected.

19.12 Active layer: Project to single slice volume

Requires an image layer. The command extracts the current slice from the active document, resamples this
slice to isotropic resolution equal to the smallest dimension of the original voxel, and displays this slice in a
new document labeled snapshot.
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Chapter 20

Nonuniformity

� Introduction to MRI nonuniformity correction

� Nonuniformity correction methods in FireVoxel

� N3 and N4 algorithms

� N3 (NYU implementation)

� N4 (UPenn implementation)

� N4 Explorer

� BiCal algorithm

� BiCal nonuniformity correction

� BiCal Explorer

� Measure {CV, CJV, Spillover} for two ROI layers

� Measure {CJV, Spillover} for two ROI layers (All Documents)

20.1 Introduction to MRI nonuniformity correction

FireVoxel’s Nonuniformity tab provides access to several nonuniformity correction methods for MR images.
The user may choose the most appropriate method based on the type of images, the severity of nonuniformity
artifact and resources available for image processing (such as time and computing power).

Non-uniformity of image intensity is a common MRI artifact. It creates a smooth variation of signal intensity
across the image that is unrelated to tissue properties. This artifact may be caused by the imperfections
of the imaging technique or the patient’s influence on the magnetic and electric fields. Non-uniformity is
often unnoticeable to a human observer, but it may introduce errors into quantitative MRI methods, such
as segmentation, registration, and dynamic modeling. To minimize these errors, it is often helpful to remove
the non-uniformity artifact before analyzing images.

A number of methods have been developed to minimize the nonuniformity artifacts, including prospective
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and retrospective methods. Prospective methods rely on additional sequences acquired during the MRI exam
and then used during processing for nonuniformity reduction. Retrospective methods, such as the methods
available in FireVoxel, estimate the nonuniformities directly, without the need for additional acquisitions.
These methods assume that nonuniformity is multiplicative, which means that the intensity of the acquired
image at every point can be represented as a product of the corrected intensity and a spatially varying bias
field (20.1):

𝐼𝑎(𝑟) = 𝐼𝑐(𝑟)×𝐵(𝑟) (20.1)

where 𝐼𝑎(𝑟) is the acquired image, 𝐼𝑐(𝑟) is the corrected image and 𝐵(𝑟) is the bias field. To find the corrected
image, we need to estimate the bias field.

20.2 Nonuniformity correction methods in FireVoxel

FireVoxel offers three retrospective methods for non-uniformity correction: the widely-used N3 method and
its variant N4, as well as FireVoxel’s original method, BiCal. The N3 method, for Non-parametric Non-
uniformity Normalization (Sled 1998, PMID: 9617910) is offered in the streamlined local implementation
(Tsui W, NYU School of Medicine, 2003). The N4 method (Tustison 2010, PMID 20378467), a variant
of N3, is included as a plugin, N4BiasFieldCorrection.exe, in the FireVoxel directory. The BiCal method
(Mikheev A, Rusinek H, NYU School of Medicine, 2010) is a powerful method for challenging imaging
situations, such as abdominal, high field, and accelerated MRI.

The choice of method is usually motivated by a compromise between the quality of correction and compu-
tational resources and time available. Among these three methods, N3 is the fastest but the least powerful,
and BiCal is the slowest, but may be better suited for complex imaging problems, such as high field imaging.

Additionally, N4 Explorer and BiCal Explorer enable parameter optimization by running corrections with a
grid of parameters. The tab also contains options for measuring nonuniformity via coefficient of variation
(CV), coefficient of joint variation (CJV), and spillover for two ROI layers.

The correction methods act on 3D or 4D images. For 4D images, if the current image is not the first frame in
the dynamic series, FireVoxel shows a warning and asks the user whether to proceed or cancel the correction.
If the user chooses to proceed, only the current frame will be corrected. No warning is shown for correction
of the first image in dynamic series, and only the first image is corrected.

Each of the three correction commands (N3, N4, and BiCal) opens a dialog panel with adjustable options.
The output includes the corrected image or an option to create a bias field map. [N3 – checked check-
box Bias Field creates only bias field, but no corrected image]. The corrected images are placed in new
layers named [active_layer]_N3 (or _N4 or _BiCal). Bias field maps are placed in new layers named
[active_layer]_N3_BiasField.
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20.3 N3 and N4 algorithms

Below is a brief description of the algorithms for N3 and its variant N4 methods (Fig. 20.1). N3, or Non-
parametric Non-uniformity Normalization, is the most commonly used non-uniformity correction method.
Both N3 and N4 methods operate in the log-transform space of the image intensities and bias field. These
methods deal with the probability densities, or, for discrete images, intensity histograms. The histogram
of the logarithm of the bias field is assumed to be a zero-centered Gaussian. Below is an overview of the
internal steps of the N3 and N4 algorithms.

Fig. 20.1: N3 or N4 algorithm diagram.

First, the image background is masked. This initial step is followed by an iterative block performed in the
log-transform space of the image intensities and bias field. The logarithmic transformation conveniently
changes the multiplication to addition, but may run into problems in areas where signal intensity approaches
zero, such as the air-filled background regions. Masking the background helps to minimize these potential
issues. Within the iterative block, each iteration includes three steps.

In Step 1, the bias field histogram is estimated so that the corrected image is sharpened. This sharpening
is achieved by applying the Wiener deconvolution filter to the image intensity histogram. The Wiener filter
uses a Gaussian kernel with a full width at half maximum (FWHM) selected by the user.

In Step 2, the new estimate of the bias field is smoothed by fitting it with a three-dimensional B-spline field
with a user-specified grid size (given in millimeters). The size of the grid controls the degree of smoothing.
This grid size is typically about 200 millimeters for images acquired with a body coil and smaller for images
acquired with localized surface coils.

In Step 3, the termination criterion is tested against a specified threshold. In practice, the algorithm stops
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after a fixed number of iterations specified by the user.

Once the iterations are completed, the bias field is extrapolated over the entire field of view. Finally, the
original image is divided by the bias field to obtain the corrected image.

20.4 N3 (NYU implementation)

Fig. 20.2: N3 parameter panel.

Selecting N3 on the Nonuniformity tab opens a parameter panel (N3 – Bias Field Correction, Fig. 20.2),
where the user can specify the method parameters. The three key parameters, as described in the N3/N4
algorithm, are: Number of iterations (exit parameter in Step 3), Field Smoothness (grid size in Step
2), and FWHM of the Gaussian kernel (Step 1).

Additional parameters:

Subsample – ADD DETAILS

Dynamic Field (checkbox) – ADD DETAILS

Noise – ADD DETAILS

(Pad volume – currently disabled)

By default, the operation creates a corrected image in a newly added layer. Checking Output Bias Field
checkbox creates instead a new layer with the bias field map.
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20.5 N4 (UPenn implementation)

Fig. 20.3: N4 parameter panel.

The N4 command opens a parameter panel (N4 nonuniformity correction, Fig. 20.3) with parameters of the
N3/N4 algorithm: Number of Iterations, Spline Distance (grid size, mm), and FWHM.

Background mask parameters (?):

Air threshold – ADD DETAILS

Noise – ADD DETAILS

By default, the output is the corrected image placed in a new layer. Checking Output Bias Field creates
instead a new layer with the bias field map.

20.6 N4 Explorer

Enables optimization of N4 parameters. Requires a visible ROI comprising multiple blobs scattered uniformly
across the image. If the document has no visible ROI, the command shows a warning.

Opens an N4 Explorer panel (Fig. 20.4) to test combinations of values for three parameters: Spline Distance,
Noise, and FVHM. The parameters are sampled on a grid between the minimum and maximum values at
a set number of grid steps (Grid).

The results include coefficients aCV, bCV, CSM, blobCJV, voxCJV (Fig. 20.5).
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Fig. 20.4: N4 Explorer panel.

Fig. 20.5: N4 Explorer results.
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20.7 BiCal algorithm

BiCal is a powerful and computationally intensive method that may overcome the limitations of the N3/N4
methods in complex imaging tasks.

The BiCal algorithm includes the following main steps. (Fig. 20.6)

Fig. 20.6: BiCal algorithm diagram.

First, the background signal is removed from the acquired image to create a background mask. The algorithm
then detects sharp edges and creates an edge mask, a key step in this method. The next three action steps
are performed in the log-transform space of the image intensities and bias field, as in the N3 and N4 methods.

In the first of these three steps, the partial derivatives of the image intensity are computed for each
voxel of the body. The bias field is estimated as a set of smooth polynomial functions and the partial
derivatives of the bias field are fitted directly to the partial derivatives of the image signal intensity.

The resulting set of linear equations is solved to obtain the polynomial coefficients that are used to
estimate the bias field. Finally, the acquired image is divided by the bias field to obtain the corrected image.
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20.8 BiCal nonuniformity correction

The BiCal command opens a parameter panel for configuring the correction (BiCal Parameters, Fig. 20.7)
with the following options.

Fig. 20.7: BiCal parameter panel with default values.

Basis functions – Dropdown menu with the choice of polynomial functions used to estimate the bias field:

� Legendre polynomial

� Chebyshev polynomial of the first kind

� Chebyshev polynomial of the second kind

� Regular polynomial

� Cosine.
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Processing scale – Sets how many voxels are skipped to speed up processing. Processing scale p indicates
that every p-th voxel will be processed.

Field precision (mm) – Sets the degree of polynomial expansion. Related to degree n of basis function
expansion, n = image width/field precision.

Max correction – Limits the correction factor: 𝑚𝑎𝑥(𝐵(𝑟)) = 𝑚𝑎𝑥(𝐼𝑎/𝐼𝑐).

Background transition (mm)

Background group – Background (air) region mask parameters:

� Air level (*Noise) (noise=. . . )

� Low signal level

Region separation – Edge mask parameters:

� Method – Including: Regular Edge, Thin Edge, Gradient (time+)

� Gradient radius (voxels)

� Edge Level (noise)

� (Gradient inclusion)

� Region smooth eps

� Adaptive edge (time+)

Output:

(Checkboxes) Real voxels, Work mask, Field (bias field map), All documents

20.9 BiCal Explorer

Currently unavailable. ADD DETAILS

20.10 Measure {CV, CJV, Spillover} for two ROI layers

Used to estimate nonuniformity using two distinct tissues. Requires two ROI layers, one in each tissue, with
blobs uniformly distributed over the image. Returns basic statistics for each ROI, including number of seeds,
average seed intensity, standard deviation, and non-uniformity (Fig. 20.8). Also provides measures derived
from matched blobs: contrast average\stdev. ADD DETAILS

Blob Coefficient of Joint Variation (CJV): Defined from two set of regions, delineated by expert observers in
areas of known, uniform tissue throughout the imaged organ (20.2).

𝐶𝐽𝑉 =
(𝜎1 + 𝜎2)

|𝜇1 − 𝜇2|
(20.2)
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Fig. 20.8: Results of Measure {CV, CJV, Spillover}.

where 𝜇1 and 𝜇2 are the average values, and 𝜎1 and 𝜎2 are standard deviations of intensity over the two
regions. CJV quantifies the intensity variability in each set and controls for the potential undesirable loss of
tissue contrast by the algorithm. CJV is quantified before and after correction, a decrease in CJV reflects
decreased nonunformity.

Voxel CJV: vxCJV – similar quantity calculated. . . ADD DETAILS

Optimal Separation misclassification portion. . . ADD DETAILS and Optimal Threshold. . . ADD DETAILS

20.11 Measure {CJV, Spillover} for two ROI layers (All Documents)

Returns Blob CJV, Voxel CJV, and overlap for two ROI layers (Fig. 20.9).

Fig. 20.9: Results of Measure {CJV, Spillover}.
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Chapter 21

Coregister with DICOM Tags

� About coregistration using DICOM tags

� Register Using Orientation\Position Tags

� Using Orientation\Position tags with Centering

21.1 About coregistration using DICOM tags

Coregistration aligns two images of different dimensions, orientations, and imaging modalities (e.g., CT
and MRI). During coregistration, one image, which we will call the source image, is transformed and
superimposed onto a fixed image called the target image, which remains unchanged.

21.2 Register Using Orientation\Position Tags

Register > Using Orientation\Position tags is FireVoxel’s basic coregistration command that uses
DICOM orientation and position attributes and matrix algebra to align the source image with the target.
This method works best for 3D images acquired during the same imaging session. The patient position is
assumed to be unchanged between the two acquisitions. The source and target images may have different
matrix, field of view, and orientation. This method is fast, convenient, and requires no parameters to be
adjusted.

Requires two 3D images in DICOM format: source and target.

May also work for NIfTI images that unambiguously store the image orientation information. This method
does not work for ANALYZE and similar image formats that do not store the orientation data.

The source document, besides the acquired image, may also contain other layers, including segmentation
masks (ROI layers) and parameter maps. All these layers will be coregistered together with the base image.

Returns coregistered image, with the same matrix dimensions and resolution as the target image. The
coregistered layer will be named after the source image with a suffix added (_reg). The coregistered image
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is placed either in an automatically created new layer or a new document window, depending on the user
choice.

Any ROI layers present in the source window (and containing the same DICOM tags as the source image)
will also be coregistered together with the source image.

To use:

1. Open the source image in FireVoxel. The source image will be displayed in a new document window.
If the source document contains multiple layers, make sure that the base layer (acquired image, MRI, CT,
PET, etc.) is the active layer.

2. Open the target image in target document window. Make sure that the target window is the active
window by clicking on it. The active window is indicated by the blue title bar. Also make sure that the base
image is the active layer (Fig. 21.1).

Fig. 21.1: Target (left, active) and source (right) images.

3. Select Register > Using Orientation Position tags on the main menu.

4. A dialog opens showing the output options (Fig. 21.2). Select an option to start processing or cancel:

a. Add as a new layer – Coregistered image is added to the target window as a new (topmost)
layer;

b. Create new Document – Coregistered image is displayed in a new document window;

c. Cancel – Cancel the operation.

5. After registration is completed, the coregistered image will be displayed according to the selected option:
(a) in a new layer or (b) in a new document window. The new layer or document is labeled [source]_reg.
All layers of the source document will be coregistered together and placed either into the target window or
into the new document window.
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Fig. 21.2: Output options for coregistration with DICOM tags.

Fig. 21.3: Coregistered image in a new layer (left) in target window.
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6. Check the accuracy of registration. Open Layer Control and use the Alpha slider to adjust the layer
transparency to inspect the coregistered image.

7. If coregistration accuracy is unacceptable, try a more advanced coregistration method, such as Register
> Coregister with AutoFocus.

21.3 Using Orientation\Position tags with Centering

ADD DETAILS
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Chapter 22

Coregister with AutoFocus

� About Coregistration with AutoFocus

� Basics of AutoFocus

� Using Coregistration with AutoFocus

� 3D Registration with AutoFocus Dialog

� Signal Difference with AutoFocus

� Cross Correlation with AutoFocus

� URAL with AutoFocus

� Slice-by-slice with AutoFocus

22.1 About Coregistration with AutoFocus

AutoFocus is a scheme that iteratively optimizes a voxel-based similarity measure between two images, such
as mutual information. Coregistration with AutoFocus is a powerful and versatile coregistration method that
can be used for coregistering images from different imaging sessions and different modalities. For images
acquired in the same session, see the basic method for coregistration using DICOM tags.

This section describes AutoFocus coregistration for 3D images. FireVoxel also offers AutoFocus with
motion correction for 4D coregistration.
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22.2 Basics of AutoFocus

During coregistration, the source image is transformed and superimposed onto a fixed image called the
target image, which remains unchanged.

Coregistration with AutoFocus may use a target ROI enclosing the organ or tissue of interest to restrict
coregistration and speed up processing. Coregistration can be performed without the target ROI, but it may
take much longer than with the ROI, because coregistration is a computationally intensive task.

The target ROI can be created on the target image manually (using the Paintbrush tool) or automatically,
using ROI operations or segmentation tools, such as EdgeWave.

The coregistration algorithm searches for a transformation that best matches the source and the target
volumes. This group of commands offers a choice of transformations ranging from simple translations to
affine transform. The matching of the volumes is based on optimizing a similarity measure (with a
selection for different scenarios).

The transformation is computed in two stages, AutoFocus and Fine-tuning:

1. AutoFocus. The algorithm constructs a variety of transformations with combinations of parameters that
span a multidimensional grid. The transformations include translation, scaling, rotation, and shear. The
transformations are ranked by how well they match the two volumes based on the similarity measure. A
user-selected number of the best transformations is retained for the second, fine-tuning stage.

2. Fine-tuning. The algorithm performs iterative adjustment of the best transformation parameters until
it finds a local optimum of the similarity measure. Finally, the transformed source image is interpolated and
saved as a new layer in the target image window.

22.3 Using Coregistration with AutoFocus

Here we will describe coregistration with AutoFocus using Register > Mutual Information with Auto-
Focus. Other variants of AutoFocus commands are applied similarly.

1. Open the target window in another document window.

2. Open the target window in another document window.

3. Define a rough target ROI around the organ or tissue of interest. You may use manual or automatic
segmentation tools (Fig. 22.1).

Manual ROI. Use Layer Control > New ROI 3D to create a new ROI layer. Use the Paintbrush tool
(Ctrl+Left mouse) to draw a rough contour around the organ of interest. Define these contours on every few
slices (e.g., on every 5th slice). Next, use ROI > Morphology > Fill 2D Contours and Morph Convex to
fill the contours and extend the ROI across slices. The resulting ROI should fully enclose the organ or tissue
of interest.

4. Select the target window as the active window and select the base image as the active layer. Select
Register > Mutual Information with AutoFocus.
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Fig. 22.1: Target image with target ROI (MR, right) and source image (CT, left).

5. If the active layer is an ROI layer, a warning will be shown alerting the user to this fact (Target is ROI.
Proceed?).

6. If the active layer is the base image (acquired image), a dialog window will open to adjust parameters (3D
Registration with AutoFocus).

7. Check Use Target ROI box (checked by default if a visible ROI is present). If no visible ROI is present,
this box is grayed out.

8. Select suggested AutoFocus and Finetune parameter (Fig. 22.3). It is recommended to start with
AutoFocus: Translation and Rotation only and Finetune: Transform > Rigid.

9. Click OK to start processing. Registration will commence. Its progress will be indicated in the bottom
right corner of the software window.

10. When registration is completed, a new layer with coregistered image will be created in the target window
(Fig. 22.2).

11. Check registration accuracy using Layer Control > Alpha slider to adjust the transparency of the
coregistered layer.

12. If registration accuracy is unacceptable, repeat steps 5-11 and adjust the coregistration parameters. As
the first step, increase Power before adjusting other parameters.
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Fig. 22.2: Coregistration with AutoFocus results.

22.4 3D Registration with AutoFocus Dialog

If suitable source and target images are present, Register > Mutual Information with AutoFocus
command opens a dialog panel (3D Registration with AutoFocus, Fig. 22.3). The components of this
dialog are described below.

If one of the volumes is missing, an error message is shown (No suitable source volume is found).

22.4.1 Load Initial Transformation

Loads transformation information from a previously saved Volume Transform File (*.VTF). Enter a path
to the .VTF into the text box or click Browse to open browse-for-file dialog to select a previously saved
transform file.

Dicom tags – ADD DETAIL.

22.4.2 Save Final Transformation

Save the final transformation as *.VTF. Enter the path to the file or click Browse to open browse-for-file
dialog to navigate to the destination directory and enter a file name.
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Fig. 22.3: 3D Registration with AutoFocus dialog.

22.4. 3D Registration with AutoFocus Dialog 169



FireVoxel: User Manual, Draft 2025-04-29

22.4.3 ROI (option)

Use Target ROI (checkbox) – If checked, the target ROI is used for coregistration. If a visible ROI is
present in the target window, by default its name will be displayed here. If the ROI is absent or invisible,
this option is grayed out.

Inflate/units – Text box and drop-down menu to select the grow distance (in voxels OPTION: MILLIME-
TERS?) by which the target ROI should be inflated by the Grow command.

22.4.4 Measure (options)

This block contains a dropdown menu with a selection of similarity measures and related settings. The
similarity measures range from simple to complex and powerful:

� Signal Difference (simple)

� Cross Correlation

� Image Ratio Uniformity

� Mutual Info

� Mutual Info Normalized

� URAL

� URALTAU (advanced)

Related settings include:

� MI bin number – Number of bins in the mutual information method

� Source Noise – Noise level in the source image (default: measured automatically)

� Target Noise – Noise level in the target image (default: measured automatically).

URAL Settings – Opens dialog (Multiscale Texture Gradient , Fig. 15.6) to adjust texture edge detector
parameters for URAL and URALTAU methods.

22.4.5 AutoFocus (options)

Subsample [1, 8] – Default 3

Translation max {X, Y, Z} – Default: {30, 30, 30}

Scale Deformation matrix – Default: {0, 0, 0}, Grid: 1

Uniform scale (checkbox) – Default – unchecked

Rotation angle max (deg) – Default: {0, 0, 0}, Grid: 1

Shear Magnitude max [0, 10] – Default: 0, Grid: 1
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22.4.6 Finetune (options)

Power [0, 1000] – Default: 20. Suggested starting value: 2-3

Multipass (checkbox) – Default: unchecked

Transform (dropdown menu) – Dropdown menu with a selection of transform types: Translation, Rigid
(default), Affine, Quadratic, Polynomial Multipass.

22.4.7 Output (options)

Interpolation (dropdown menu) – Nearest neighbor, Tri-linear (default), Wsinc2, Wsinc3, Wsinc4

Reslice Target to Source (checkbox) – Default: unchecked.

22.5 Signal Difference with AutoFocus

Shortcut for coregistration with Similarity Measure: Signal Difference

22.6 Cross Correlation with AutoFocus

Shortcut for coregistration with Similarity Measure: Cross Correlation

22.7 URAL with AutoFocus

Shortcut for coregistration with Similarity Measure: URAL

22.8 Slice-by-slice with AutoFocus

Requires source and target images of the same dimensions.
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Chapter 23

Coregister with Landmarks

Landmark coregistration enables aligning two images by superimposing their landmark locations, or promi-
nent sites that can be easily identified on both images. The stationary image is called the target image and
the image that is transformed and superimposed is the source image.

Landmark coregistration may be the method of choice when aligning images of disparate modalities, with
different contrasts and fields of view, such as MRI and ultrasound, or acquired images and atlas maps (e.g.,
mouse CT and mouse brain atlas).

To coregister using landmarks, the user places pairs of vector regions of interest (VROIs) at the matching
locations of the target and source images. During coregistration, the source image is transformed to align
the coordinates of its landmarks with the coordinates of the landmarks in the target image.

23.1 Landmark Registration

Image requirements (and limitations)

Steps:

1. Load the source and the target images into FireVoxel (see Open).

2. Place between 3 to 10 small vector ROIs in easily identifiable locations in the target image (see Con-
struct VROI ). Assign a unique name to each VROI using VROI properties. Use Display Orthogonal
Projections to view and adjust the position and size of the VROIs in three dimensions. What should
be VROI sizes - vs landmark features in source and target images?

3. Place the same number of VROIs at the matching locations of the source image. Assign the same
VROI names to the corresponding VROIs. VROIs only need to have the same names, but don’t need
to be in the same order?

4. The correct naming and number of VROIs can be checked by using Vector > List All VROIs to display
the VROIs in each document.

5. Activate the target document (window to which the source image will be coregistered).

6. Select Segmentation > Landmark registration. If there are no errors in landmarks, this command
opens parameter dialog (Register Volumes and Landmarks, Fig. 23.1).
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7. If there are errors in matching landmarks, an error message is shown (Mismatched labels), showing
the numbers of landmarks in each image and the mismatched (unpaire) VROI(s).

Fig. 23.1: Register Volumes and Landmarks dialog.

8. Customize parameters and click OK.

9. A summary dialog will be displayed showing basic measures of the transformation to be performed
(Fig. 23.2): dir and rev (mm) for each landmark, transformation matrix and its determinant, direct
root mean square error (RMSE, mm), and reverse RMSE. Low RMSE values indicate good accuracy.
If these measures are satsfactory, click OK to proceed with transformation. If these measures are not
acceptable, click Cancel and return to the images to correct the VROI placement.

10. Once the user clicks OK, a new layer is created in the target document window with the coregistered
image. The coregistered layer is named [source]_reg. The target image remains unchanged. If the user
chooses to create *.vtf file, this file saved at the user-selected location.

Parameters

� Type – Transformation type. Options include: Translation, Rigid, Affine (default), Polynomial, Gaus-
sian Radial Basis Functions, TPS (thin plate splines).

� polynomial degree – Degree of polynomial for Polynomial transformation. Default: 2 mm.

� sigma (mm) – Standard deviation (?) for Gaussian Radial Basis Function transformation.

� lambda – WHICH TRANSFORM? WHAT IS THIS PARAMETER?

� Interpolation – Interpolation method. Options include: Tri-linear (default), Nearest Neighbor, Ws-
inc2, Wsinc3, Wsinc4.

� Transformation File – Browse for folder to select the location to save the Volume Transform File
(.vtf). The default name of the *.vtf is identical to the name of the base (image layer) in the target
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Fig. 23.2: Landmark registration summary.

window. However, the *.vtf file is not saved by default unless the user selects a directory. The *.vtf file
is created once the coregistration is complete and contains the dimensions and resolution of the source
and target images, as well as the transformation matrix applied to the source image (Fig. 23.3).

23.2 Landmark Registration with Voxel Similarity

Applies a combination of landmark coregistration with voxel similarity coregistration (with AutoFocus).
Requires a source document, a target document, and two matching sets of landmarks in each document.
Creates a new layer containing transformed source image placed into the target document window.

If landmarks are defined correctly, opens dialog with parameters of landmark coregistration (Register Vol-
umes using Landmarks, Fig. 23.1).

Once the user clicks OK, shows processing summary dialog with coregistration measures (Fig. 23.2).

IS THIS CORRECT? The user may choose to save the *.vtf transformation file to be used in the next stage,
AutoFocus registration.

If the landmark measures are acceptable, the user clicks OK to to proceed with transformation. If one of
the documents is an ROI, a warning is shown asking the user whether to proceed with the transformation.

If both documents are images, the command opens the AutoFocus dialog (see Coregister with AutoFocus,
Fig. 22.3).

IS THIS CORRECT? The *.vtf file created during the landmark registration stage can be applied for rough
alignment of the two images. An output transformation file may also be created.

IS THIS CORRECT? The URAL and URAL TAU similarity measures require the values of the image noise in

23.2. Landmark Registration with Voxel Similarity 174



FireVoxel: User Manual, Draft 2025-04-29

Fig. 23.3: Landmark registration volume transform file.
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the source and target images. The noise values are measured automatically and showed in the corresponding
text boxes.

The coregistered image is placed into a new layer automatically created in the target document. The accuracy
of coregistration may be assessed by changing the transparency level of the coregistered layer.
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Chapter 24

Segmentation 3D: EdgeWave

Tutorials & Sample Data

Watch on YouTube: Tutorial 6: Introduction to EdgeWave Segmentation

Tut6data.zip (3.5MB)

� Tools for Manual and Automatic 3D Segmentation

� EdgeWave Segmentation

� Brain segmentation [Group]

� Detect [Group]

� Feature point detection

24.1 Tools for Manual and Automatic 3D Segmentation

FireVoxel offers users a variety of tools for manual and automatic segmentation of 3D images.

Manual segmentation of 3D images can be performed using a combination of the Paintbrush tool, ROI
commands (see ROI), and Magnetic Trace (see Trace). However, manual segmentation can be time-consuming
and prone to observer bias.

Automatic segmentation can be performed using commands based on the EdgeWave algorithm that are
offered under Segment menu tab. These commands include options for various segmentation scenarios, as
well as pre-configured workflows for brain segmentation, which combine non-uniformity correction based on
the N3 method and EdgeWave segmentation.
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24.2 EdgeWave Segmentation

EdgeWave is an automatic segmentation algorithm for 3D medical images based mainly on the shape char-
acteristics of an image, as it uses primarily thresholding and morphology operations.

24.2.1 EdgeWave Algorithm

The EdgeWave algorithm follows the following main internal steps (Fig. 24.1).

Fig. 24.1: EdgeWave algorithm diagram with the output of each step shown schematically on the right (black
- background, gray - tissue, red - core set & final mask, white - peeled voxels, blue - part of core set excluded
from final mask).

Step 1 - The original image is resampled.

Step 2 - Thresholding by image intensity is applied to roughly delineate the region that needs to be seg-
mented, which we will call the Core Set. The Core Set must enclose the segmentation target, otherwise the
segmentation will fail.

Step 3 - Edge detection is then applied in some cases. Edges are areas of the Core Set where image intensity
changes abruptly.

Step 4 - The boundary of the Core Set is eroded, or peeled. The Peel operation removes all voxels within
a certain distance from the boundary using rules applied to each voxel and its neighbors. Peeling enlarges
the gaps between different regions of the image, removes small details, and breaks “bridges” between weakly
connected areas. The thickness of the region to be removed is controlled by the peel distance, measured in
voxels or millimeters.
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Step 5 - The algorithm breaks up the peeled Core Set into blobs, or connected components. It then
determines which connected components are to be retained and which ones should be discarded.

Step 6 - The selected connected components are subjected to constrained growth, or dilation. The Grow
operation adds voxels within a given distance of the ROI boundary. Any recovered voxels must still belong
to the Core Set. The thickness of the recovered region is controlled by the grow distance, which should be
larger than the peel distance.

24.2.2 EdgeWave Dialog

Selecting Segment > EdgeWave Basic or using icon on the main toolbar opens the EdgeWave
dialog panel that allows the user to customize the tool by selecting appropriate parameters (Fig. 24.2).

Basic EdgeWave tool can be used in two scenarios, depending on how the connected component is determined:
1) with the seed (vector ROI) or 2) without the seed.

If the seed option is used, prior to running EdgeWave, the user needs to draw the seed in an area of uniform
tissue to be segmented. For example, in brain segmentation, the seed is usually placed in white matter.

Core Set parameters:

[Seed average signal box] – If a vector ROI is present in the document, this box shows the average signal
intensity Savg within this ROI. WHAT IF SEVERAL VROIS?

Signal Intensity interval [Low, High] and Signal units – The lower and upper limits of the signal
intensity (SI) interval, specified, as indicated by Signal units drop-down menu, as either 1) Absolute SI -
absolute signal intensity, or 2) Relative to Seed Average, as a fraction of the average signal intensity Savg.
By default, the interval is [0.528,1.35]*Savg (typical range for white matter segmentation on T1-weighted
brain images).

Connected components – Drop-down menu with options of selecting:

1) All components,

2) Max components only - maximum connected component, or

3) Seed components – connected component determined starting from the seed, if the vector ROI seed
is present, by the region-growing method.

Peel+Grow parameters:

Peel Distance and Grow Distance – Thickness of the region to be removed (for Peel) or added (for Grow)

[Peel/Grow Distance units] – Drop-down menu to select millimeters or voxels as units of peel/grow
distance.
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Fig. 24.2: EdgeWave dialog (configured with vector ROI seed).
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24.2.3 EdgeWave Basic

Opens the EdgeWave dialog that can be configured in the most general scenario, with and without a seed.
See EdgeWave Dialog for parameter details. The command creates a new layer with the segmentation mask.
The vector ROI seed is NOT deleted after segmentation.

24.2.4 EdgeWave-Live with Single Seed and Constraint ROI

Expects isotropic volume (T1 MPRAGE?). Requires a raster ROI to be drawn around the organ to be
segmented (Core Set). This ROI must enclose all of the tissue to be included, but does not need to be
precise. Is this correct? Requires a seed (vector ROI).

Creates a temporary new document window with cropped volume and segmentation mask updated in real
time. Also opens an interactive dialog window for parameter adjustments. Changes in parameters are applied
immediately and displayed in real time. Once the user is satisfied with the result and clicks OK on the dialog
window, the temporary document is closed and the resulting segmentation mask is added to the original
window.

24.2.5 EdgeWave MultiLabel

24.2.6 EdgeWave MultiLabel – Boundary Only

24.2.7 EdgeWave with N largest Connected Components

24.3 Brain segmentation [Group]

These commands are specifically configured for whole-brain segmentation of (T1 and T2?)-weighted brain
images in sagittal, coronal, and axial orientations. They help the user perform non-uniformity correction and
segmentation in one step.

HOW ARE N3 PARAMETERS SET?

The combination non-uniformity / segmentation commands for three brain orientations (sagittal, axial,
coronal) act on (T1 and T2?)-weighted images in a corresponding orientation and require a seed vector
ROI to be defined in a uniform area of (white?) matter.

The EdgeWave parameters are set up through Brain segmentation profile command. The user then needs
to select one of the three commands corresponding to the orientation of the original images. After a command
is selected, it commences to run and produces results without requiring any additional user actions.

These commands create two new layers: 1) NU corrected (non-uniformity corrected image, integer), and
2) ROI layer named [original image]_ewmask (EdgeWave segmentation mask). The layer containing the
original image is made invisible when these results are displayed.

The commands work even if applied to images in another orientation (i.e., Axial Brain EdgeWave\N3 acting
upon a sagittal image). ANY ISSUES WITH USING A MISMATCHED ORIENTATION?
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24.3.1 Brain segmentation profile

Opens the EdgeWave dialog with presets for brain segmentation that apply to the three workflows that
combine non-uniformity correction and segmentation. IS THIS CORRECT? Clicking OK on the EdgeWave
dialog does not start segmentation (as EdgeWave Basic does). Actually running the segmentation requires
calling one of the orientation-specific commands (see next three sections).

24.3.2 Sagittal Brain EdgeWave\N3

Requires sagittal brain images.

24.3.3 Axial Brain EdgeWave\N3

Requires axial brain images.

24.3.4 Coronal Brain EdgeWave\N3

Requires coronal brain images.

24.4 Detect [Group]

The Detect commands automatically identify all voxels in a 3D image [satisfying X condition] and return a
corresponding ROI layer. These commands open dialog windows with adjustable parameters.

24.4.1 Detect bright or dark ridges

Opens Detect ridges dialog with parameters (Fig. 24.3):

Fig. 24.3: Detect Ridges dialog window.
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Operating volume: Increase resolution coefficient – Interpolation – Dropdown menu with the choice
of Tri-linear, (default), Nearest neighbor, Wsinc2, Wsinc3, Wsinc4.

Feature detection: 3D Processing – (Checkbox) Toggles on/off 3D mode. Smooth Radius (vox) –
(Default 8) – Strength threshold [0,1] – (Default 0.05) – Kernel type – Dropdown menu with the choice
of Uniform, Gaussian, Radial, Raleigh, Median, Minimal SI, Maximal SI.

Output – Dropdown menu with the choice of Ridge Mask (ROI layer), Elevation Map (real-valued layer),
and Ridge Skeletons (ROI layer).

These commands create a new document window with two layers: 1) the original image (labeled [original
image]_base), and 2) an ROI layer (labeled Ridges).

24.4.2 Detect bright or dark spots

These commands identify voxels with signal intensity ADD DETAIL and create an ROI layer with these
voxels.

Open Detect spots dialog with parameters (the dialog window looks the same for both commands, Fig.
24.4):

Smooth Radius (vox) – (Default: 8)

Feature threshold [0,1] – (Default: 0.075)

Max spot size (vox) – (Default: 8)

3D Mode (checkbox) – (Default: off)

The commands return results to the original document window and create a new ROI layers labeled spots.

24.5 Feature point detection

24.5.1 Tomasi Feature response map

24.5.2 Tomasi Feature points

24.5.3 Basic Feature response map

24.5.4 Basic Feature detector

24.5.5 Detect Body Mask
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Fig. 24.4: Detect Spots dialog window.
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Chapter 25

Segmentation 4D

� About 4D Segmentation

� 4D Segmentation [Group]

25.1 About 4D Segmentation

ADD CONTENT

25.2 4D Segmentation [Group]

25.2.1 4D: Dynamic Multi-Agent Clustering (DMAC)

25.2.2 4D: Multi-seed nearest within Radius

25.2.3 4D: Multi-seed nearest within DAC threshold

Opens dialog Specify Segmentation distance threshold [0,1]. Requires touchup

25.2.4 4D: Multi-seed segmentation in Real Time (currently unavailable)

25.2.5 4D: Dynamic Clustering

Requires two raster layers. Otherwise error: “Exactly two raster layers should be present.”
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25.2.6 4D: Blood Vessel Map

Requires a dynamic (4D) image and a 3D ROI. Does not have configurable parameters. Creates new ROI
layers labeled blood vessel or Organ, with segmented areas identified based on their enhancement charac-
teristics. IS THIS CORRECT?
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Chapter 26

CT Abdominal Segmentation

This chapter describes semi-automatic segmentation of fat and muscle on abdominal CT images. The purpose
of this segmentation is to delineate various compartments of fat and muscle and measure the areas and
volumes of each compartment. These measurements have been shown to correlate with certain clinical
indicators (see References).

The steps below use the commands under the main menu’s Workflows > CT Abdominal Fat Segmen-
tation group to create the segmentation masks (ROI layers) with automatically assigned names, including:

1) whole fat (total adipose tissue, TAT),

2) subcutaneous fat (subcutaneous adipose tissue, SAT),

3) visceral fat (visceral adipose tissue, VAT),

4) muscle,

5) intramuscular fat (intramuscular adipose tissue, MAT).

The workflow is intended for segmenting CT abdominal images with the field-of-view that extends from the
diaphragm to the sacrum.

References

Chandarana H, Dane B, Mikheev A, Taffel MT, Feng Y, Rusinek H. Visceral adipose tissue in patients
with COVID-19: risk stratification for severity. Abdom Radiol (NY). 2021 Feb;46(2):818-825. PMID:
32748252.

Chandarana H, Pisuchpen N, Krieger R, Dane B, Mikheev A, Feng Y, Kambadakone A, Rusinek H.
Association of body composition parameters measured on CT with risk of hospitalization in patients with
Covid-19. Eur J Radiol. 2021 Dec;145:110031. PMID: 34801878.

The commands in this workflow enable segmentation in two different modes: single slice (2D) and multi-slice
(3D). The 2D commands are labeled “single slice”. Similarly named commands without the “single slice” label
perform 3D segmentation.

After the images are loaded in FireVoxel, the initial step for both 2D and 3D processing is the fully automatic
total fat segmentation (Segment Whole Fat Mask).
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The next step is the segmentation of subcutaneous and visceral fat (SAT and VAT, respectively), which can
also be done automatically (Produce Subcutaneous and Visceral Fat Masks).

The 2D segmentation of SAT and VAT may also be done with the help of a manually defined Abdominal
Cavity (AC) ROI (Segment Abdominal fat using Abdominal Cavity ROI ).

To create the AC ROI, the user needs to draw a vector contour using either the Magnetic Trace tool (Define
Abdominal Cavity using MagTrace) or using the Paintbrush tool and ROI operations (Define Abdominal
Cavity using Paintbrush).

Segmentation of subcutaneous, visceral, and intramuscular fat and muscle can also be performed using the
AC contour (Single Slice 2D: Segment SAT, VAT, MAT and Muscle using AC contour).

The volumes of SAT and VAT compartments, as well as the visceral fat fraction VAT/(SAT+VAT), can be
measured for both automatically and manually segmented ROIs (Measure VAT/(SAT+VAT) ratio). For 2D
manual ROIs obtained with AC, area measurements of SAT, VAT, MAT and muscle may also be obtained
(Measure SAT, VAT, MAT and Muscle).

In 3D, manual segmentation may be done by defining the AC contour on every slice (by copying the contour
to multiple slices and adjusting it) or using the ROI operations (Define Abdominal Cavity using Paintbrush).

26.1 Load and display images

To load CT images in the DICOM format, start FireVoxel and use the main menu to select File > Open
DICOM Single Document . This opens the DICOM Tree dialog (Fig. 26.1) that allows the user to preview
and select images to be loaded. Select (click on series name) or check (check box) the abdominal CT series
and click Load.

This will open the dialog titled Load Volume value conversion, specifying options for the conversion from
Hounsfield units (HU) to signal intensity. Accept the default settings, Load as Unsigned Integer Volume.
With this transformation, air (-1024 HU or -1000 HU, depending on the manufacturer) is assigned 0 grayscale
intensity and water is +1024. Click OK to load the images.

Save the document by selecting on the main menu File > Save FireVoxel Document. The user may wish
to save the document after each processing step to avoid losing results.

Images can be displayed in Film view or Slice view. To toggle between the views, double-right-click on
the image. In Slice view, use Up and Down arrow keys on the keyboard or scroll the mouse wheel to scroll
through slices.

To view the layers in the document (essential in this procedure), double-left click on the image to open the
Layer Control panel. After the images are loaded, only the base image layer is present.
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Fig. 26.1: DICOM Tree dialog to load images.

26.2 Segment Whole Fat Mask (current slice)

Navigate to the slice to be segmented by scrolling the mouse wheel or pressing Up and Down arrow keys.
The first step is the automatic segmentation of the total fat on the selected slice. On the main menu, select
Workflows > CT Abdominal Fat Segmentation > Segment Whole Fat mask (current slice) (Fig.
26.2).

This command opens CT Fat Segmentation Dialog (Fig. 26.3). Accept the defaults and click OK. This
command creates two new ROI layers (Fig. 26.4):

1) auto whole fat slice #[number] – the TAT layer mask, and

2) auto body slice #[number] – the whole body mask (vs background).

In more detail, the whole fat segmentation is done as follows. First, the Body Mask is detected to remove
all objects outside the trunk. The mask is thresholded and followed by mask erosion, dilation and connected
component operations.

The image outside the Body Mask is then cleared to form the Clipped Image. Median filter (radius=2 voxels)
is applied to reduce the noise while preserving the edges. The Clipped Image is then thresholded with fat
interval, default = [-120,-90] HU, to form the initial Whole Fat Mask (WFM). The WFM is then eroded
and dilated by one voxel to remove the fringe of partial volume voxels on the surface of the Body Mask. Salt
& Pepper filter is applied to WFM to remove the remaining small imperfections.

In 3D, the mid-pelvis slice is detected by analyzing the distribution of the bone signal. Starting from mid-
pelvis slice, the distribution of the lung signal is analyzed to determine the bottom of the diaphragm. WFM
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Fig. 26.2: CT Abdominal Segmentation commands.

is then clipped outside the pelvis and diaphragm slices to produce the final WFM.

26.3 Produce Subcutaneous and Visceral Fat Masks

This step automatically separates the total fat mask into subcutaneous and visceral fat masks (SAT and
VAT, respectively).

Make sure that the base image and the auto whole fat slice #[number] (TAT) layer are checked (visible).
Select Workflows > CT Abdominal Fat Segmentation > Produce Subcutaneous and Visceral
Fat Masks (current slice). This opens the CT Fat Segmentation Dialog. Accept defaults and click
OK. During processing, the status bar in the lower left corner of the software window will show the current
processing step. When completed, the command creates two new ROI layers (Fig. 26.5):

1) auto subcutaneous fat (SAT mask),

2) auto visceral fat (VAT mask).
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Fig. 26.3: CT Fat Segmentation Dialog.

Fig. 26.4: Whole fat segmentation result.
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26.4 Segment Abdominal fat using Abdominal Cavity ROI (current slice)

This step describes a method to create SAT and VAT masks with the help of a user-defined Abdominal
Cavity (AC) ROI layer. Here, this method and its results are labeled manual segmentation.

Fig. 26.5: Subcutaneous and visceral fat segmentation result.

26.4.1 Define Abdominal Cavity using MagTrace

The Abdominal Cavity ROI may be created using the Magnetic Trace tool (MagTrace, Trace). The user
draws a MagTrace vector contour around the abdominal cavity, including the abdominal organs and visceral
fat inside the contour and leaving the muscle, bones, and subcutaneous fat outside (Fig. 26.6).

To start MagTrace, on the main menu, select Trace > Start MagTrace. Click along the boundary of AC to
place about 20 anchor points (green circles in Fig. 26.6). Press Esc to finish and exit from the MagTrace
tool.

To reposition an anchor point, click the contour to display the anchor points, hover the mouse over the point
and drag it to the new location. To add an anchor point, hover the cursor over the contour and press Alt+1.
To delete an anchor point, hover the cursor over the point and press Alt+4. To activate the contour click on
the contour; to deactivate, click anywhere outside the contour. All anchor point adjustments are done after
exiting from the MagTrace tool.

Now this vector contour can be used to create a raster ROI layer. Uncheck all ROI layers. With only
the base (image) layer visible, click on the contour to activate it and select Vector > Rasterize selected
Vector entities. This creates a new ROI layer, named New ROI 3D #[roi number], with the voxels inside
the MagTrace contour filled with color (Fig. 26.7). Rename this layer Abdominal Cavity (double-click the
layer name in the Layer Control, type in a new name in the box that opens and click OK).

Alternatively, the user may first create a new ROI layer (Layer Control > New ROI 3D), rename it
Abdominal Cavity, make it the active ROI layer, and then use Vector > Rasterize selected Vector entities
command to create the raster AC ROI in this layer.
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Fig. 26.6: MagTrace contour enclosing abdominal cavity.

26.4.2 Define Abdominal Cavity ROI using Paintbrush

The Abdominal Cavity ROI can also be created using the Paintbrush and ROI tools. Some users may prefer
this method to using MagTrace.

Fig. 26.7: Abdominal Cavity ROI layer.

Create a new layer (Layer Control > New ROI 3D) and rename it Abdominal Cavity. Activate the
Paintbrush tool by holding down Ctrl key and the left mouse and draw a rough contour around the abdominal
organs. The outside boundary of this contour must follow the AC boundary. The shape of the inside boundary
does not matter. Once the contour is completed, release the Ctrl key and mouse button. Make corrections
using the Paintbrush and Eraser (Ctrl + right mouse button). Next, on the main menu, select ROI > Fill
2D Contours. This command fills the inside of the contour and completes the AC ROI. This ROI can be then
used to perform segmentation with Segment Abdominal fat using Abdominal Cavity ROI (current
slice) in the same fashion as the ROI created using MagTrace.
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To define the AC ROI for 3D segmentation, the user may use the Paintbrush to draw the perimeter of the
ROI skipping several slices (e.g., on every 5th slice) on every 5th slice and then use ROI > Morphology >
Fill 2D Contours and Morph Convex to complete the AC ROI.

Fig. 26.8: SAT and VAT segmented with abdominal cavity ROI.

26.4.3 Segment subcutaneous and visceral fat using AC ROI

Check the boxes next to the base image, auto whole fat slice, and Abdominal Cavity layers to make
them visible. Uncheck all other layers.

Select Workflows > CT Abdominal Fat Segmentation > Segment Abdominal fat using Abdom-
inal Cavity ROI (current slice). This command creates two new ROI layers (Fig. 26.8):

1) manual subcutaneous fat slice #[number],

2) manual visceral fat slice #[number].

26.5 Measure VAT/(SAT+VAT) ratio (current slice)

This step allows the user to measure the volumes of visceral and subcutaneous fat compartments (in cm3)
and the visceral fat fraction VAT/(SAT+VAT).

This step will return the measurements for all segmentation layers present in the document, both automatic
and manual, visible or invisible.

On the main menu, select Workflows > CT Abdominal Fat Segmentation > Measure
VAT/(SAT+VAT) ratio (current slice). This opens a dialog displaying the results: VAT volume (cm3),
SAT volume (cm3), and VAT/(SAT+VAT) ratio.

If both automatic and manual segmentation ROIs are present in the document, the SAT, VAT and VAT
fraction are returned for each segmentation type (Fig. 26.9).
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In addition, the relative difference between the automatic and manual segmentation is also shown for the
volumes and the ratio: |auto - manual|/manual.

If layers from only one segmentation type (manual or automatic) are present, the results are shown only for
that type.

To copy these results to clipboard, click on the dialog box and press Ctrl+C, then press Ctrl+V to paste the
results into another application.

Fig. 26.9: Measure VAT/(SAT+VAT) results.

The volumes of each layer in voxels and cubic centimeters can also be obtained by activating the corresponding
layer and using ROI Stats 3D command on Layer Control.

26.6 Single Slice 2D: Segment SAT, VAT, MAT and Muscle using Abdom-
inal Cavity contour (MagTrace)

This step automatically segments muscle and intramuscular fat in addition to the subcutaneous and visceral
fat using the Abdominal Cavity contour (rather than raster AC ROI layer).

Check the boxes for base image and auto whole fat slice #[number]. Make sure that the AC vector
contour is present. On the main menu, selectWorkflows > CT Abdominal Fat Segmentation > Single
Slice 2D: Segment SAT, VAT, MAT and Muscle using Abdominal Cavity contour (MagTrace).
This opens the CT Fat Segmentation dialog (Fig. 26.3). Click OK to accept the defaults.

This commands creates four new ROI layers (Fig. 26.10):

1) manual subcutaneous fat slice #[number],

2) manual visceral fat slice #[number],

26.6. Single Slice 2D: Segment SAT, VAT, MAT and Muscle using Abdominal Cavity contour
(MagTrace)
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3) manual muscle slice #[number],

4) manual muscle fat slice #[number].

Fig. 26.10: SAT, VAT, MAT and muscle segmentation.

This command will also show a dialog with the area measurements (in cm2) for SAT, VAT, MAT and muscle
compartments (Fig. 26.11).

To copy these results to clipboard, click on the dialog box and press Ctrl+C, then press Ctrl+V to paste the
results into another application. Then click OK to close the results box.

These results can also be retrieved using Measure SAT, VAT, MAT and Muscle command described next.
The volumes of each ROI can also be obtained by activating each layer, opening Layer Control and using
ROI Stats 3D.

26.7 Measure SAT, VAT, MAT and Muscle

This step allows the user to measure and display the areas of the ROIs segmented by the Single Slice 2D
command (manual segmentation).

Check the boxes for the base image, manual subcutaneous fat slice #xx, manual visceral fat slice
#xx, manual muscle slice #xx, manual muscle fat slice #xx.

SelectWorkflows >CT Abdominal Fat Segmentation >Measure {SAT, VAT, MAT and Muscle}.
The information dialog with the area measurements (in cm2) of SAT, VAT, MAT and muscle will be displayed,
as in the previous step (Fig. 26.11). These results can be copied to clipboard (Ctrl+C) and pasted elsewhere
(Ctrl+V).

Note that this command returns the ROI areas rather than their volumes, in contrast to Measure
VAT/(SAT+VAT command).
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Fig. 26.11: SAT, VAT, MAT
and muscle areas.
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Chapter 27

Dynamic Analysis

� Dynamic Analysis Commands

� Preparing 4D Data for Analysis

� Aggregate (group)

� Dynamic (group)

� Gradient and Mutual Info (group)

� [Manipulate] (group)

27.1 Dynamic Analysis Commands

TheDynamic Analysis tab contains commands for processing dynamic (four-dimensional, 4D) data. These
commands are broken down into two types.

1. Commands related to model analysis. These include tools for processing dynamic contrast-enhanced
MRI, PET, and CT, diffusion-weighted MRI, intravoxel incoherent motion (IVIM) MRI, T1 and T2 mapping,
and other acquisitions. These commands open dialog panels with multiple user-defined options and are
described in separate sections:

Calculate Parametric Map Image Derived Input Function Cardiac Output Measurement and Correction Con-
vert TAC to Concentration

2. Commands for manipulating dynamic datasets or one-step quantification. These commands
are divided into several groups that are described below:

Aggregate (group) Dynamic (group) Gradient and Mutual Info (group) [Manipulate] (group)
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27.2 Preparing 4D Data for Analysis

Dynamic datasets usually consist of series of 3D volumes acquired at different values of a dynamic variable,
such as time, b-value, echo time (TE), inversion time (TI), flip angle (FA), etc. Dynamic data in DICOM
format can be loaded into FireVoxel using File > Open DICOM commands.

As a rule, FireVoxel automatically determines the type of dynamic data and reads the dynamic variable from
the DICOM header. After loading images into FireVoxel, the user should check if the dynamic variable has
been read correctly. For each 3D volume, the corresponding value of dynamic variable is displayed in the
lower left corner of the main software window. The user can switch between images with different dynamic
variable (e.g., time points) using Right and Left keys on the keyboard (in both the Slice view and the Film
view). To scroll through slices of a 3D image, the user can use the mouse wheel or Up and Down arrows on
the keyboard.

Once the 4D images are properly loaded, they can be pre-processed (for example, co-registered and/or
segmented, if necessary) and then analyzed using various processing methods to determine tissue parameters.

27.3 Aggregate (group)

27.3.1 Aggregate (command)

27.3.2 Aggregation Residual

27.3.3 Aggregation Relative Residual

27.3.4 Aggregate by Median selection

27.4 Dynamic (group)

These commands require the dynamic image to be the active layer. If the active layer is not a 4D image, an
error message is shown: 4D volume is required. The Dynamic commands open a dialog (Specify time
interval) that prompts the user to enter the index of the first and last points (labeled T0 index and T1
index, respectively) of the interval of dynamic variable to be analyzed.

By default, then entire range of dynamic variable is included between the first time point with T0 index =
0 and the last point with T1 index = N-1 (where N is the total number of dynamic points).

The Dynamic group commands determine signal maximum (Max), integral, or average within the [T0, T1]
interval and return the results as 3D voxel maps placed in new, automatically created layers. These new
layers are named the same way as the original image.

Use ViewFilter to change the appearance of the color map. Use ROI Stats 3D to extract quantitative
information from the map.
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27.4.1 Dynamic Max

Create a map with each voxel containing maximum signal intensity in that voxel over the user-specified
interval of time point indices. The result is an integer 3D image.

27.4.2 Dynamic Integral

Create a map with each voxel containing the integral of the signal intensity in that voxel over the user-specified
interval of dynamic variable. The result is a real 3D image.

27.4.3 Dynamic Averaging

Create a voxel map with each each voxel containing the average signal in that voxel over the user-specified
interval. The result is a real 3D image.

27.5 Gradient and Mutual Info (group)

27.5.1 Image Gradient Average over Time

27.5.2 Basic 4D Gradient

Requires a 4D image. Creates a 3D image with width, height, and number of slices the same as in the original
image, in which each voxel contains the signal gradient. ADD DETAILS

27.5.3 Calculate Cross4D Mutual Info over ROI

Requires a 4D image and a visible ROI layer. Returns the value of Cross4D mutual information in the image
processing dialog (Cross4D Mutual Info over ROI [value]). Use Ctrl+C Ctrl+V to copy and paste the dialog
information elsewhere.

If there is no visible ROI layer, an error message is shown (ROI is required in this operation). If there are
two or more visible ROI layers, but the active layer is an ROI layer, the command will be executed using
this layer. If there are two or more visible ROI layers, but none is the active layer, an error message is shown
(Ambiguous layer configuration). The user must select one ROI layer as the active layer, or uncheck the
visibility boxes for all ROI layers but one, for which the command will be executed.
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27.5.4 Calculate Cross4D Mutual Info Norm over ROI

Requires a 4D image and a visible ROI layer. Returns the value of Cross4D mutual information norm in the
image processing dialog (Cross4D Mutual Info over ROI [value]). Use Ctrl+C Ctrl+V to copy and paste the
dialog information elsewhere.

If there is no visible ROI layer, an error message is shown (ROI is required in this operation).

If there are two or more visible ROI layers, but the active layer is an ROI layer, the command will be executed
using this layer.

If there are two or more visible ROI layers, but none of them is the active layer, an error message is shown
(Ambiguous layer configuration). The user must select one ROI layer as the active layer, or uncheck the
visibility boxes for all ROI layers but one, for which the command will be executed.

27.6 [Manipulate] (group)

27.6.1 Extrapolate Multi-echo volume into TE=0

Requires a 4D MRI dataset acquired with echo time (TE) as the dynamic dimension. Opens dialog (Volume
Smooth parameters) with extrapolation parameters (Fig. 27.1).

VERIFY Next, opens dialog (Specify Air threshold) to enter the signal intensity threshold value below which
voxel intensities will not be processed and will be instead replaced with zeros.

Creates a 3D volume calculated by extrapolating data, voxel by voxel, to TE=0 ms.

If the dynamic dimension is NOT the echo time, shows an error message (Echo Time dynamic dimension is
expected).

Note: FireVoxel determines the dynamic dimension automatically when images are loaded. If your 4D data
are opened in FireVoxel with a wrong dynamic dimension, check the loading step first and if this does not
solve your problem, contact the FireVoxel team.

27.6.2 Remove all Dynamic Dimensions except Time

ADD CONTENT Requires a 4D dataset. Removes dynamic dimensions except time.

27.6.3 4D Volume to Principal Components (PCA)

VERIFY Requires a 4D dataset (dimensions WxHxDxN). Opens dialog (Specify Integer) to enter the number
of principal components to keep (P). By default, the number of principal components is the same as the
maximum length of the fourth (dynamic) dimension (N).

Creates a new document (titled [original]_PCA) with the principal component analysis of the original 4D
image and dimensions WxHxDxP.
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27.6.4 Convert 3D layers to 4D volume

VERIFY Requires a 3D volume.

27.6.5 Dynamic Dimension support

VERIFY

Fig. 27.1: Volume
Smooth parameters for
Extrapolate Multi-echo
volume into TE=0.
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Chapter 28

Calculate Parametric Map

� Main steps in dynamic analysis

Dynamic (4D) images are often analyzed to derive quantitative parameters of organs and tissues. FireVoxel
offers a selection of 4D processing tools under the Dynamic Analysis menu tab.

Commonly used 4D processing tasks can be accessed by selecting Dynamic Analysis > Calculate Para-
metric Map.

This command enables various semiquantitative analysis tasks (signal, signal integral, peak analysis, etc.) as
well as model analysis for DWI MRI and IVIM, DCE MRI, relaxometry (measurements of T1, T1rho and
T2 (or T2*) relaxation times), and others. The analysis can be performed for ROI-averaged curves, or voxel
by voxel - for a part of the image within an ROI or for the entire image.

This section describes the main steps of using this command. The details are provided in sections describing
particular workflows.

28.1 Main steps in dynamic analysis

28.1.1 Load dynamic data

Use File > Open DICOM to open browse-for-folder dialog and select the directory with DICOM images.
Once the user selects the directory, the DICOM Tree dialog is displayed. Select the dynamic dataset and
click Load. See Open for details.
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28.1.2 Verify dynamic variable

In most cases, FireVoxel determines the dynamic variable (4th dimension, such as time, b-value, TE, etc.)
automatically from the information in the DICOM header. The user should verify that the dynamic variable
has been read correctly by scrolling through the images using the Left and Right arrow keyboard keys. The
dynamic variable for the current image will be displayed in the lower left corner of the software window. You
can also use Layer Control > Info to view the header information.

28.1.3 Prepare inputs

The analysis is often done for parts of image rather than the entire image. The relevant tissues and organs need
to be segmented prior to the analysis. The segmentation can be performed manually, using the Paintbrush
tool, or using automatic tools (see Segmentation 3D: EdgeWave). Segmentation will produce one or more
ROI layers with segmentation masks.

Compartmental modeling of dynamic contrast-enhanced experiments usually requires an input function (or
input functions). The input function can be determined manually, or using FireVoxel’s Image Derived Input
Function tool, or another method, and saved as a .txt file with at least two columns containing: 1) time, and
2) signal intensity (or concentration). This file needs to be created and saved prior to modeling.

Select ROIs to be analyzed. The analysis may be performed voxel-by-voxel for the entire image, or only
within a selected 3D ROI, or for a curve averaged over a selected 3D ROI, all visible ROIs, or the entire
image (see Processing Options below). If the analysis is to be performed for an ROI (or ROIs), make sure
that the ROI (or ROIs) of interest is/are visible (see Layer Control).

28.1.4 Calculate Parametric Map Dialog

To proceed with analysis, selectDynamic Analysis > Calculate Parametric Map. This command opens
dialog that allows the user to select a model and configure the analysis by selecting inputs, parameters, and
outputs (Parametric Map Calculation for Dynamic Experiment, Fig. 28.1).

Parametric Map Dialog Sections:

Model – Select an appropriate model from the drop-down menu with a list of metrics and models
compatible with the current dataset (six models shown in Fig. 28.1 and Model 26 selected). Each
metric/model is numbered. The compatible models are automatically selected based on the
DICOM header information. For a list of models, see Models.

Input function – Use these buttons (Load, Paste, Delete, Attributes, View, Concentration) for
loading and configuring the input function for compartmental models. For details, see DCE MRI
Model Analysis and Image-Derived Input Function.

Hyperparameters – Enter fixed input parameters or parameter limits into these text boxes.

Outputs – Check boxes for selecting output parameters that will be returned by the analysis. In
voxel-based analysis, each output parameter will create its own parametric map, each placed in
a separate layer. The model parameters that are not checked will be calculated, but not shown
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Fig. 28.1: Parametric Map dialog with models for an MRI dataset with exponentially decaying signal.

as the results. Many models include a measure of goodness of fit among output parameters. See
example in DWI > DWI Output .

Tissue Concentration – Button active for DCE MRI data for setting up the signal-to-
concentration conversion parameters for the tissue of interest. See details in DCE Model Analysis
> Configure model analysis.

Optimization and Noise processing – This part contains parameters of numerical methods
used to obtain the parameters as well as rules for rejecting unreliable results. NOTE: Build
381. This part is under construction and not yet functional.

Processing Options:

The buttons at the bottom of the panel initiate the analysis in one of the three regimes: on a voxel-by-voxel
basis over the entire image, or within an ROI, or for ROI-averaged curve or curves. For examples of output
results, see DWI Results.

Process All – Process the entire image voxel by voxel. For each output parameter, the result
will be displayed as a color map residing in a new, automatically created, real-valued layer. These
new layers will be placed on top of all other layers in the same document window as the original
data. This option is always available, though not always optimal, as whole-image processing may
be time-consuming.

Process ROI Only – Process the visible ROI voxel by voxel. This option is available when 1)
the active layer is a visible ROI layer (other visible ROIs may be present in the document), or 2)
there is a single visible ROI layer (active or inactive). The option is deactivated if no visible ROI
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layers are present (even if one of them is the active layer), or multiple visible ROIs are present,
but the active layer is NOT an ROI. The results are returned as new, color map layers, as in
Process All .

Process ROI/volume/All ROIs as a single curve – Analyze the average signal intensity
within the ROI at every value of dynamic variable as a single curve determined from data averaged
over ROI(s) or the whole volume. The averaging volume depends on the presence and visibility
of ROI layers.

If there is the active ROI layer or a single visible ROI layer, the data will will be averaged within
this ROI and analyzed.

If there are multiple visible ROI layers present in the document, but the active layer is NOT an
ROI, this option is replaced with Process All ROIs as separate curves. In this case, each
ROI is analyzed with the same method and parameters.

If there are NO visible ROI layers, and the active layer is NOT an ROI, this option is replaced
with Process volume as a single curve, which averages the entire image at each dynamic
point.

The result is returned in an output panel showing the data and fit curves and a table of output
parameters. These parameters can then be copied to clipboard and pasted into a spreadsheet or
other software.
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Chapter 29

Models

NOTE: May 11, 2022. Current FireVoxel Build 381. This page is under construction. Content
is added and edited daily.

The following models are available via Dynamic Analysis > Calculate Parametric Map in a dropdown menu
labeled Model (see Fig. 28.1). Only models compatible with the current dataset are shown to the user. The
compatible models are selected automatically based on the DICOM header information of the images in the
current layer.

0. Signal measurements

Fig. 29.1: Model 0.

1. Signal intensity
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Fig. 29.2: Model 1.

2. Peak analysis

3. Interleaved 2-state profile

4. Reference curve distance and correlation: 1IF

5. Time of active rise

6. Model 6

7. Model 7

8. Tofts two compartment exchange model {k-trans, Ve}: I1IF

9. Modified Tofts two compartment exchange model {k-trans, Ve, Va}: 1IF

10. RPF\vACx (AIF integration): 1IF

11. RPF\vACx (AIF convolution): 1IF

12. Model 12

13. Transit Model {wa,ki,kti} (AIF convolution): 1IF

14. GKM with two site water exchange: 1IF
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Fig. 29.3: Model 2.

Fig. 29.4: Model 3.
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Fig. 29.5: Model 4.

Fig. 29.6: Model 5.
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Fig. 29.7: Model 8.

Fig. 29.8: Model 9.
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Fig. 29.9: Model 10.

Fig. 29.10: Model 11.
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Fig. 29.11: Model 13.

Fig. 29.12: Model 14.
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15. Dual Input (Arterial\Portal Vein): {k_trans, V_e, Artf}: 2IF

Fig. 29.13: Model 15.

16-21. Models 16-21

22. S = M0*(1-exp(-TD/T1)) with 6 fixed TD values

23. S=M0*(1-exp(-TD/T1)) – 2 variables, TD=(700/4000) or TD=(350,700,1050,1750,2450,4000)

24-42. Models 24-42

43. 2CXM {vp,ve,Fp,PS} simplex optimization [Flouri 2016]: 1IF

44. Model 44

45. 2CXM {vp,ve,Fp,PS} – LLS: 1IF

46. Same as 43? 2CXM {vp,ve,Fp,PS} simplex optimization [Flouri 2016]: 1IF
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Fig. 29.14: Model 22.

Fig. 29.15: Model 23.
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Fig. 29.16: Model 43.

Fig. 29.17: Model 45.
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Fig. 29.18: Model 46.

47. Tissue Uptake Model {vp,Fp,PS} simplex optimization [Sourbron 2013]: 1IF

48. Model 48

49. MR 2-Compartment Reference Region model [Yankeelov 2005]: 1IF

50. Model 50

51. Model 51

52. Gamma Variate fit: Y(t) = K*((t-TA)/Tspan)^alpha*exp(-(t-TA)/Tspan/beta))
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Fig. 29.19: Model 47.

Fig. 29.20: Model 49.
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Fig. 29.21: Model 52.
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Chapter 30

Diffusion-Weighted MRI (DWI)

� DWI experiment and analysis

� Challenges of DWI quantification

� DWI analysis in FireVoxel

� Loading and preparing DWI data

� Model analysis of DWI

30.1 DWI experiment and analysis

This section describes FireVoxel’s tools for the analysis of diffusion-weighted MRI (DWI).

A typical DWI experiment involves:

� 4D images acquired using diffusion-weighted (DW) sequences, usually spin echo echo-planar imaging
sequences (SE-EPI), at two or more diffusion weighting factors (b-values, in s/mm2) as the dynamic
dimension, and

� Model fitting of DWI data to calculate the apparent diffusion coefficient (ADC, mm2/s) and other
parameters of tissues of interest.

30.2 Challenges of DWI quantification

Accurate quantification of tissue parameters from DWI presents a number of challenges, including:

� Inherently low signal-to-noise ratio, especially at high b-values;

� Artifacts (geometric distortions, ghost images, susceptibility artifacts, etc.);

� Complexity of tissue diffusion (due to the presence of anisotropy, microperfusion, etc.) that may not
be accurately captured by the diffusion model;
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� Computational challenges: Efficient voxel-based fitting, overfitting, etc.

30.3 DWI analysis in FireVoxel

FireVoxel offers a set of tools for the analysis of DWI data, including image loading, preview, signal visual-
ization, motion correction, and model analysis.

30.4 Loading and preparing DWI data

DW images in DICOM format can be loaded into FireVoxel as 4D datasets using File > Open DICOM
Single Document or Open DICOM Multiple Documents (DICOM Tree dialog, Fig. 30.1).

Fig. 30.1: DICOM Tree dialog for loading DWI dataset.

In the DICOM Tree dialog, DW images are organized by PATIENT, STUDY, 4D volume lists (VL, ), and

3D volumes (V, ). The user may load the entire 4D series (VL) or individual 3D volumes (V) by checking
the boxes next to the corresponding titles and clicking Load. If no boxes are checked, the entry highlighted
with a red box will be loaded.

For most MRI systems, the b-values should be automatically read from the DICOM header (Diffusion b-value
Attribute (0018,9087)). Please contact the FireVoxel team about any issues with image loading.

It is important to verify the correctness of the b-values once the images are loaded into FireVoxel. To do
this, scroll through the images using the Right and Left arrow keys on the keyboard and check the b values
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displayed in the status bar in the lower left corner of the main software window (Fig. 30.2). To scroll through
slices, use Up and Down arrow keys.

Fig. 30.2: The status bar in the lower left displays the current b-value.

The signal change with b-value can also be viewed using Play 4D experiment tool on the main toolbar.

The local signal behavior can also be visualized using Voxel Time Activity Browser .

Before proceeding with the analysis, the user is advised to check the images for any issues, for example,
motion artifacts, and decide whether any preprocessing, such as motion correction, may be necessary.

If the images are affected by motion, the user may use 4D coregistration tools to align images.

Prior to modeling, it is recommended to segment the organs or tissues of interest using FireVoxel’s segmen-
tation tools and perform initial voxel-based analysis within these ROIs (Fig. 30.3).

30.5 Model analysis of DWI

The analysis of DWI data may be performed using Dynamic Analysis > Calculate Parametric Map

command, also available via toolbar icon. The command opens a dialog panel for setting up the model
analysis (Parametric Map Calculation for Dynamic Experiment, Fig. 30.4).

30.5.1 Model

The top part of the panel (labeled Model) contains a drop-down menu with a numbered list of models
compatible with the current dataset. The compatibility between data and models is determined by FireVoxel
automatically based on the DICOM header information. Models that are not compatible with the current
dataset are not shown.

The following models are compatible with the DWI data:
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Fig. 30.3: The ROIs allow the user to examine parameters of tissues of interest.

Fig. 30.4: Calculate Parametric Map dialog for DWI.
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Model 17: IVIM bi-exponential diffusion (segmented fit) Model 18: IVIM bi-exponential diffusion (regular fit)

𝑆 = 𝑆0(𝑓 · 𝑒𝑥𝑝(−𝑏 ·𝐷𝑝) + (1− 𝑓)𝑒𝑥𝑝(−𝑏 ·𝐷𝑡)) (30.1)

Model 19: Monoexponential diffusion

𝑆 = 𝑆0𝑒𝑥𝑝(−𝑏 ·𝐴𝐷𝐶) (30.2)

Model 21: Stretched exponential fit

𝑆 = 𝑆0𝑒𝑥𝑝(−𝑏 ·𝐷𝐷𝐶)𝛼 (30.3)

Model 28: Diffusional kurtosis

𝑆 = 𝑆0𝑒𝑥𝑝(−𝑏 ·𝐷 + 𝑏2 ·𝐷2 ·𝐾/6) (30.4)

The following description will focus onModel 19 (monoexponential diffusion). The analysis using other
models can be done in a similar way.

30.5.2 Hyperparameters

This series of text boxes allows the user to specify the fixed input parameters (referred to below as hyperpa-
rameters) and the bounds of the fitted model parameters:

Low signal tail cutoff – If signal intensity falls below this cutoff value, the data at the corresponding
b-value and all higher b-values are discarded from fitting.

Maximal ADC (mm^2/sec) – Upper limit on the ADC value.

[Tissue Concentration – Not relevant to DWI processing. Opens Concentration Conversion dialog
for setting up the conversion from signal intensity to contrast concentration in contrast-enhanced CT and
dynamic contrast-enhanced MRI experiments. By default, unconverted Signal values are selected, so no
further action is needed for DWI analysis. This option will be removed in future builds.]

30.5.3 Output

These checkboxes allow the user to select the parameters that will be returned as the results of model analysis.
At least one output parameter must be selected. For curve fitting models, the output parameters also include
a measure of goodness of fit, such as the root-mean-square error

𝑅𝑀𝑆𝐸 =

√︂
1

𝑛

∑︁
(𝑦𝑖 − 𝑦𝑖)2 (30.5)

where 𝑦𝑖 and 𝑦𝑖 are the signal data and model fit values, respectively, at 𝑖-th value of the dynamic variable
(𝑖 = 1, 2, ...𝑛).

Model 19 (monoexponential diffusion) has two possible outputs: the apparent diffusion coefficient (ADC)
and the fit residual.

Select All or Unselect All – Clicking these buttons selects or unselects all output parameters.
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30.5.4 Optimization

UNDER DEVELOPMENT

This block controls the optimization options for the curve fitting models (for both voxel-based and average
curve fitting analyses, see Fitting Options).

[Optimization method] – Dropdown menu with a choice of: 1) Simplex optimization or 2) Global opti-
mization.

Simplex optimization is based on the simplex Nelder-Mead (or amoeba) method. As a heuristic, it finds an
optimal solution by iteratively replacing the worst solution with a better solution at each step. The simplex
method starts from multiple grid points for fitted parameters, which ensures a more optimal solution, but
is not guaranteed to yield the global optimum. The precision of the simplex solution is determined by
a combination of the number of simplex grid points and the number of iterations (see Simplex grid and
#Iterations below). Simplex optimization can work efficiently with multiparameter models. In FireVoxel, all
convolutional models currently use simplex optimization.

Global optimization is based on interval arithmetic, branch-and-bound approach that always searches for a
guaranteed global optimum. The precision of global optimization is controlled by fitted parameter bounds
(see Hyperparameters) and the maximum allowed number of iterations. Global optimization provides the
exact solution bounds on the globally optimal parameters and fitting residual (which heuristic methods, such
as simplex optimization, cannot provide). With increasing number of iterations, the solution bounds become
tighter. For models with multiple parameters, global optimization may become impractical because of the
high computational cost.

Simplex grid – Number of grid points Ng (typically 3 to 5) for simplex optimization. For the monoexpo-
nential model, the grid points are constructed by dividing the full ADC range from 0 to the maximum ADC
into (Ng-1) equal subintervals. For other models, Ng applies to each of the fitted parameters.

#Iterations – Maximum number of iterations used as a stopping criterion in simplex fitting. Higher numbers
may help achieve a better fit but will also require longer processing times.

30.5.5 Noise processing

UNDER DEVELOPMENT

Sets the parameters of noise and excluding unreliable data and/or results:

Noise – Noise level.

Exclude RRSE above – Checkbox and text box (for cutoff value) – Exclude voxels with poor quality fit.
If the box is checked, replace with VOID any voxel for which RMSE is above the cutoff entered in the text
box. Trial and error is often used to establish the desired cutoff.

Exclude parameters above (%) – Checkbox and text box (to enter percent cutoff) – Exclude voxels that
yield exceedingly large or negative parameters. If the box is checked, replace with VOID any voxel where
ADC is greater than percent cutoff as defined by maximum ADC.
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30.5.6 Fitting options: Process All, Process ROI Only, Process ROI as a single curve

These buttons at the bottom of the panel enable the user to select how the model analysis is performed: on
a voxel-by-voxel basis over the entire image, or within an ROI, or for an ROI-averaged curve. The available
options depend on the presence of a visible ROI layer (or layers). If ROIs are invisible or not present at all,
only the entire image can be modeled (voxel-by-voxel or as an average curve). If multiple ROI layers are
visible and one of them is active, the model analysis is performed for the active ROI. If ROIs are visible, but
none of them is active, modeling is available either for the entire image or for all of the ROI-averaged curves.

Process All – Fit the entire image voxel by voxel. For each output parameter, the result will be displayed
as a color map residing in a new, automatically created real-valued layer. These new layers will be placed on
top of all other layers in the same document window as the original data.

Process ROI Only – Enabled when the active layer is a visible ROI. The model analysis is performed on a
voxel-by-voxel basis within the ROI. If more than one ROI is present, but none of them is active, this option
is not available. The results will be returned as new, color map layers, as in Process All.

Process ROI/volume/All ROIs as a single curve – The functionality depends on the active layer:

1) The active layer is a visible ROI – Fit the curve obtained by averaging the signal within the active ROI.

2) The active layer is an image layer and no ROIs are visible or present – Fit the signal averaged over the
entire volume.

3) The active layer is an image layer, and multiple visible ROI layers are present – Fit the curves obtained
by averaging each visible ROI.

Extrapolate – Create an extrapolated 4D volume corresponding to the user-specified values of the dynamic
variable (b value for DWI), with signal in each voxel computed based on the model formula and fitted
parameters. The extrapolated 3D volumes are added to the original image set and displayed in a new
document window titled [original document]_extrapolated.

30.5.7 Results

The results correspond to the fitting options selected in the previous step:

Process All – Parametric maps, displayed as color maps, for the entire image. The appearance of the color
maps can be customized using ViewFilter command on the Layer Control panel (Fig. 30.5).

Process ROI Only – Parametric maps within the filled (non-zero) ROI voxels; all other voxels remain fully
transparent. Again, the appearance of the color maps can be customized using ViewFilter (Fig. 30.6).

Process volume/ROI/ROIs as a curve – Opens the output panel (Dynamic Experiment Single
Curve Results: [Model name], Fig. 30.7). The panel consists of three parts.

The top part of the panel displays a plot of the signal data and the model fit as a function of the dynamic
variable (for DWI b-value, s/mm2). The bottom right part shows the current ROI (and a dropdown menu
to select other ROIs, if multiple ROIs were fitted). Below the ROI menu are the color swatches for the data

30.5. Model analysis of DWI 226



FireVoxel: User Manual, Draft 2025-04-29

Fig. 30.5: Process All results showing whole-image ADC map.
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Fig. 30.6: Fit ROI Only results showing map of ADC for the right kidney.
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Fig. 30.7: Dynamic Experiment Single Curve Results panel.
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curve, fit curve, and the plot background. The buttons next to the color swatches open the standard color
picker for selecting the colors of the curves and the background.

The bottom left part under the plot contains a table of fitted parameters with the columns showing parameter
name, fitted value, and units (if applicable). For Model 19, the table lists the ADC and residual as the output
parameters.

For global optimization, the table also shows the lower and upper solution bounds [LB, UB] on the globally
optimal parameter value OV and percent spread = 100%*max(OV-LB, UB-OV)/OV.

Offset signal (checkbox) – Toggles on/off the vertical axis offset. If checked, the vertical axis range is
restricted to the interval between the smallest and largest value of the data or fitting curve. If unchecked,
the vertical axis range is from zero to the largest data/fit value.

Copy results to clipboard – Copies fitted parameters to the clipboard and makes them available for
posting into a text file or spreadsheet. For each ROI, each parameter is recorded in a separate line (ROI
name, parameter name, fitted parameter value, and units, if applicable).

OK – Closes the panel.

30.5.8 Analyzing parametric maps with ROI Stats 3D

To explore the ADC voxel values within an ROI, make sure that this ROI is the only visible ROI layer and
the ADC map is the active layer, then click ROI Stats 3D on the Layer Control panel. This command
opens a panel (ROI Stats 3D) that provides the histogram, selected features, and other statistics of the
parameter distribution.

The top part of the panel shows the histogram of the voxel distribution of the parameter values. The options
controlling the histogram are located below the histogram. These options include the Range, Number of
bins, and Bin Width.

By default, the full range of values is displayed. To adjust the range, click Range to open dialog showing
the lower and upper bounds and type new values. If Clip box is checked, the values outside the Range are
not included into the histogram and from statistics calculation. This is reflected in the first order features
and ROI voxel count (under Geometrical features). In response to the change of Range, the Number
of bins is automatically updated (if Bin Width stays unchanged).

The range may also be set via specifying the low and high percentile bounds to be displayed (by clicking the
% button and entering the corresponding values). Clicking Full restores the full range of values included
into the histogram.

The lower left part of the panel lists the first order features of the voxel values distribution, including the
mean, standard deviations, etc., as well as a selection of percentile values between 1% and 95%.

All values are displayed in scientific notation, e.g., mean ADC = 3.487193e-03 = 0.003487193.

Geometrical features list the voxel count and ROI volume and other parameters.

The Segmentation\Modeling options on the lower right enable partitioning (segmentation) of ROI voxels
into subgroups, such as viable tissue versus necrotic tissue, based on the voxel value distribution. Voxels
within each subgroup are presumed to have similar parameter values.
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Fig. 30.8: The ROI Stats 3D panel showing ADC statistics within the left kidney ROI.
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Clicking Save Stats opens a text file with the main statistical results (named RoiStats3D.txt), including
ROI volume, first order features, and histogram. By default, this file is created in FireVoxel’s Temp directory,
but can be saved in any user-selected directory.
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Chapter 31

IVIM

� Basics of IVIM

� Model 17: IVIM bi-exponential diffusion Segmented Fit

� Model 18: IVIM bi-exponential diffusion

31.1 Basics of IVIM

Intravoxel incoherent motion (IVIM) imaging is a type of diffusion-weighted (DW) MRI that separates the
contributions of molecular diffusion and microcirculation (microperfusion) to the diffusion-weighted signal
[LeBihan1988].

Diffusion-weighted MRI (DWI) data at different b-values, S(b), are described by the model expression with
separate terms due to microcirculation and diffusion (31.1):

𝑆 = 𝑆0(𝑓 · 𝑒𝑥𝑝(−𝑏 ·𝐷𝑝) + (1− 𝑓)𝑒𝑥𝑝(−𝑏 ·𝐷𝑡)) (31.1)

Here S0=S(b=0) is the unweighted signal, Dp is the perfusion-dominated pseudodiffusion coefficient (denoted
D* in some sources), Dt is the true diffusion coefficient (or D), and f is the perfusion fraction (also referred
to as microcirculation fraction) [Koh2011], [LeBihan2019].

In FireVoxel, IVIM modeling is available via Dynamic Analysis > Calculate Parametric Map, Models 17
and 18, which represent two different computational approaches to the analysis of multi-b-value DWI data.

Aside from the choice of the models, the processing routine (which includes loading and preparing data,
setting up the model analysis, and output options) is similar to the routine for Diffusion-Weighted Imaging
(DWI).
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Fig. 31.1: IVIM model fit (blue - data, red - fit, orange - monexponential fit to b>200 s/mm2).

31.2 Model 17: IVIM bi-exponential diffusion Segmented Fit

Model 17 implements the segmented curve fit, as proposed by Sigmund et al [Sigmund2011] for analyzing
IVIM data in breast lesions. This fit is performed in two steps (Fig. 31.1). First, the data at higher b-values
(b>~200 s/mm2) are used to compute the true diffusion coefficient Dt and perfusion fraction f. These values
are then fixed and used to determine Dp.

Model 17 requires DW data with at least three b-values greater than 200 s/mm2. If the user
attempts to process an incompatible dataset, the model shows an error message, advising the user to select
Model 18: IVIM bi-exponential fit .

This goal of this approach is to improve the robustness of the model output parameters by reducing the
number of parameters at each fitting step. This approach may be preferable for datasets with relatively few
b-values and signal data with higher noise, such as when performing model analysis on a voxel-by-voxel basis.

The pseudodiffusion coefficient Dp is typically much greater than Dt. Therefore for b much greater than
~1/Dp (e.g., for Dp~10 x 10-3 mm2/s, b>100 s/mm2), the contribution of the pseudodiffusion term to the
signal S(b) is small compared to the contribution of the true diffusion form. Considering only these higher
b-values, the IVIM model equation reduces to a monoexponential fit expression with only f and Dt:

𝑆 = 𝑆0(1− 𝑓)𝑒𝑥𝑝(−𝑏 ·𝐷𝑡) (31.2)

Using this monoexponential fit, Dt can be determined from data at b-values above a given threshold (in
FireVoxel, b>200 s/mm2 by default), with zero intercept Si and S0=S(b=0) used to determine the perfusion
fraction f:

𝑓 = (𝑆0 − 𝑆𝑖)/𝑆0 (31.3)

With Dt and f fixed at these values, the values of Dp can be determined by using a nonlinear fit of the entire
dataset with (eq).

The parameters of model 17 are as follows (Fig. 31.2):

Model 17 hyperparameters:

� maximal Dp (mm^/sec) - Upper limit on pseudodiffusion coefficient Dp. Default: 1 (mm
2/s).

� maximal Dt (mm^/sec) - Upper limit on true diffusion coefficient Dt. Default: 0.01 (mm
2/s).

� B-value Tail Start - The data at b-values higher than this threshold value are used to determine Dt

and f. Default: 199.99 (s/mm2). At least three b-values greater than this threshold are required. If
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Fig. 31.2: Model 17 IVIM dialog with default hyperparameters.

this condition is not met, an error message is shown. Model 18, which does not have this restriction,
can be used instead.

Model 17 output parameters:

� S0 - Unweighted signal S0=S(b=0)

� f microcirculation fraction - Microcirculation (microperfusion) fraction f (unitless)

� Dp component - pseudodiffusion coefficient Dp (mm2/s)

� Dt component - true diffusion coefficient Dt (mm
2/s)

� Dp x f - Composite parameter describing microcirculation (microperfusion) (mm2/s)

� Dt x 1-f - Composite parameter describing true diffusion (mm2/s)

� RMSE - Root-mean-square error of the model fit

The output of Model 17 with Process ROI as a single curve option yields fitted parameters that can be
exported (Fig. 31.3).
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Fig. 31.3: Model 17 IVIM segmented fit results.
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31.3 Model 18: IVIM bi-exponential diffusion

Model 18 performs regular nonlinear curve fit of all signal intensities at all b-values. This model requires a 4D
DW dataset consisting of 3D volumes acquired at different b-values. There is no restriction on the number
of b-values. However, analysis of datasets with few b-values (n~5) is likely to yield fitted parameters with
larger uncertainties than analysis of larger datasets. This may also entail convergence of the fit to various
local minima depending on the values of hyperparameters.

The parameters of Model 18 are as follows (Fig. 31.4).

Fig. 31.4: Model 18 IVIM (regular) biexponential fit dialog.

Model 18 hyperparameters:

� Low signal tail cutoff - Signal value below which data are excluded from fit. Default: 0.

� maximal Dp (mm^/sec) - Upper limit on pseudodiffusion coefficient Dp. Default: 1 (mm
2/s).

� maximal Dt (mm^/sec) - Upper limit on true diffusion coefficient Dt. Default: 0.01 (mm
2/s).

� maximal f - Upper limit of microcirculation fraction f. Default: 1.

Model 18 parameters:

� f microcirculation fraction - Microcirculation (microperfusion) fraction f (unitless)

� Dp component - pseudodiffusion coefficient Dp (mm2/s)

� Dt component - true diffusion coefficient Dt (mm
2/s)
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� Dp x f - Composite parameter describing microcirculation (microperfusion) (mm2/s)

� Dt x 1-f - Composite parameter describing true diffusion (mm2/s)

� RMSE - Root-mean-square error of the model fit

The results of Model 18 (Fig. 31.5) for the same data as in Fig. 31.3 enables comparisons between the two
fitting approaches.

Fig. 31.5: Model 18 IVIM (regular) biexponential output.
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T2 and T2* Mapping

� T2 or T2* data

� Compute T2 or T2*

32.1 T2 or T2* data

Relaxation times T2 and T2* are usually determined from 4D MRI data acquired with multiple gradient
echo sequences at different echo times (TE). These images are then analyzed with an appropriate model (e.g.,
monoexponential or bi-exponential) and fitted values of the relaxation times are determined as a result. The
processing routine for T2 or T2* relaxometry is similar to the routine for DWI .

32.2 Compute T2 or T2*

1. Load images. Use Open > Open DICOM folder: Single Document . This opens the DICOM Tree
Dialog . Select the multiple gradient echo series and click Load. The images will be loaded and displayed
in a new document window.

2. Check images. Verify that the 4D images were loaded correctly by scrolling through the dynamic
variable. Click the right arrow key on the keyboard several times. The image intensity must decrease
as the echo time increases.

3. Check dynamic variable. Now check that FireVoxel correctly read the dynamic variable, TE. Open
the Layer Control and click Info. The layer information panel will open. Click on the lower right part
that shows a summary of the main DICOM fields and scroll to the bottom. This part usually displays
the dynamic variable for every frame of the 4D image. For T2 or T2* data, this part should show a list
of echo times (in seconds). If this list is not displayed, check your data and/or contact the FireVoxel
team for assistance. If you see the correct TE values, you proceed with your analysis.

4. Segment the tissue or organ of interest. You can define these ROIs manually (see Drawing raster
ROIs), or using a combination of manual drawing and ROI tools (see ROI> Morphology>Fill 2D
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Contours and Fill Convex ), or with fully automatic tools (Segment 3D: EdgeWave). The segmentation
mask will reside in an ROI layer. Label ROIs clearly if multiple ROI layers are present in the document.

5. Perform model analysis. Make sure that the base layer is active and the ROI is visible. Select

Dynamic Analysis > Calculate Parametric Map or click toolbar icon.

The Parametric Map Calculation dialog will open. In the Model dropdown menu, select Model 16.
T2 or T2* mono-exponential mapping. In most cases, the default values of hyperparameters are
acceptable. Select at least one output parameter (usually T2 or R2).

Select the processing option by clicking one of the buttons at the bottom of the dialog: Process all,
Process ROI only, Process volume as a single curve. Note that Process ROI only is available
only when there is a single visible ROI in the document.

When the user clicks a button that initiates voxel-by-voxel fitting, a summary dialog with the data,
model, and ROI is shown, and the user is asked to confirm these details. Once the user clicks OK,
processing starts and may be time consuming for large voxel maps.

If the user selects Process ROI/volume as a single curve, there is no confirmation screen, but
instead the results are returned in the Dynamic Experiment Single Curve Results dialog. This
dialog shows the plot of data and model curve and a table of parameters, as well as controls for
customizing this plot and generating report.

6. Inspect modeling results. The results of voxel-based analysis are returned in automatically created
real-valued layers and the maps are displayed as colormaps. Activate the parametric maps in Layer
Control and select ROI Stats 3D to explore the parameter statistics.

7. Save modeling results. The easiest way to save the parametric maps is to save them together with
the data as a FireVoxel document (.fvx). Alternatively, these maps can be saved as NIfTI images.
Activate the map in Layer Control and select Save as Image > (NIfTI) or select File > Save Active
Layer as Image > (NIfTI).
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Chapter 33

Basics of DCE MRI

� DCE MRI experiment and analysis

� Contrast agents: Safety, dose, concentration, and volume

– Contrast agent safety

– Injected dose

– Contrast agent concentration

– Injected volume of contrast agent

� Conversion of MRI signal to contrast concentration

– Fast exchange limit

– Concentration units

– Relaxivity of the contrast agent

– Pre-contrast T10 in tissues and blood

– T1-mapping

– Signal to concentration conversion with gradient echo signal expression

– Linear approximation at low concentration

33.1 DCE MRI experiment and analysis

This section summarizes the information about the T1-weighted dynamic contrast-enhanced MRI (DCE
MRI) MRI and issues related to the quantification of contrast concentration and tissue parameters from
DCE MRI data.

A typical DCE MRI experiment (for quantitative model analysis) involves:

� Human subjects imaged at 1.5 T or 3.0 T,
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� Bolus injection of Gd-based contrast agent (GBCA) into a peripheral vein,

� Serial images acquired using T1-weighted gradient-echo (GRE) sequence with temporal resolution of a
few seconds (15 s or less),

� Images acquired in coronal, oblique coronal, or axial plane,

� Blood signal sampled in a vessel feeding the tissue of interest to determine the arterial input function
(AIF) driving a compartmental model describing the tissue,

� Tissue and blood signal converted to gadolinium (Gd) concentration,

� Model fitting of tissue concentration performed to derive tissue parameters.

In the first approximation, all complexities are ignored (non-uniformity, artifacts, high field imaging, parallel
imaging, animal imaging, etc.).

33.2 Contrast agents: Safety, dose, concentration, and volume

33.2.1 Contrast agent safety

The FDA-approved gadolinium-based contrast agents (GBCA) currently include: Dotarem (Clariscan), Eo-
vist, Gadavist (Gadovist), Magnevist, MultiHance, Omniscan, Optimark, and ProHance. Among these,
Eovist is used to detect and characterize liver lesions. The other GBCA may be used for DCE MRI in the
brain and body.

Since the late 1990x, GBCA have been found to increase the risk of nephrogenic systemic fibrosis (NSF), a
rare, but serious, condition in patients with kidney dysfunction (FDA 2010). The risk of NSF was the highest
for linear GBCA (such as Magnevist, Omniscan, and Optimark) and in patients with estimated glomerular
filtration rate GFR <30 mL/min/1.73m2. As a result, in the European Union, since 2017 the use of linear
GBCA has been suspended, except in liver imaging (European Medicines Agency 2017).

Since the adoption of safety measures (such as using predominantly macrocyclic GBCA and screening patients
with severe, chronic kidney disease (CKD) or acute kidney injury (AKI)), new cases of unconfounded NSF
have been nearly eliminated.

Subsequently, it has been determined that gadolinium from GBCA is retained in the brain, liver, bone, and
skin (Mathur 2020 PMID: 31809230; Marks 2021 PMID: 33868652).

The retention of gadolinium is higher with Omniscan and Optimark than after Eovist, Magnevist, or Multi-
Hance. The retention is the least after Dotarem, Gadavist, or ProHance.

The updated FDA recommendations (FDA 2018) advise considering the retention characteristics of each
agent for patients at risk and using GBCA judiciously, especially for repeated examinations. Although the
deposition of gadolinium in the brain has not been linked to any adverse effects on health, risk-to-benefit
ratio of GBCA use is advised in each case.
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33.2.2 Injected dose

The dose of gadolinium (in millimoles, mmol) administered to the patient may be:

� A fixed amount, constant for all patients in the cohort, or, more commonly,

� An amount proportional to the patient’s weight (typically 0.1-0.2 mmol/kg). Thus, a patient weighing
80 kg and dosed at 0.1 mmol/kg will receive 8 mmol of gadolinium.

For repeat studies (such as the evaluation of response to treatment), it is important that the dose be deter-
mined the same way for the baseline and the follow-up examinations.

33.2.3 Contrast agent concentration

Contrast agents are formulated as solutions with different concentrations of gadolinium (Table 33.1).

Table 33.1: Contrast agent concentrations

Contrast Agent Concentration (mmol/mL)

Magnevist, ProHance, Omniscan, MultiHance, Dotarem/Clariscan 0.50
Gadavist (US) (Gadovist elsewhere) 1.00
Eovist 0.25

The FDA label format varies and may list: concentration in mg/mL, mmol/mL, or mmol/L, molar mass,
recommended dose per weight for different applications, and other parameters.

33.2.4 Injected volume of contrast agent

The injected volume is equal to the dose of Gd (mmol) divided by concentration (mmol/mL). Thus, the
patient receiving 8 mmol of Gd would need 16 mL of MultiHance, but only 8 mL of Gadavist.

33.3 Conversion of MRI signal to contrast concentration

33.3.1 Fast exchange limit

DCE MRI data are often analyzed assuming fast water exchange, when water protons in tissue move across
tissue compartments much faster than they interact with the contrast agent. The tissue is then described
by a single, uniform relaxation rate R1 (or relaxation time T1, so that R1=1/T1) and the change in R1 is
proportional to the concentration of Gd contrast:

𝐶(𝑡) =
1

𝑟1

(︂
1

𝑇1(𝑡)
− 1

𝑇1(0)

)︂
(33.1)

where:
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𝐶(𝑡) – concentration of Gd (units: mmol/L = mM)

𝑟1 – longitudinal relaxivity of the contrast agent (L/(mmol x s) = mM-1 s-1)

𝑇1(0) = 𝑇10 – pre-contrast longitudinal relaxation time of blood or tissue (s)

𝑇1(𝑡) – post-contrast longitudinal relaxation time of blood or tissue (s).

33.3.2 Concentration units

The concentration units (for tissue or blood) are customarily mmol/L = mM. In the US, the preferred
notation for liter and milliliter is L and mL, respectively (NIST SP330 2019, p. iii and p. 25, Table 8).
However, lower case l and ml are often used as well (US Metric Association).

33.3.3 Relaxivity of the contrast agent

Relaxivity of the contrast agent is dependent on magnetic field strength, temperature, and medium (e.g.,
water, plasma, or whole blood) and is usually obtained from manufacturer’s data and literature. For exam-
ple, at 3 T in human plasma, the relaxivity of ProHance (gadoteridol) is r1=3.28 mM-1 s-1 and Gadavist
(gadobutrol) r1= 4.97 mM-1 s-1.

33.3.4 Pre-contrast T10 in tissues and blood

Tissue T10

Pre-contrast T10 in tissue may be measured individually (and quantified via ROI- or voxel-by-voxel fitting,
see T1-mapping) or assigned a fixed value for a given tissue type and field strength. Examples of T10

measurements in various tissues include:

� Abdomen 1.5T and 3T – de Bazelaire 2004 PMID: 14990831

� Breast 1.5T and 3T – Rakow-Penner 2006 PMID: 16315211

� Brain and body 3T (extensive collection of literature T10 and T20 values) – Zavala Bojorquez 2017
PMID: 27594531

� Brain at 1.5T, 3T, 7T – Wright 2008 PMID: 18259791.

33.3.5 T1-mapping

Warning: 02.04.2022 This section is under construction.

Quantitative T1-mapping, or T1-relaxometry, is used to measure precontrast (unenhanced) T1 values. Com-
mon methods of T1-mapping include inversion recovery, multiple flip angle, inversion recovery TrueFISP,
etc.
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FireVoxel enables T1-mapping based on inversion recovery (IR) or multiple flip angle (mFA) acquisitions
throughDynamic Analysis > Calculate Parametric Map. A T1-map can be created using the following
sequence of steps:

1. Load data. Both IR and mFA data are 4D datasets. See Open for details. The dynamic variable
is automatically determined from DICOM headers. It is always a good practice to check if the 4D signal
behaves as expected for this acquisition (see View).

2. Segment tissue or organ of interest (optional). Segment tissue or organ of interest using manual ROI
drawing, ROI operations, or automatic segmentation. This step is optional, but may help saving processing
time.

3. Perform model analysis to generate T1-map. Mark the base image as active, and make sure that
the segmentation mask (ROI) is visible. Select Dynamic Analysis > Calculate Parametric Map and
configure model analysis.

The following models are available for analyzing mFA data:

� Model 24: T1 mapping using variable flip angle;

� Model 42: T1 mapping using variable flip angle with B-field;

� Model 51: T1 mapping using variable flip angle and TR with bias field;

� Model 53: T1 mapping using variable flip angle and two TR values.

The output parameters always include T10 (in seconds) and additional parameters. The results are returned
as a colormap in a new, automatically created, real-valued layer. The user may perform quality control of
the T1-map using Layer Control > ROI Stats 3D. The resulting map may be coregistered with the DCE
MRI data (see Coregister using DICOM Tags).

Blood T10

Pre-contrast blood T10 varies with the field strength, temperature, and blood oxygenation. Fixed literature
values of blood T10 are often used DCE MRI analysis (see examples in Table 33.2).
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Table 33.2: Selected studies of pre-contrast blood T10

Reference/Experiment Measured in Field T10
(ms)

Lu et al. 2004. PMID 15334591
Flow phantom 37°C

Arterial
blood

3T 1664

Venous
blood

3T 1584

Zhang et al. 2013. PMID 23172845
Healthy volunteers (sagittal sinus)

Venous
blood

1.5T 1480

Venous
blood

3T 1649

Venous
blood

7T 2087

Shimada et al. 2012. PMID 23269013
Healthy volunteers (abdominal aorta, jugular vein)

Arterial
blood

3T 1779

Venous
blood

3T 1694

Vatnehol et al. 2019. PMID 30604145
Healthy volunteers (portal vein)

Venous
blood

3T 1733

As noted by Zhang et al. (Zhang 2013 PMID: 23172845), “At 1.5 T, arterial and venous blood T1 values are
virtually the same, whereas arterial blood T1 is 79 ms higher than venous blood T1 at 3 T and 330 ms at
4.7 T.”

Additionally, in vitro T10 of blood and plasma are often reported in studies of contrast agent relaxivity (Shen
2015 PMID: 25658049; Rohrer 2005 PMID: 16230904).

33.3.6 Signal to concentration conversion with gradient echo signal expression

MRI signal can be related to blood or tissue relaxation rate R1=1/T1 using the Spoiled Gradient Recalled
(SPGR) echo signal expression:

𝑆(𝑡) = 𝑀0 sin𝛼
1− exp

(︁
− TR

𝑇1(𝑡)

)︁
1− cos𝛼 exp

(︁
− TR

𝑇1(𝑡)

)︁ exp

(︂
− TE

𝑇 *
2 (𝑡)

)︂
(33.2)
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where TR is the repetition time and 𝛼 is the flip angle. M0 is the equilibrium magnetization (for 𝛼 = 90∘

and TR>>T1(0), which accounts for the spin density and receiver gain.

At short TE (TE<<T2*), the T2* effect can be ignored (Schabel & Parker 2008 PMID: 18421121):

𝑆(𝑡) = 𝑀0 sin𝛼
1− exp

(︁
− TR

𝑇1(𝑡)

)︁
1− cos𝛼 exp

(︁
− TR

𝑇1(𝑡)

)︁ (33.3)

At high Gd concentrations, the assumption of TE<<T2* may no longer be valid. However, correcting for
T2* has its own challenges.

The concentration C(t) may be obtained by solving Eq. (33.3) for 1/T1(t) and plugging it into Eq. (33.1).
The expressions for C(t) and T1(t) are available in several forms, with slight differences in notation.

𝑆rel ≡
𝑆 (𝑡)

𝑆0

𝐸10 ≡ exp

(︂
−TR

𝑇10

)︂
𝐵 ≡ 1− 𝐸10

1− cos𝛼𝐸10

1

𝑇1(𝑡)
=

1

TR
ln

(︂
1− BSrel cos𝛼

1−𝐵𝑆rel

)︂
(33.4)

𝐶(𝑡) =
1

𝑟1TR

[︂
ln

(︂
1− BSrel cos𝛼

1−𝐵𝑆rel

)︂
− TR

𝑇10

]︂
(33.5)

33.3.7 Linear approximation at low concentration

At low contrast concentrations (i.e., when the contrast does not alter the spin density and T2* effects are
negligible), the signal in Eq. (33.3) (at 𝛼 → 90∘ and TR/T1<<1) is approximately linear with 1/T1 (Buckley
& Parker in DCE MRI in Oncology 2005):

𝑆 (𝑡) ≈ 𝑀0
TR

𝑇1
(33.6)

Then the concentration from Eq. (33.6) is approximately linearly related to the signal enhancement (Wake
2018 PMID: 29777820):

𝐶(𝑡) =
1

𝑟1𝑇1(0)

(︂
𝑇1(0)

𝑇1(𝑡)
− 1

)︂
≈ 1

𝑟1𝑇1(0)

(︂
𝑆(𝑡)

𝑆0
− 1

)︂
(33.7)

This approximation may be appropriate at low concentrations. However, it may not be optimal for converting
the signal of blood in dynamic contrast-enhanced MRI with bolus injections of contrast, especially during
the first-pass peak.
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MRI Signal to Concentration

� Concentration Conversion Dialog

– Method

– Signal Baseline

– Acquisition parameters

– Water Exchange

– Contrast Agent Relaxivity

– HCT (Hematocrit)

– Completing the conversion

The quantification of contrast concentration is often required in contrast-enhanced MRI and CT.

See Conversion of MRI signal to contrast concentration (under Basics of DCE MRI ) for a description of
common conversion methods used in MRI.

The signal-to-concentration conversion can be performed Concentration Conversion dialog, available
under the Dynamic Analysis tab and through other commands (Fig. 34.1).

The Conversion dialog can be accessed via the following routes:

1. Dynamic Analysis > Convert TAC to Concentration.

This option is available with and without images loaded into FireVoxel. The command launches browse-
for-file dialog to select a the input text file, in which the first two columns contain (1) time and (2) signal
intensity values. Once a compatible file has been selected, the signal values versus time are displayed in a
new panel (Signal values, Fig. 34.2). The user can inspect the signal curve and set up the conversion using
the buttons at the bottom of this panel.

Attributes – Opens dialog for entering the precontrast T of tissue of interest (in seconds) (see Attributes
dialog Fig. 34.2).
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Fig. 34.1: Concentration Conversion dialog in its default state.
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Concentration – Opens Concentration Conversion dialog.

Fig. 34.2: Concentration Conversion panel in its default state.

2. Calculate Parametric Map > Concentration (for AIF) or Tissue Concentration (for tissue). This
option is available when the 4D dataset is recognized as a dynamic contrast-enhanced MRI time series and
the model requires signal-to-concentration conversion (such as the Tofts model). Clicking the Concentration
buttons opens the Concentration Conversion dialog for blood and tissue, respectively. See Dynamic
Analysis and DCE MRI Model Analysis.

3. Cardiac Output Measurement and Correction > Concentration. This command opens a dialog
panel enables the user to load and display signal intensity data and convert it to concentration by clicking
Concentration button, which opens Concentration Conversion dialog.

34.1 Concentration Conversion Dialog

The dialog contains the options to configure the conversion the CT and MRI signal values.

34.1.1 Method

A dropdown menu with a selection of conversion scenarios (Fig. 34.3). The first entry (Signal values,
default, no conversion) applies to both CT and MRI. The second method (CT basic) is for converting CT
data, and the subsequent methods are for MRI data.

� Signal values – Default – No conversion, retains original signal intensity values.

� CT basic S(t)–S(0) – Returns CT HU level corrected for baseline S(0). The baseline can be deter-
mined automatically or manually (see Signal Baseline).
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Fig. 34.3: Conversion methods in Concentration Conversion panel.

� Basic T1-weighted: S(t)/S(0)–1 – Returns signal enhancement for T1-weighted MRI. The method
assumes linear relationship between signal enhancement and contrast concentration. The effect of tissue
precontrast T10 is ignored.

� Basic T2-weighted: –ln(S(t)/S(0))/TE – Returns R2 values from T2-weighted MRI, with signal
given by: S(t)=S(0)*exp(-TE/T2), where TE is the echo time (see Acquisition).

� Fast Transcytolemmal Water Exchange – UNDER DEVELOPMENT. Returns contrast concen-
tration (in mmol/L) for T1-weighted MRI signal. The conversion is done using the shutter speed water
exchange model for TE<<T2* in fast exchange regime (FXR) (see Water Exchange).

� Fast Transcytolemmal Water Exchange with T2* effect – UNDER DEVELOPMENT. Returns
contrast concentration (in mmol/L) for T1-weighted MRI signal with the shutter speed model in FXR
regime with accounting for T2* effect. REQUIRES TE?

� Two Site Water Exchange – Returns contrast concentration (in mmol/L) for T1-weighted MRI
signal with the shutter speed model in two-site exchange (2SX) regime for water molecules exchanging
between intracellular and extracellular compartments.

� SPGR LC: (S(t)/S(0)–1)/r1/T10 – Returns contrast concentration (in mmol/L) for T1-weighted
MRI signal in fast exchange limit. The conversion is done with linearized Spoiled Gradient Recalled
Echo (SPGR) signal expression (linear conversion, LC) (See Eq. (33.7)). Requires pre-contrast tissue
T10 (see Attributes) and relaxivity of contrast agent r1 to be selected in Contrast.

� SPGR NLC: (1/T(t)–1/T10)/r1 – Returns contrast concentration (in mmol/L) for T1-weighted
MRI computed using SPGR signal equation (nonlinear signal-to-concentration conversion, NLC) (See
Eq. (33.5)). Requires pre-contrast tissue T10 entered in Attributes.

34.1.2 Signal Baseline

This part enables the user to control how the baseline (pre-contrast) signal S(0) is determined.

By default, the signal baseline is determined by averaging the data points from the first data point to the
contrast arrival time. ADD DETAILS: HOW IS THE CONTRAST ARRIVAL TIME DETERMINED?

Alternatively, the user may select the baseline to be determined manually (e.g., when the first data points
are problematic).

Manual – Checkbox which, if checked, allows the user to specify the baseline points manually using the
following options:
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Skip first [X] timepoints – Text box to enter the number of time points Nskip to be excluded from baseline
computation: timepoints 1, 2. . . , Nskip will be ignored.

Average next [X] timepoints – Text box to enter the number of timepoints Navg, to be used as the
baseline: signal at timepoints Nskip+1, Nskip+2,. . . , Nskip+ Navg will be averaged to determine the baseline.

34.1.3 Acquisition parameters

Here the sequence parameters – repetition time (TR, seconds), echo time (TE, seconds), and flip angle (FA,
degrees) - required for the conversion can be entered manually into the corresponding text boxes.

Only parameters required by the selected conversion Method can be entered; the unused parameter(s) are
grayed out and cannot be changed (Fig. 34.4).

The sequence parameters may be loaded directly from the DICOM header when the user clicks from DI-
COM button. This option is available only when DICOM images are open in the active document window,
and the conversion is performed for the ROIs in the same window. This is the case, for example, when
the Concentration Conversion panel is accessed from Calculate Parametric Map, when the active
document window contains DICOM images as well as the IDIF ROI and the tissue ROI, which are used to
compute the model parameters.

34.1.4 Water Exchange

This part specifies the parameters of the conversion using the shutter speed water exchange model (see
Yankeelov et al. 2003. PMID:14648563, Landis et al. 2000. PMID:11025512, and critical discussion in
Buckley 2019. PMID:30230007).

Tissue Water Fraction (fw) – Tissue volume fraction accessible to mobile water solutes f_w (unitless;
default, 0.8).

Mean intracellular lifetime (sec) – Mean lifetime of a water molecule in intracellular compartment, 𝜏𝑖
(in seconds; default, 1.1 s).

Intracellular relaxation rate without exchange (1/sec) – Intracellular rate constant without exchange,
denoted 𝑅1𝑖 (in inverse seconds; default, 0.69).

34.1.5 Contrast Agent Relaxivity

Text box labeled CR relaxivity r1 (1/(mM x s)) is for entering contrast agent relaxivity value r1 (Fig.
34.4).

Lookup Value - Opens a sub-panel that allows the user to select literature values of r1 relaxivity for
six currently approved contrast agents: Magnevist, Omniscan, MultiHance, Gadavist, ProHance, and
Dotarem\Clariscan (Fig. 34.5).

The appropriate r1 value can be obtained using three drop-down menus to choose: 1) contrast agent, 2) field
strength (1.5 T, 3 T, 7 T), and 3) medium (human blood, human plasma, bovine blood, bovine plasma,
canine blood, canine plasma) matching the user’s experimental conditions.
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Fig. 34.4: Concentration Conversion panel set up for nonlinear conversion with a manual baseline, TR=2.84
ms, FA=12 deg.

Fig. 34.5: Lookup Value panel for selecting contrast agent relaxivity value from literature for the experimental
conditions (contrast, field strength, and medium).
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Literature values of relaxivity r1 (1/(mM s))

Study Field,
T

Medium Protein,
g/dL

Mag-
nevist

Om-
niscan

Multi-
Hance

Ga-
davist

Pro-
Hance

Dotarem/Clariscan

Rohrer 2005 1.5 Bovine
plasma

7.0-9.0 4.1
(0.2)

4.3
(0.3)

6.3
(0.3)

5.2
(0.3)

4.1
(0.2)

3.6 (0.2)

Rohrer 2005 1.5 Canine
blood

ND 4.3
(0.3)

4.6
(0.3)

6.7
(0.4)

5.3
(0.3)

4.4
(0.3)

4.2 (0.3)

Szomolanyi
2019

1.5 Human
plasma

7.35 4.78
(0.12)

3.8
(0.1)

3.32 (0.13)

Pintaske 2006 1.5 Human
plasma

7.8 3.9
(0.2)

7.9
(0.4)

4.7
(0.2)

Shen 2015 1.5 Human
blood

6.5 4.25
(0.32)

4.47
(0.08)

6.2
(0.36)

4.61
(0.18)

4.39
(0.47)

3.91 (0.13)

Rohrer 2005 3 Bovine
plasma

7.0-9.0 3.7
(0.2)

4.0
(0.2)

5.5
(0.3)

5.0
(0.3)

3.7
(0.2)

3.5 (0.2)

Noebauer-
Huhmann 2010

3 Human
plasma

4.59 3.5
(0.08)

3.6
(0.22)

5.1
(0.54)

4.9
(0.15)

3.5
(0.08)

3.3 (0.24)

Pintaske 2006 3 Human
plasma

7.8 3.9
(0.2)

5.9
(0.4)

4.5
(0.2)

Szomolanyi
2019

3 Human
plasma

7.35 4.97
(0.59)

3.28
(0.09)

3.0 (0.13)

Szomolanyi
2019

3 Human
blood

ND 3.47
(0.16)

2.61
(0.16)

2.72 (0.17)

Shen 2015 3 Human
blood

6.5 3.76
(0.17)

3.89
(0.15)

5.37
(0.33)

4.46
(0.24)

3.46
(0.46)

3.43 (0.29)

Noebauer-
Huhmann 2010

7 Human
plasma

4.59 3.3
(0.13)

3.5
(0.18)

4.3
(0.38)

4.7
(0.13)

3.3
(0.13)

3.2 (0.17)

Szomolanyi
2019

7 Human
plasma

7.35 3.83
(0.24)

3.21
(0.07)

2.84 (0.09)

Shen 2015 7 Human
blood

6.3 3.11
(0.36)

3.72
(0.19)

4.67
(0.09)

4.2
(0.24)

3.35
(0.12)

2.82 (0.4)

Sources:

Rohrer 2005 PMID: 16230904
Pintaske 2006 PMID: 16481903
Noebauer-Huhmann 2010 PMID: 20697225
Shen 2015 PMID: 25658049
Szomolanyi 2019 PMID: 31124800

Notes:

34.1. Concentration Conversion Dialog 254

https://pubmed.ncbi.nlm.nih.gov/16230904/
https://pubmed.ncbi.nlm.nih.gov/16481903/
https://pubmed.ncbi.nlm.nih.gov/20697225/
https://pubmed.ncbi.nlm.nih.gov/25658049/
https://pubmed.ncbi.nlm.nih.gov/31124800/


FireVoxel: User Manual, Draft 2025-04-29

� All measurements were performed at 37C.

� Relaxivity data are mean (st dev).

� Protein, g/dL - Total protein.

� In Noebauer-Huhmann 2010, st dev was calculated from data at different concentrations in Tables 2
and 3 therein (following Szomolanyi 2019).

34.1.6 HCT (Hematocrit)

Text box for entering the value of hematocrit (HCT). This is done to determine the concentration of contrast
in plasma instead of the whole blood by excluding the volume occupied by the blood cells: Cplasma =
Cwhole_blood / (1 – HCT). By default, HCT=0 (no correction).

34.1.7 Completing the conversion

The user clicks OK on the Concentration Conversion panel.

The result is displayed as a plot of concentration (in mM) versus time, if the command was accessed through
Convert TAC to Concentration or Cardiac Output Measurement and Correction.

The user can save the concentration as a text file by clicking Save (or Save Original). The output file
contains two columns: time (as in the input data file) and concentration (in mM).

If the conversion was called via the Calculate Parametric Map dialog, the concentration is not displayed.
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Chapter 35

DCE MRI Model Analysis

� Compartmental modeling

� Tofts model

� Step-by-step DCE MRI analysis

35.1 Compartmental modeling

DCE MRI analysis is required to relate measured data to the parameters of the tissue or organ of interest.
These parameters have been increasingly used in individualized medicine for disease diagnostics, treatment
planning, and predicting and monitoring response to treatment.

Compartmental modeling provides fully quantitative physiological parameters. Compartmental models rep-
resent tissues and organs as combinations of uniform, instantly mixed compartments. Models usually require
a vascular input function (IF) driving the system. The input function is usually the concentration of contrast
in a vessel feeding the tissue of interest. Some models require more than one IF, such as the liver models,
which may have two IFs, arterial and portal venous, reflecting the hepatic blood supply.

In FireVoxel, several compartmental models are available under Dynamic Analysis > Calculate Para-
metric Map for the analysis of compatible DCE MRI data.

The following describes two-compartment Tofts models (regular and extended), widely used for analyzing
DCE MRI in cancer and other diseases:

Model 8: Tofts two-compartment exchange model {k-trans, Ve} : 1IF (single input function);

Model 9: Modified Tofts two-compartment exchange model {k-trans, Ve, Va} : 1IF.

256



FireVoxel: User Manual, Draft 2025-04-29

35.2 Tofts model

The two-compartment tracer kinetic models describe the scenario, in which intravenously injected contrast
agent enters the bloodstream, and (in body tissues) distributes throughout the vasculature and the EES,
with bidirectional exchange between the vascular compartment and the EES compartment across the vessel
walls (Fig. 35.1).

The extended Tofts model [Tofts1999] predicts the contrast concentration as a function of time in the
tissue of interest 𝐶𝑡(𝑡) fed by a blood vessel with the plasma concentration 𝐶𝑝(𝑡):

𝐶𝑡(𝑡) = 𝑣𝑝𝐶𝑝(𝑡) +𝐾trans

∫︁ 𝑡

0
𝐶𝑝(𝜏) exp(−𝑘ep(𝑡− 𝜏))𝑑𝜏 (35.1)

The concentration in the vascular compartment is considered to be the same as the concentration in the
feeding vessel, which serves as the arterial input function (AIF). The model parameters include the vascular
volume fraction 𝑣𝑝 (unitless), the volume transfer constant 𝐾trans (measured in mL/min/mL, i.e., mL/min
per mL of tissue) and the rate constant 𝑘ep = 𝐾trans/𝑣𝑒 (1/min), where 𝑣𝑒 (unitless) is the fractional EES
volume.

The regular Tofts model ignores the contribution of the vascular compartment, when the vascular volume
fraction is small (𝑣𝑝 ≪ 1), which may be an appropriate approximation for tissues that are not highly
vascularized:

𝐶𝑡(𝑡) = 𝐾trans

∫︁ 𝑡

0
𝐶𝑝(𝜏) exp(−𝑘ep(𝑡− 𝜏))𝑑𝜏 (35.2)

In the body, the volume transfer constant 𝐾trans typically reflects a combination of tissue perfusion (blood
flow, F in Fig. 35.1) and vessel wall permeability (leakiness). In contrast, in the brain with mostly intact
blood-brain barrier (BBB), where low molecular weight GBCAs mostly intravascular, 𝐾trans is mostly a
measure of vascular permeability, which is low in healthy brain and may be elevated in areas of injury or
tumors, where BBB may be disrupted. The rate constant 𝑘ep describes the rate of the contrast washout from
EES back into the vasculature.

The Tofts model parameters scale with the AIF and, as a result, are sensitive to the AIF errors. Special
care must be exercised to ensure robust measurements of the Tofts model parameters and their intrapatient
repeatability in longitudinal studies. Users are urged to consider the issues that may affect the reliability of
the AIF measurements in their experiments.
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35.3 Step-by-step DCE MRI analysis

DCE MRI analysis requires the following components:

� DCE MR images (4D dynamic dataset);

� Segmentation masks for tissues or organs of interest (optional);

� Input function (IF) saved as a text file;

� Precontrast blood T10 value - A fixed T1-value is required (see T10 of Blood);

� Precontrast tissue T10 value - Either a fixed value or a voxel-by-voxel T1-map. The T1-map may be
generated from a separate dataset, such as inversion recovery or multiple flip angle acquisitions;

� Modeling options - Model, output parameters, and modeling regime (voxel-based or average curve-
based).

The following sequence of steps may be executed to perform DCE MRI model analysis:

1. Open images. Open dynamic images into FireVoxel and Save them as a FireVoxel document. See
Loading DWI data for details of loading 4D datasets.

2. Segment the tissue or organ of interest. If model analysis is performed only for a tissue or organ
of interest, this tissue or organ need to be segmented. Segmentation can be performed manually, by drawing
an ROI (see Draw Raster ROIs) or using commands under the ROI menu (see ROI ), or via automatic
segmentation (such as Segmentation 3D (EdgeWave)). This step will create one or more ROI layers. Name
these layers clearly to make them easy to distinguish (see Layer Control for how to rename layers).

3. Determine the input function. The input function must be saved as a text file with at least two
columns of data: (1) time and (2) signal intensity or concentration (in mmol/L). The input function may be
derived using a variety of methods, including FireVoxel’s Image Derived Input Function.

4. Set the precontrast T10 value. The T10 is required to convert the MR signal to contrast concentration.
For blood, a fixed value T10 is assumed (see 5.2). For tissue, two scenarios are possible:

4.1 Single T10 value.
A single, fixed T10 value is set for each ROI layer, corresponding to the tissue or organ. In
this case, the tissue signal intensity data are fitted directly and the signal-to-concentration
conversion is combined with model analysis. To set T10 for an ROI, open Layer Control and
make this ROI layer active. Click Attributes in the lower right corner of the Layer Control).
This opens a dialog (Tissue attributes) to enter the T10 (in seconds). The default value
is fixed at T10 = 1 s. Click OK. Repeat these steps for each ROI layer for which the model
analysis will be performed.

4.2 Voxel-based T1-map.
The conversion of the 4D DCE MRI data can be performed voxel-by-voxel using a coreg-
istered voxel map of T10. In the current implementation (Build 368 and newer), the DCE
MRI data must be first converted to concentration and then subjected to model analysis.
The T1-map must be present in the same document as the DCE MRI data as a visible, real-
valued layer named T1-map. Since the T1-map is usually created in another document, see
Coregister with DICOM Tags and Copy layers for how to superimpose the T1-map with the
DCE MRI data. To convert DCE MRI data to concentration, select Dynamic Analysis
> Convert Volume to concentration > using T1-map. This opens the Concentration
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Conversion Dialog to select the conversion parameters. The concentration results are re-
turned as a new 4D dataset in an automatically created real-valued layer. This new layer is
named after the original data with the suffix indicating the conversion method.

5. Configure model analysis. Select Dynamic Analysis > Calculate Parametric Map. This opens
Parametric Map Calculation for Dynamic Experiment dialog, where the user can configure the model
analysis and select the model parameters.

5.1 Select the model.
Use theModel dropdown menu to select the compartmental model: Model 8 (regular Tofts
model), Model 9 (extended Tofts model), or another model.

5.2 Specify the input function (IF).
In the Input function section, click Load to browse for file and select the IF file (.txt).
Alternatively, use Paste to load the IF data from clipboard. Click View to preview the IF
curve. Note whether the IF is signal or concentration.

5.2.1 If the IF data are concentration (in mmol/L), make sure that the box next to the
Concentration button shows No conversion and proceed to step 6.

5.2.2 If the IF data are signal intensity, set up the conversion to concentration. Click
Attributes and enter the blood T10 (in seconds). Next, click Concentration to open the
Concentration Conversion dialog and enter the required parameters for blood/plasma.

6. Set up the tissue signal to concentration conversion. The signal to conversion is set using Tissue
concentration located in the left half of the Parametric Map dialog under the Hyperparameters section.
The settings depend on the tissue data:

6.1 Tissue data are concentration:
Make sure that the box next to Tissue concentration shows No conversion.

6.2 Tissue data are signal intensity:
Click Tissue concentration to open the Concentration Conversion Dialog and enter the
conversion parameters for the tissue of interest. Note: The correction for hematocrit is not
applicable in this case.

7. Set hyperparameters and select output parameters. Hyperparameters are fixed input parameters
of the model or parameter limits. Output parameters are the results that are returned as separate layers; at
least one output parameter must be selected. (see below Hyperparameters and outputs for Tofts model).

8. Set Optimization and Noise processing options. ADD DETAILS

9. Select the fitting option. These options include Process All (analyze entire image voxel by voxel),
Process ROI Only (analyze only ROI voxel by voxel), or Process ROI as a single curve (average ROI
signal and analyze the average curve). See Fitting options and Results for details.

10. Start analysis. When the user clicks on the fitting option, the next step is different for curve processing
or voxel fitting:

10.1 Process ROI as a single curve.
The analysis is performed right away and results returned in a dialog.

10.2 Process ROI only or Process All.
A confirmation dialog with the summary of model, inputs and options is shown giving the
user an additional control step before launching voxel fitting, which may be time consuming.
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Once the user clicks OK on this dialog, model analysis commences. The results are returned
as parameter maps, each in its separate layer.

35.3.1 Hyperparameters and outputs for Tofts model

Hyperparameters (the same set for Models 8 and 9):

� K-trans max (1/min) – Maximum allowed value of Ktrans.

� Ve max – Maximum value of EES fractional volume ve.

� Max arterial delay (sec) – Maximum time interval between the bolus arrival time and the tissue
concentration rise.

� Optimization depth – ADD DETAIL

� Use L1\L2 residual metric – Default, 2. The choice of L1 or L2 norm to compute the residual. L2
norm is the default for the output residual.

� Use balanced solution (0\1) – Default, 1. ADD DETAIL.

Output:

� Ktrans – Volume transfer constant Ktrans (1/min).

� Ve – EES volume fraction ve (unitless fraction).

� Va (only for Model 9 (extended Tofts model)) – Vascular volume fraction vp (unitless fraction).

� Arterial_delay – Time interval (in seconds) between the bolus arrival time and the tissue concentra-
tion rise.

� Residual – Goodness of fit measure, expressed as L1 or L2 norm, as selected underHyperparameters
(L2 by default).

References

Tofts PS, Brix G, Buckley DL, et al. Estimating kinetic parameters from dynamic contrast-enhanced T(1)-
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Fig. 35.1: Contrast
in tissue exchanges be-
tween vascular and EES
compartments.
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Chapter 36

Image-Derived Input Function

� Vascular Input Function

� FireVoxel’s IDIF Tool

� Derive IDIF

– Define Seed Vector ROI

– IDIF Dialog

– IDIF Tool Outputs

� IDIF Algorithm

36.1 Vascular Input Function

In dynamic imaging that involves administration of tracers or contrast agents, such as dynamic PET, dynamic
contrast-enhanced (DCE) MRI and DCE CT, serial images are acquired and analyzed to derive functional
information about organs and tissues. The analysis is often performed using compartmental models, which
require knowledge of the input functions driving the system. The input function (IF) is usually determined
as the time-activity curve (TAC), or contrast concentration curve, in a blood vessel feeding the organ or
tissue. The input function can be measured in a manually-drawn ROI or derived analytically by selecting
voxels based on the characteristics of their time-activity curves.
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36.2 FireVoxel’s IDIF Tool

FireVoxel offers a semi-automatic tool to determine the IDIF with minimal user interaction. The user must
first draw a vector ROI (seed) to initialize the process and then use Dynamic Analysis > Image Derived
Input Function to customize and run the IDIF tool. The resulting IDIF (signal versus time data) can be
saved as a text file or pasted into other applications.

The IDIF algorithm has two stages: 1) seeding and 2) vessel tracking (Fig. 36.1).

Fig. 36.1: Two stages of the IDIF algorithm.

In the seeding stage, the algorithm finds a location where the time-activity curve (signal versus time curve)
has the tallest peak within the user-defined seed region.

In the vessel tracking stage, this starting location and its reference curve are used to initialize the search
for nearby voxels with similar time-activity curves. The candidate curves are compared with the reference
curve. The locations where candidate curves are similar to the reference curve are added to the vessel tracking
region. The average time-activity curve of the tracking region serves as the IDIF.

For more detailed description, see IDIF Algorithm.
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36.3 Derive IDIF

This section describes the steps required to derive the IDIF.

36.3.1 Define Seed Vector ROI

The user first loads the dynamic images into FireVoxel using, for example, File > Open DICOM . In most
cases, FireVoxel will read the time points automatically from the DICOM image header.

The user then defines a vector ROI enclosing the blood vessel using Vector > Construct Vector ROI or the

toolbar icon. The position of the VROI can be adjusted in three dimensions using Display orthogonal
projections. The ROI does not need to conform to the vessel, but only delineate the area in which the vessel
is located (Fig. 36.2).

Fig. 36.2: Vector ROI (green square) on PET image (in 3 projections) to initialize the IDIF tool.

The user must keep in mind various confounding factors that may complicate the identification of the IDIF
voxels. For example, the presence of the veins within the seed ROI may distort the resulting arterial input
function.

36.3.2 IDIF Dialog

Use Dynamic Analysis > Image Derived Input Function to open the IDIF dialog (Fig. 36.3).

The panel consists of three parts.

The top part, labeled Curve similarity, contains parameters that control the comparison between the
candidate curves with the reference curve:

Peak time tolerance – Maximum time difference between the peaks of the candidate curve and the reference
curve. A candidate curve with a peak within this interval is considered further.
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Fig. 36.3: IDIF dialog in its default state.

Peak signal low threshold – Minimum peak height (as percent of the reference curve peak height) that
the candidate curve must have to be considered further. If the threshold is 80%, then candidate curves must
have peaks of at least 80% of the reference curve peak height.

Norm (L1=1, L2=2) – The user can select L1 or L2 norm to evaluate the difference between the candidate
curve and the reference curve.

The middle part, Vessel tracking, sets the parameters of the vessel tracking process (Fig. 36.4).

Bi-directional [tracking] – Checkbox that toggles between the entire tracking region or only its part being
used to derive the input function. The algorithm always tracks the vessel in both directions away from
the seed location. If Bi-directional option is checked, both arms of the tracking region are included. If
Bi-directional option is unchecked, only the longer arm of the tracking region is retained.

Adaptive – Checkbox that toggles between adaptive and regular modes. In Adaptive, the reference curve is
equal to the average curve over the tracking region and is updated on every tracking step. In Regular mode,
the reference curve is equal to the seed curve and is constant throughout the tracking process.

Minimum and Maximum diameters (mm) – Set the limits for the diameters (Dmin, Dmax) of the
candidate spheres at every tracking step to account for possible variation of the vessel width over the tracking
region.

Maximum length (mm) – Sets the maximum length Lmax of each arm of the tracking region.

Maximum turn (deg) – Angle (in degrees) that limits the angle by which the direction of the tracking
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region can change from one tracking step to the next. This ensures that the tracking region follows a smooth
course along the vessel.

The lower part of the panel, labeled Output, contains the parameters controlling the results.

Higher signal voxels – Dropdown menu to select a percentage of voxels, or a volume in cubic millimeters,
that will be used to derive the input function.

Tracking map – Checkbox to create a new layer with an integer-valued color map of the tracking region
showing its growth at each step. This map will be created in addition to the tracking region mask and may
be helpful in understanding the tracking process and adjusting its parameters.

36.3.3 IDIF Tool Outputs

The IDIF tool outputs include 1) IDIF ROI and 2) tracking map (if Tracking map box was checked in
IDIF dialog). The IDIF ROI and tracking map cover the same voxel locations, but the ROI is a binary mask
and the tracking map is an integer-valued image shown as colormap.

The IDIF ROI is returned in an automatically created layer labeled IDIF. The average signal over the IDIF
ROI will be displayed in the ROI Stats 4D panel opened automatically (Fig. 36.5). This curve can be saved
as a text file or copied to clipboard using Save and Copy to clipboard commands, respectively, in the
lower right corner of the panel.

Fig. 36.5: IDIF is automatically displayed in ROI Stats 4D panel.

The tracking map is placed in a layer labeled tracking info. By default, the tracking map is displayed in
the Rainbow color map, with the seed sphere shown in black and other colors indicating areas added at
each tracking step (Fig. 36.6). The IDIF ROI and tracking map layers are best saved within the FireVoxel
document, but can also be saved separately (see File > Save Active Layer as Image or Layer Control >
Save Image).
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Fig. 36.6: IDIF tracking map in abdominal aorta shows 7 tracking steps.

36.4 IDIF Algorithm

Prior to using the IDIF tool, the user defines a rectangular seed (vector ROI) enclosing the vessel. The user
then selects Dynamic Analysis > Image Derived Input Function to launch the IDIF tool.

The IDIF algorithm works in two stages: 1) seeding and 2) vessel tracking.

1. Seeding (Fig. 36.7). The algorithm considers all 3D spheres with centers inside the seed region and with
diameters within a user-specified interval. For each sphere, the average time-activity curve is constructed by
averaging all voxel curves within the sphere. The sphere with the tallest peak is selected, and its location
and time-activity curve are used as the seed to initialize the next step.

2. Vessel tracking (Fig. 36.8). First, a three-dimensional tracking region is initialized with the seed sphere
as the starting location. The reference time-activity curve is set equal to the seed curve.

The algorithm has two modes, regular and adaptive. In regular mode, the reference curve remains equal
to the seed curve throughout vessel tracking. In adaptive mode, the reference curve is set equal to the
average curve over the tracking region and is updated on every iteration.

Next, vessel tracking begins iterations. At each step, the algorithm considers all spheres adjacent to the
current tracking region and selects the sphere with the time-activity curve most similar to the reference
curve based on the following three criteria:
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Fig. 36.7: IDIF algorithm stage 1: Seeding.

Fig. 36.8: IDIF algorithm stage 2: Vessel tracking.
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1) The peak height of the candidate curve must exceed the user-specified threshold percentage of the
reference curve peak.

2) The peak time of the candidate curve must be within the time tolerance interval of the reference
curve peak time.

3) If the first two conditions are met, the candidate curve must yield the smallest difference between itself
and the reference curve (expressed as the L-norm).

The sphere that satisfies these three conditions is then added to the tracking region. In adaptive mode, the
reference curve is updated to the average curve of the newly expanded tracking region.

This sequence is repeated until the user-defined vessel length is reached or tracking fails. After vessel tracking
is finished, the image-derived input function is determined as the average time-activity curve over the filled
voxels in the tracking region.

Fig. 36.4: Vessel tracking
parameters.
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Chapter 37

Cardiac Output Measurement and
Correction

� Cardiac Output Measurement and Correction Tool

� CO-Based Correction Basics

� CO-Based Correction Algorithm

� CO-Based Correction Dialog

37.1 Cardiac Output Measurement and Correction Tool

TheCardiac Output Measurement and Correction tool (under theDynamic Analysis group) enables
constrained signal-to-concentration conversion based on the subject’s cardiac output (CO). This operation
limits the errors in the contrast concentration in the blood, which is often required in DCE MRI model
analysis, but is challenging to measure accurately.

The MRI signal in the blood may be affected by multiple issues, such as the inflow artifact, limited temporal
resolution, partial volume effects, and image inhomogeneity, among others.

In compartmental model analysis of DCE MRI data, the errors in the arterial input function (AIF) are the
main source of errors in model parameters. For example, the Tofts-Kety model (Tofts 1999 PMID: 10508281)
parameters Ktrans and ve scale nearly proportionally with the AIF, and the AIF errors propagate into the
parameters errors in a similar way.

The inflow artifact arises when unsaturated spins (which have not seen the excitation pulse) in flowing blood
move into the imaging slab and result in artificially high signal intensity of blood (higher than in a stationary
tissue with the same T10 value as blood). The inflow artifact may cause up to 100% errors in Ktrans along
the length of the vessel when a fixed T10 value is used to convert the blood to concentration.

The CO-based correction tool limits the errors that arise from the inaccurate baseline signal in blood.
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37.2 CO-Based Correction Basics

The constrained conversion method is a post-correction method that constrains the are under the first pass
of the arterial concentration based on the Stewart-Hamilton principle.

The Stewart-Hamilton principle relates the injected dose of contrast (in mmol), the subject’s cardiac output
(CO, L/min), and the area under the curve (AUC, mmol/L x min) of the first pass peak of the arterial curve:.

AUC =
Dose

CO
. (37.1)

This equation constrains the magnitude of the first pass peak of the blood concentration for a known contrast
dose and CO. If the blood concentration fails to satisfy Eq. (37.1), the baseline of the corresponding blood
signal can be altered so that .

In its initial implementation, this method was shown to reduce the variations of the AIF variations and
kidney parameters in repeated measurements in the same patients (Zhang 2009 PMID: 19711414).

The CO-based correction makes several assumptions:

� The arterial signal S(t) consists of the bolus curve Sb(t) shifted by an additive baseline S0;

� The errors in the arterial concentration are caused by (i) incorrect baseline OR (ii) by incorrect flip
angle;

� These errors are reduced by replacing the original baseline S0 with the corrected baseline signal S0c,
for which the AUC of the first peak satisfies the Stewart-Hamilton principle (Eq. (37.1)).

� The corrected signal is obtained by shifting the bolus curve to the corrected baseline: Sc(t) = S0c +
Sb(t). (Alternatively, only the baseline signal can be adjusted OR the flip angle can be corrected.)

� After Sc(t) is converted to concentration, it yields the corrected blood curve Cc(t).

37.3 CO-Based Correction Algorithm

The algorithm takes the blood signal S(t) as the input, for which the bolus arrival time (BAT), the baseline
signal S0, the recirculation time (RCT) are determined. RCT is the time point after the first pass peak and
before the start of the recirculation peak.

Next, the baseline is iteratively shifted in increments within the range: Sk(t) = Sb(t) + ∆ x k, where k =
[-N, N] and ∆ = S0/2N by default.

At each iteration, the signal Sk(t) is converted to concentration Ck(t). The first pass peak (defined as the
part of Ck(t) between BAT and RCT) is fitted with gamma variate function and the AUCk under the first
pass is determined.

This AUCk and the injected contrast dose (in millimoles) are used to estimate cardiac output COk based on
Stewart-Hamilton principle (Eq. (37.1)).
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Fig. 37.1: CO-based correction algorithm diagram.

After all iterations are completed, the curve Ck(t) that minimizes the difference between the estimated COk

and the actual CO value provided by the user. This concentration is returned as the corrected concentration
Cc(t).

37.3.1 CO Estimates

The CO required for the constrained conversion can be measured by several different methods, which include
noninvasive (Doppler ultrasound, echocardiography, cardiac MRI, modified carbon dioxide Fick method),
and invasive (oxygen Fick method, lithium dilution) (see Physiology, Cardiac Index). The agreement among
the measurements made by these methods is modest (Maeder 2015 PMID: 25728504).

Alternatively, the CO (in L/min) may be estimated as

CO = CI× BSA, (37.2)

where CI (L/min/m2) is the cardiac index and BSA (m2) is the body surface area.

For practical purposes, the cardiac index may be assumed to be constant in relatively healthy subjects.
Studies have shown that CI at rest in subjects without severe heart disease does not significantly vary with
age, sex, body mass index, overweight, and fitness (Wolsk 2017 PMID: 28017352). A small decrease of CI
with age was observed in some studies, but it was not found in all studies (Cioccari 2019 PMID: 30857507).
The CI during exercise does vary with age and it is decreased in patients with heart disease (Carlsson 2012
PMID: 22839436).

BSA can be calculated using one of several BSA formulas using the subject’s weight and height, such as the
classic Du Bois formula (Du Bois 1916 PMID: 2520314):
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BSA = 0.007184×W0.425 ×H0.725, (37.3)

where W is the subject’s weight in kilograms, and H is the height in centimeters.

37.4 CO-Based Correction Dialog

The constrained conversion is accessed by selecting Dynamic Analysis > CO Measurement and Cor-
rection, which is accessible both with and without images. This command opens a dialog panel that enables
the user to select parameters for this operation and view the results. The top part of the panel shows the
plot of the signal or concentration data. The bottom part has the controls for setting up the methods. The
routine consists of two steps:

1. CO Measurement. The CO is estimated from the concentration curve obtained using regular signal-
to-concentration conversion,

2. Concentration Correction. Corrected concentration is computed using the CO-based constrained
conversion with the actual (measured or estimated) CO value entered by the user.

These steps are described in detail below.

1. CO Measurement.

� Click Load to load the blood signal or concentration curve. This curve must be previously saved as a
text file with two columns: (1) time and (2) signal (or concentration). Any additional columns will be
ignored.

� If the loaded curve is concentration versus time (e.g., previously converted using Dynamic Analysis
> Concentration Conversion), then no further processing is required. Make sure that the box next
to the Conversion button reads No Conversion and proceed to the next step.

� If the loaded curve is signal versus time (Fig. 37.2), configure the signal-to-concentration conversion.
Click Attributes to enter the T10 for blood in seconds (default T10 = 1.4 s). Next, click Concen-
tration to open the Concentration Conversion dialog. Use this dialog to set the conversion method,
baseline definition, and parameters (TR, FA, contrast agent relaxivity). Click OK.

� The concentration curve will be displayed in the plot area (FIG?) along with the first pass and gamma
variate fit. The visibility of these curves can be turned on and off using check boxes below the plot.
The curve colors can be changed by clicking the color swatches, which open color picker palettes.

� Determine the recirculation time (RCT). By default, RCT is determined automatically upon loading
data and also when the user clicks Recirculation start button. Alternatively, the user may set the
RCT manually by clicking the plot area at the start of the recirculation peak.

� Enter the contrast Dose in millimoles (NOT milliliters).

� The parameters Gamma variate precision (default 50) and Cardiac output precision (default
500) 8i ø set the precision (stopping criteria) for the iterative process. Lower precision values will result
in faster processing, but less reliable estimate.
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Fig. 37.2: CO Correction dialog with signal data just loaded. The green line indicates RCT.

� Click Estimate CO to compute the CO corresponding to the uncorrected data. This command will
populate the corresponding text box with the CO (L/min). This estimated CO value may be outside
of the normal physiological range if the blood signal is distorted by artifacts.

2. Concentration Correction.

� To obtain the corrected concentration, enter the subject’s CO value (in L/min), measured or estimated)
into the text box labeled Actual CO in the section labeled Input Function correction.

� Select the correction Method from the dropdown menu: (i) Shift whole curve vertically, (ii) Shift
pre-contrast points vertically, (iii) Adjust flip angle.

� Next, click Correct. This will begin the iterative process. After processing is finished, the corrected
curve will be displayed in the plot area (Fig. 37.3).

� To save the uncorrected curve (the curve obtained using regular conversion), click Save original. The
uncorrected concentration will be saved as a text file. To save the corrected curve as a text file, click
Save corrected. By default, these files are saved in the Temp folder inside the FireVoxel directory.
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Fig. 37.3: CO-based correction dialog showing corrected concentration (yellow) and original concentration
(blue). Estimated CO=11.75 L/min. Actual CO = 4.79 L/min.
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Chapter 38

White Matter Lesion Segmentation on
FLAIR MRI

� WML Segmentation Overview

� WML Segmentation Input Data

� Processing a Single FLAIR Series

� WML Segmentation Dialog

� WML Segmentation Output

� Batch Mode Processing of Multiple FLAIR Series

38.1 WML Segmentation Overview

White matter hyperintensities in the brain and spinal cord are regions of high signal relative to healthy white
matter (WM) on T2-weighted fluid attenuated inversion recovery (FLAIR) MRI (see T2-FLAIR at MRI
Questions and Radiopaedia). These white matter lesions (WML) are often found in patients with multiple
sclerosis and are also commonly seen in older individuals (White Matter Lesions - NIH Bookshelf). Detecting
WML and measuring their size and location helps to assess the extent of WM disease (Fig. 38.1).

FireVoxel offers automatic workflows for WML segmentation on FLAIR MRI for individual series and batch
mode processing for multiple series.

The WML and ventricle segmentation masks may be used for classification of WML as periventricular and
deep lesions. It has been shown that periventricular lesions are more strongly associated with cognitive
decline, and therefore knowing the location of WML in relation to the ventricles may help to characterize
the subject’s neurological status. Currently, the WML classification may be done with the help of the
3D “bilateral distance” method (Chen 2021 PMID: 33127308), available as open-source software (GitHub:
WMHS). The implementation of this method in FireVoxel is under development.
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Fig. 38.1: WML manually segmented (yellow ROI) on axial FLAIR image.

The WML segmentation workflow includes the following steps:

1. Nonuniformity correction (optional).

2. Whole-brain segmentation using EdgeWave.

3. Lateral ventricle segmentation (with multi-pass EdgeWave and advanced morphology operators).

4. White matter segmentation – WM is segmented by excluding gray matter (GM) from the whole-brain
mask. GM segmentation can be done by

a. using a previously created GM mask, or

b. loading the subject’s T1-weighted magnetization-prepared rapid gradient echo (MPRAGE) image
and using it to automatically segment GM, or

c. specifying the width of a uniform region to be excluded from the outer edge of the whole-brain
mask (using Peel command).

5. “Healthy” WM sampling – The signal is sampled in uniform, lesion-free WM to determine its mean and
standard deviation (mean_WM and stdev_WM, respectively). Healthy WM signal may be sampled
using one of two available methods:

� Using a WM seed (default) – The signal is sampled within a WM seed, a small (1 mL) cubic
vector ROI automatically created in the most uniform area of WM.

� Using the whole WM – The whole WM is sampled. It is assumed that WML occupy a small
volume compared to the whole WM and do not distort the distribution of the WM signal.

6. Identifying WML candidates – WM voxels are marked as WML if their signal exceeds threshold_WML
= mean_WM+ k x stdev_WM, where k is a user-selected multiplier. This step results in a preliminary
WML segmentation.

7. Filtering WML based on size and location – Cortical lesions and lesions smaller than a user-specified
minimum size are removed from the preliminary segmentation. The final WML segmentation is created.

8. Returning segmentation results in new, automatically created layers.
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38.2 WML Segmentation Input Data

Segmentation of a single FLAIR series takes the following input data:

1. FLAIR MRI (required) – 3D FLAIR MR image (usually in DICOM format).

2. Gray matter segmentation mask (optional) – The GM mask (ROI layer) must be created before-
hand using FireVoxel or another software tool (such as FreeSurfer or SPM), coregistered with FLAIR
image, and placed as a layer into the same document as FLAIR MRI. This layer should be named gray
matter or GM (case insensitive).

3. MPRAGE MRI (optional) – T1-weighted 3D MPRAGE MR image (usually in DICOM or NIfTI
format). This MPRAGE image must be opened in a separate document window within the same
instance of FireVoxel as FLAIR. This is an alternative method to perform GM segmentation within
the same command as WML segmentation. If both MPRAGE and GM mask are present, GM mask is
used.

38.3 Processing a Single FLAIR Series

To segment one FLAIR series at a time, first, prepare input data. Open FLAIR image in FireVoxel and,
optionally, load GM mask into the same document window or open MPRAGE image in another document
window. Make sure that FLAIR image is the active layer.

Next, select Workflows > Brain MR > White Matter FLAIR Lesions. This will open WML dialog
described below. Enter the parameters, or accept defaults, and click OK. The command will run automatically
and return outputs described in WML Segmentation Output .

38.4 WML Segmentation Dialog

Both individual and batch commands use the same dialog: White Matter Lesions Segmentation
(FLAIR) Using Lateral Ventricle (Fig. 38.2).

The dialog panel contains blocks that closely match the workflow steps described in Overview :

� Nonuniformity correction

� Gray matter (GM) segmentation

� MPRAGE processing

� Brain mask EdgeWave

� Lateral ventricle

� Healthy White Matter signal meanstdev

� [WML selection by size and location]
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Fig. 38.2: White Matter Lesions Segmentation dialog with default parameters.

Nonuniformity correction – Parameter: DoN3 (default: 1/checked); – When checked, the N3 nonunifor-
mity correction is performed prior to WML segmentation. Using nonuniformity correction is recommended,
as it may considerably reduce the number of false positives, especially in deeper regions of the brain.

N3 Parameters (button) – Opens N3 dialog to configure the nonuniformity correction parameters.

Use provided Gray Matter mask – Parameter: UseProvidedGMmask (default: 0/unchecked) – Check
this box to use a previously created GM segmentation mask (see WML Input Data).

MPRAGE processing – This block is activated when MPRAGE image series is detected in another doc-
ument window. In this case, MPRAGE can be used to create a GM mask. When MPRAGE is present, the
name of the MPRAGE image series is displayed in the text box below the section title. The user must then
check the box labeled Use MPRAGE and configure coregistration of MPRAGE to FLAIR. If Nonunifor-
mity correction is checked, the correction is also applied to MPRAGE. If both MPRAGE and GM mask
are present (and Use provided Gray Matter mask is checked), the algorithm uses the GM mask and
ignores MPRAGE.

Use MPRAGE – Parameter: UseMprage (default: 0/unchecked) – This button becomes available if
MPRAGE is detected and when checked, MPRAGE image is coregistered with FLAIR and used to segment
GM. The GM mask is created using the bimodal Gauss histogram thresholding with mass ratio constraint
(Mikheev and Rusinek, ISMRM 2023, Abstract #3602). The parameters of MPRAGE/FLAIR coregistration
can be configured by clicking Registration Parameters (see next).

Registration Parameters (button) – Opens the image coregistration dialog (3D Registration with
AutoFocus). The dialog enables the user to set up the coregistration parameters of MPRAGE (source)
to FLAIR (target). If both image series were acquired during the same exam, the best option for the
initial transform is clicking Dicom Tags. This command creates a volume transform file DicomTags.vtf
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in FireVoxel’s Temp directory with the dimensions and resolution of the source (MPRAGE) and target
(FLAIR) images and the affine transform matrix computed based on the orientation and position DICOM
fields of these files (Fig. 38.3). This transformation is then used for the initial coregistration.

GM over FLAIR bright coeff threshold – Parameter: GMbrightThrKoff (default: 1.5) – Coefficient
setting the upper threshold GM signal relative to FLAIR signal. The brightest voxels on FLAIR are excluded
from the GM mask.

Fig. 38.3: A volume transform file for MPRAGE to FLAIR coregistration based on DICOM tags.

38.4.1 Brain mask EdgeWave

This block contains parameters of the whole brain segmentation of FLAIR image using EdgeWave (see Seg-
mentation with EdgeWave). A WM seed (WMS, a 1-mL cube) is automatically constructed. The EdgeWave
algorithm is applied with WMS.

Note: The whole-brain mask resulting from this step does not include CSF-filled spaces.

Signal low (relative to seed) – Parameter: BmCoreSiLo (default: 0.4) – Lower threshold for signal
intensity of the whole brain as a fraction of the mean WM signal.

Brain mask EdgeWave signal high (relative to seed) – Parameter: BmCoreSiHi (default: 1.5) – Upper
threshold of brain signal relative to the average WM signal.

Peel (mm) – Parameter: BmPeel (default: 2.9 mm) – Whole-brain Peel distance – The thickness of the
region to be removed by the Peel command.

Grow (mm) – Parameter: BmGrow (default: 6.4 mm) – Whole-brain Grow distance – The thickness of the
region to be added by the Grow command.

Brain stem cutoff threshold – Parameter: StemWeightThr (default: 0.05) – Signal threshold for excluding
the brainstem.
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38.4.2 Lateral ventricle

This block sets the parameters of the lateral ventricle segmentation.

Peel (mm) – Parameter: VentPeel (default: 2 mm) – Ventricle Peel distance – The width to be removed
by the Peel command during ventricle segmentation.

Grow (mm) – Parameter: VentGrow (default: 3 mm) – Ventricle Grow distance – The width to be added
by the Grow command during ventricle segmentation.

Max number CC – Parameter: VentMaxCC (default: 1) – Maximum number of connected components in
the ventricle mask.

Periventricular border (mm) – Parameter: VentInfl (default: 5 mm) – The width to be added around
the edge of the ventricle mask by Grow command to ensure that no GM is detected in this inflated mask.

38.4.3 Healthy White Matter signal mean\stdev

This block sets up the WM segmentation and the signal threshold used to identify WML.

Use WM seed (uncheck for using WM morphology) – Parameter: UseWMseedForNormalVox-
elsCheckbox (default: 0/unchecked) – When this box is checked, the signal mean and stdev within the
WM seed are used to determine the threshold for WML segmentation. The seed is then deleted, so the user
never sees it.

If the Use WM seed box is unchecked, the whole WM is used to determine signal mean and stdev. See
this Important Note on selecting the multiplier for thresholding when using WM seed or whole WM.

Peel Brain mask to obtain healthy WM voxels (mm) – Parameter: WMdeflateToNormal (default: 5
mm) – The thickness of the region between the outer edge of the brain mask and the edge of healthy WM
to be excluded from the whole brain mask by the Peel command.

WML threshold stdev multiplier – Parameter: WMLThresholdStddevMult (default: 2.0) – As described
in Overview , the algorithm looks for WML voxels with signal above threshold_WML = mean_WM +
multiplier x stdev_WM. Larger multiplier values result in fewer and smaller lesions being found.

Important Note: A higher value of the multiplier is needed when using the WM seed option compared to
the no-seed (whole WM) option to reduce the number of false positives, which may arise if the WM seed is
hypointense and uniform compared to the rest of WM.

38.4.4 WML selection by size and location

The last block sets the parameters to exclude those WML that are located in the cortex and those smaller
than a user-selected minimum volume.

Peel to exclude cortical lesions (mm) – Parameter: WMLzoneDeflate (default: 3 mm) – Thickness of
the area along the edge of the WM mask to be removed by the Peel command in order to exclude voxels
with high-intensity FLAIR signal located in the cortex and probably not lesions.

WML minimal size (mm^3) – Parameter: PepperThr (default: 12 mm^3) – Lower threshold for WML
size. In the final segmentation step, scattered WML voxels or clusters of voxels below this threshold are
removed from the WML mask.

38.4. WML Segmentation Dialog 281



FireVoxel: User Manual, Draft 2025-04-29

38.5 WML Segmentation Output

The command automatically creates several new layers (Fig. 38.4):

Fig. 38.4: FireVoxel’s WML segmentation performed using MPRAGE (axial and sagittal views; red - WML,
blue - GM, green - ventricle).

WML_thr_xxxx (ROI layer) – WML segmentation mask. The threshold signal is shown in the layer
name after “thr_”.

gray matter (ROI layer) – When MPRAGE is used, GM segmentation mask is created as one of the output
layers.

lateral ventricle (ROI layer) – Ventricle segmentation mask.

38.6 Batch Mode Processing of Multiple FLAIR Series

To segment WML on multiple FLAIR series in batch mode, use FireVoxel without any images open and select
Applications > White Matter Lesions (FLAIR-MPRAGE) batch measurement from DICOM.

Note: White Matter Lesions (FLAIR) batch measurement is a legacy command - do not use.

The batch command opens a dialog to select the source and target (input and output) directories (Fig. 38.5,
top). The source directory is expected to contain subfolders, each of which should contain a folder with 3D
FLAIR series in DICOM format (Fig. 38.5, bottom). The target directory is where the results are saved as
FireVoxel documents (*.fvx). If this directory is not empty, the user will see a warning that its contents will
be overwritten by the new results.

After selecting the directories, click OK.
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Fig. 38.5: WML batch mode dialog to select input and output folders (top) and expected folder structure
of input data (bottom). The source directory (batch_data_in) contains 3 folders (for subjects labeled b, d,
and e), each containing folders with FLAIR and MPRAGE series.

Next, the WML segmentation dialog will open to set up the segmentation parameters (see WML Dialog).
Select parameters and click OK to start processing. If MPRAGE images are to be used for GM segmentation,
click Use MPRAGE. If any of the input data folders contain no MPRAGE, segmentation will be performed
without using MPRAGE.

After processing is completed, the results will appear in the target directory, saved as FireVoxel documents,
with each subject’s results in its own document, containing FLAIR images, WML segmentation masks, and
GM masks (if MPRAGE was used) in different layers. The results log is written into a text file in FireVoxel’s
Temp directory (\FireVoxel\Temp\NotepadTempFile.txt). This file contains a list of processing parameters
followed by tab-delimited processing results (Fig. 38.6).

Note: It is highly recommended to move this file to another location and rename it. If the file remains in
FireVoxel’s Temp directory, it may be overwritten by the output from WML processing or other commands
that generate text files.

Fig. 38.6: WML batch mode results log saved as NotepadTempFile.txt in FireVoxel’s Temp directory.

Results log entries:

Parameters

� Number of cases processed
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� Total execution time (for the entire batch)

� DoN3 – Do N3 nonuniformity correction (yes/no = 1/0) (see Nonuniformity correction)

� UseMprage – Use MPRAGE (yes/no = 1/0) (Use MPRAGE )

� BMCoreSiLo – Brain mask core set signal low threshold (Signal low)

� BMCoreSiHi – Brain mask core set signal high threshold (Signal high)

� Peel – Whole brain mask peel distance (mm) (Whole brain Peel)

� Grow – Whole Brain mask grow distance (mm) (Whole brain Grow)

� StemWeightThr – Brain stem cutoff threshold <wml_wb_brainstem>

� VentPeel – Ventricle mask peel distance (mm) (Ventricle Peel)

� VentGrow – Ventricle mask grow distance (mm) (Ventricle Grow)

� VentMaxCC – Ventricle maximum number of connected components (Max number CC )

� VentInfl – Ventricle inflate (mm) (Periventricular border)

� UseWMSeedForNormVoxels – Use WM seed for normal voxels (Use WM seed)

� WmDeflateToNormal – Whole brain mask deflate to normal (mm) (Peel brain mask to obtain normal
WM )

� WMLThresholdStddevMult – WML threshold stdev multiplier

� WMLzoneDeflate – WML zone to deflate (mm) (Peel to exclude cortical lesions)

� GMbrightThrKoff – GM over FLAIR bright coeff threshold

Results

caseID – The name of the individual subject’s input data directory

Mprage used – Whether MPRAGE was found and successfully used

WML_volume(cm3) – WML total volume

WML_signal – Mean WML signal

WMLthr – WML threshold signal

WM_signal – Mean wealthy WM signal

time – Processing time for a given case

Status – Whether processing was completed normally
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Radiomics 2D Features

� Radiomics 2D Features Overview

� Computing Radiomics Features in FireVoxel

� Radiomics 2D Features Dialog

� Radiomics 2D Results

– First-order features (16 features)

– Gray Level Co-occurrence Matrix (GLCM) (23 features)

– Gray Level Run Length Matrix (GLRLM) (16 features)

39.1 Radiomics 2D Features Overview

Radiomics extracts multiple features from medical images using data-characterization algorithms. These
features may reveal patterns and properties of tissues and lesions that are not apparent to an observer’s eye.

39.2 Computing Radiomics Features in FireVoxel

FireVoxel offers automatic workflows for measuring the first- and second-order radiomics features with a
minimal user interaction. The workflows require an image (acquired or computed) and (optional) one or
more visible ROIs. If there are no visible ROIs, the analysis is performed using the entire image (which may
not be informative).

To use, open image in FireVoxel, create or load the ROI layer(s) and make sure they are visible. Select
Measure > Radiomics Features 2D - Active ROI or Radiomics Features 2D - All ROIs, depending
on the ROI(s) present. This will open the Radiomics Features 2D dialog described in detail in the next
section. Adjust the parameters and output options and click OK. The results will be returned to the clipboard
and/or to a text file (depending on user selections). Import or paste the results into a spreadsheet for further
analysis.
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39.3 Radiomics 2D Features Dialog

Both Active ROI and All ROIs workflows use the same dialog Radiomics Features 2D (Fig. 39.1).

Fig. 39.1: Radiomics 2D features dialog.

The dialog presents the following options:

� Discretization (over whole volume) [text window] – Displays parameters of the signal histogram
(Range [min, max], Bin width(real), Bins(int), Clip range(int)). Default: Undefined. Click Change to
the right from the text window to change these parameters. This opens ROI Stats 3D dialog, which
enables the user to change the histogram parameters. After the user clicks OK, this dialog closes, and
the histogram parameters appear in the Discretization box.

Important Note: It is important NOT to accept the default histogram values, which are image-
specific.

� Features – Checkboxes to select the main radiomics feature groups. Check to compute these features
and return them in the results file.

First order – First-order parameters of signal distribution, including Min, Max, Mean, Vari-
ance, Skewness, Kurtosis, Entropy and percentiles (1%, 5%, 10%, 25%, 50%, 75%, 90%,
99%).

Gray Level Co-occurrence Matrix (GLCM) – See detailed description below.

Gray Level Run Length Matrix (GLRLM) – See detailed description below.

� GLCM settings – Customize settings to compute GLCM.

Symmetric – Checkbox to select symmetric GLCM (default: checked, symmetric).

Distance list – Text box to enter an integer.

Averaging weights – Dropdown menu to select an option for averaging weights: No averaging,
Constant (default), Infinity norm, Euclidian norm, Manhattan norm.
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� Output – Output options for results.

Include header row – Include output parameter names in the first line of the results file.

To Clipboard – Copy results to clipboard. To paste results into another application (such as
Excel), press Ctrl + V. If Include header row is checked, the results contain a row of text
labels (parameter names) followed by numerical parameter values.

To tab-delimited file – Create a file (NotepadTempFile.txt in FireVoxel’s Temp directory)
with tab-delimited results. If Include header row is checked, the results file contains a row of
text labels (parameter names) followed by numerical parameter values.

39.4 Radiomics 2D Results

The following labels and parameters are included in the output results (in the same order as in the output
file):

Input Parameters and Labels

VolName – Volume name. The name of the image that is being analyzed.

ROIname – ROI name. The name of the ROI layer for which the analysis is performed.

GLCMsymm – User-selected option for GLCM symmetry, 1 (symmetric, default) or 0 (not
symmetric).

distance – User-selected distance list value.

39.4.1 First-order features (16 features)

First-order features describe the distribution of voxel intensities within ROI through the commonly used
metrics and moments.

1. Min – Minimum signal intensity.

2. Max – Maximum signal intensity.

3. Mean – Signal mean.

4. Variance – Signal variance (squared deviation from the mean).

5. Skewness – Skewness, a measure of asymmetry of signal distribution. Positive for right-tailed distri-
butions (right tail is longer); negative for left-tailed distributions (left tail is longer).

6. Kurtosis – Kurtosis, measure of “tailedness” of a distribution, expressed in relation to the Gaussian
distribution, which has zero kurtosis. Higher kurtosis corresponds to greater extremity of outliers
(tails). Kurtosis is positive for distributions with “fatter” tails than Gaussian distribution (e.g., Laplace
distribution). Kurtosis is negative for distributions with “thinner” tails than Gaussian distribution (e.g.,
uniform distribution).

7. Entropy – Entropy, the average level of “information” needed to encode the image values.
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8. 1%, 5%, 10%, 25%, 50%, 75%, 90%, 95%, 99% – Percentile intensity values. Maximum signal
values for each percentage of voxels. Example: If 75% percentile is 192, 75% of voxels have signal less
than or equal to 192.

39.4.2 Gray Level Co-occurrence Matrix (GLCM) (23 features)

GLCM describes the second-order joint probability function of an image within ROI. The element of this
matrix with indices (i,j) represents the frequency at which the combination of intensities i and j occur in two
voxels in the image, which are separated by a given distance D long a given angle. The distance D from the
center voxel is defined as the distance according to the infinity norm.

GLCM describes how often pairs of voxels with specific intensities and in a given spatial relationship occur
in an image. The GLCM features are the statistical measures of the GLCM matrix.

1. AuCor – Autocorrelation.

2. JointAvg – Joint Average.

3. ClstProm – Cluster Prominence.

4. ClstShade – Cluster Shade.

5. ClstTend – Cluster Tendency.

6. GLCMContr – GLCM Contrast.

7. GLCMCor – GLCM Correlation.

8. DiffAvg – Difference Average.

9. DiffEntr – Difference Entropy.

10. DiffVar – Difference Variance.

11. AngSecMom – Angular Second Moment.

12. JointEntr – Joint Entropy.

13. FirstMeasInfoCor – First Measure Information Correlation.

14. SecMeasInfoCor – Measure Information Correlation.

15. InvDiffMom – Inverse Difference Moment.

16. InvDiffMomNorm – Inverse Difference Moment Normalized.

17. InvDiff – Inverse Difference.

18. InvDiffNorm – Inverse Difference Normalized.

19. InvVar – Inverse Variance.

20. JointMax – Joint Maximum.

21. SumAvg – Sum Average.

22. SumEnt – Sum Entropy.

23. JointVar – Joint Variance.
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39.4.3 Gray Level Run Length Matrix (GLRLM) (16 features)

1. ShortRunEmph – Short Run Emphasis.

2. LongRunEmph – Long Run Emphasis.

3. GLNU – Gray Level Non-Uniformity.

4. GLNUnorm – Gray Level Non-Uniformity Normalized.

5. RunLenNU – Run Length Non-Uniformity.

6. RunLenNUnorm – Run Length Non-Uniformity Normalized.

7. RunPerc – Run Percentage.

8. GLVar – Gray Level Variance.

9. RunLenVar – Run Length Variance.

10. RunEntr – Run Entropy.

11. LowGLRunEmph – Low Gray Level Run Emphasis.

12. HighGLRunEmph – High Gray Level Run Emphasis.

13. ShortRunLowGLEmph – Short Run Low Gray Level Emphasis.

14. ShortRunHighGLEmph – Short Run High Gray Level Emphasis.

15. LongRunLowGLEmph – Long Run Low Gray Level Emphasis.

16. LongRunHighGLEmph – Long Run High Gray Level Emphasis.
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